Results 1 to 2 of 2

Thread: 10.04: X.org fails to start

  1. #1
    Join Date
    Dec 2013
    Beans
    3

    10.04: X.org fails to start

    My ubuntu 10.04 Lucid on a Barton+MX440 used to work fine. But one day I found it failed to start, with the following log generated. Could anyone tell me what is wrong with my X server?


    X.Org X Server 1.7.6
    Release Date: 2010-03-17
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.42-37-generic i686 Ubuntu
    Current Operating System: Linux athubuntu 2.6.32-53-generic-pae #115-Ubuntu SMP Wed Oct 23 17:44:16 UTC 2013 i686
    Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-53-generic-pae root=UUID=46b26ddf-d31c-471e-93e2-423f9f67cf53 ro ro
    Build Date: 11 April 2013 01:18:49PM
    xorg-server 2:1.7.6-2ubuntu7.12 (For technical support please see http://www.ubuntu.com/support)
    Current version of pixman: 0.16.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec 3 17:33:43 2013
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) Using config directory: "/usr/lib/X11/xorg.conf.d"
    (==) ServerLayout "Layout0"
    (**) |-->Screen "Screen0" (0)
    (**) | |-->Monitor "Monitor0"
    (**) | |-->Device "Device0"
    (**) |-->Input Device "Keyboard0"
    (**) |-->Input Device "Mouse0"
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
    Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    Entry deleted from font path.
    (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/100dpi,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
    (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    (WW) Disabling Keyboard0
    (WW) Disabling Mouse0
    (II) Loader magic: 0x81f1b20
    (II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
    (--) using VT number 7

    (--) PCI:*(0:2:0:0) 10de:0181:0000:0000 nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] rev 162, Mem @ 0xe0000000/16777216, 0xd8000000/134217728, BIOS @ 0x????????/131072
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/extra-modules/libglx.so
    (II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
    (II) NVIDIA GLX Module 96.43.17 Thu Apr 15 05:52:20 PDT 2010
    (II) Loading extension GLX
    (II) LoadModule: "record"
    (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "dri2"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    (II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (II) LoadModule: "nvidia"
    (II) Loading /usr/lib/xorg/extra-modules/nvidia_drv.so
    (II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
    (II) NVIDIA dlloader X Driver 96.43.17 Thu Apr 15 05:35:23 PDT 2010
    (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    (II) Primary Device is: PCI 02@00:00:0
    (II) Loading sub module "fb"
    (II) LoadModule: "fb"
    (II) Loading /usr/lib/xorg/modules/libfb.so
    (II) Module fb: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
    (II) Loading sub module "ramdac"
    (II) LoadModule: "ramdac"
    (II) Module "ramdac" already built-in
    (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
    (==) NVIDIA(0): RGB weight 888
    (==) NVIDIA(0): Default visual is TrueColor
    (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    (**) NVIDIA(0): Enabling RENDER acceleration
    (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
    (II) NVIDIA(0): enabled.
    (II) NVIDIA(0): NVIDIA GPU GeForce4 MX 440 with AGP8X at PCI:2:0:0 (GPU-0)
    (--) NVIDIA(0): Memory: 65536 kBytes
    (--) NVIDIA(0): VideoBIOS: 04.18.20.07.00
    (II) NVIDIA(0): Detected AGP rate: 8X
    (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    (--) NVIDIA(0): Connected display device(s) on GeForce4 MX 440 with AGP8X at
    (--) NVIDIA(0): PCI:2:0:0:
    (--) NVIDIA(0): Philips 150S (CRT-0)
    (--) NVIDIA(0): Philips 150S (CRT-0): 350.0 MHz maximum pixel clock
    (II) NVIDIA(0): Assigned Display Device: CRT-0
    (WW) NVIDIA(0): No valid modes for "1600x1200"; removing.
    (WW) NVIDIA(0): No valid modes for "1280x1024"; removing.
    (II) NVIDIA(0): Validated modes:
    (II) NVIDIA(0): "1024x768"
    (II) NVIDIA(0): "800x600"
    (II) NVIDIA(0): "640x480"
    (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
    (--) NVIDIA(0): DPI set to (86, 84); computed from "UseEdidDpi" X config
    (--) NVIDIA(0): option
    (--) Depth 24 pixmap format is 32 bpp
    (II) NVIDIA(0): Initialized GART.
    (II) NVIDIA(0): Setting mode "1024x768"
    (II) Loading extension NV-GLX
    (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
    (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
    (==) NVIDIA(0): Backing store disabled
    (==) NVIDIA(0): Silken mouse enabled
    (**) NVIDIA(0): DPMS enabled
    (II) Loading extension NV-CONTROL
    (==) RandR enabled
    (II) Initializing built-in extension Generic Event Extension
    (II) Initializing built-in extension SHAPE
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension BIG-REQUESTS
    (II) Initializing built-in extension SYNC
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-MISC
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing extension GLX
    (II) XKB: generating xkmfile /tmp/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
    (II) config/udev: Adding input device Power Button (/dev/input/event1)
    (**) Power Button: Applying InputClass "evdev keyboard catchall"
    (II) LoadModule: "evdev"
    (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    (II) Module evdev: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 2.3.2
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 7.0
    (**) Power Button: always reports core events
    (**) Power Button: Device: "/dev/input/event1"
    (II) Power Button: Found keys
    (II) Power Button: Configuring as keyboard
    (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "pc105"
    (**) Option "xkb_layout" "us"
    (**) Option "xkb_options" "lv3:ralt_switch"
    (II) XKB: generating xkmfile /tmp/server-0C76CA335E924C2441A31FBFED02D59A89874CA6.xkm
    (II) config/udev: Adding input device Power Button (/dev/input/event0)
    (**) Power Button: Applying InputClass "evdev keyboard catchall"
    (**) Power Button: always reports core events
    (**) Power Button: Device: "/dev/input/event0"
    (II) Power Button: Found keys
    (II) Power Button: Configuring as keyboard
    (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "pc105"
    (**) Option "xkb_layout" "us"
    (**) Option "xkb_options" "lv3:ralt_switch"
    (II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/event4)
    (**) Logitech USB Optical Mouse: Applying InputClass "evdev pointer catchall"
    (**) Logitech USB Optical Mouse: always reports core events
    (**) Logitech USB Optical Mouse: Device: "/dev/input/event4"
    (II) Logitech USB Optical Mouse: Found 12 mouse buttons
    (II) Logitech USB Optical Mouse: Found scroll wheel(s)
    (II) Logitech USB Optical Mouse: Found relative axes
    (II) Logitech USB Optical Mouse: Found x and y relative axes
    (II) Logitech USB Optical Mouse: Configuring as mouse
    (**) Logitech USB Optical Mouse: YAxisMapping: buttons 4 and 5
    (**) Logitech USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    (II) XINPUT: Adding extended input device "Logitech USB Optical Mouse" (type: MOUSE)
    (II) Logitech USB Optical Mouse: initialized for relative axes.
    (II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/mouse1)
    (II) No input driver/identifier specified (ignoring)
    (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)
    (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    (**) AT Translated Set 2 keyboard: always reports core events
    (**) AT Translated Set 2 keyboard: Device: "/dev/input/event3"
    (II) AT Translated Set 2 keyboard: Found keys
    (II) AT Translated Set 2 keyboard: Configuring as keyboard
    (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "pc105"
    (**) Option "xkb_layout" "us"
    (**) Option "xkb_options" "lv3:ralt_switch"
    (II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/event2)
    (**) Macintosh mouse button emulation: Applying InputClass "evdev pointer catchall"
    (**) Macintosh mouse button emulation: always reports core events
    (**) Macintosh mouse button emulation: Device: "/dev/input/event2"
    (II) Macintosh mouse button emulation: Found 3 mouse buttons
    (II) Macintosh mouse button emulation: Found relative axes
    (II) Macintosh mouse button emulation: Found x and y relative axes
    (II) Macintosh mouse button emulation: Configuring as mouse
    (**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
    (**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    (II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
    (II) Macintosh mouse button emulation: initialized for relative axes.
    (II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/mouse0)
    (II) No input driver/identifier specified (ignoring)
    (II) Power Button: Close
    (II) UnloadModule: "evdev"
    (II) Power Button: Close
    (II) UnloadModule: "evdev"
    (II) Logitech USB Optical Mouse: Close
    (II) UnloadModule: "evdev"
    (II) AT Translated Set 2 keyboard: Close
    (II) UnloadModule: "evdev"
    (II) Macintosh mouse button emulation: Close
    (II) UnloadModule: "evdev"
    ddxSigGiveUp: Closing log

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    10,480
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: 10.04: X.org fails to start

    Related but separate thread here:
    http://ubuntuforums.org/showthread.php?t=2191160
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •