Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Intel Centrino Advanced-N 6235 / Dell XPS 15

  1. #1
    Join Date
    Jul 2013
    Beans
    23

    Intel Centrino Advanced-N 6235 / Dell XPS 15

    Hi, I was recently given a Dell XPS 15 L521X as a holiday gift. Now that I have Ubuntu up and running (a project unto itself), I need help with the wifi. It is not good in either Windows 7 or in Ubuntu. My wireless card is an Intel Centrino Advanced-N 6235. The problem is that in order to get a connection, I have to be in the living room (the room where we keep the router). It doesn't work in any other room in the house. If I do manage to get connected in the other rooms, it just cuts out. I read that this model laptop often has wifi issues, but I haven't read about any fixes. Any advice would be greatly appreciated.
    Last edited by Rachel_Bunker; December 1st, 2013 at 12:11 AM. Reason: have to reopen

  2. #2
    Join Date
    Jan 2009
    Location
    Belgium (Ghent)
    Beans
    481
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    What about other WiFi cards?
    Maybe it is not the WiFi card but the router who is not strong enough.
    Dutch speaking; understand English, writing is a bit difficult. Member of: http://forum.ubuntu-nl.org
    be Open be Free be Ubuntu Reg. User #485479
    Ubuntu 13.10 Saucy Salamander - Ubuntu 14.04 Trusty Tahr

  3. #3
    Join Date
    Jul 2013
    Beans
    23

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    I don't think it is the router since 4 other laptops, 3 gaming consoles, 5 smartphones, a smart TV, and 2 tablets are connected to the router without any issues.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,545
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    I suggest you try the infamous trick for these devices. Please open a terminal and do:
    Code:
    sudo -i
    echo "options iwlwifi 11n_disable=1"  >>  /etc/modprobe.d/iwlwifi.conf
    exit
    Reboot and tell us if there is any improvement.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Jul 2013
    Beans
    23

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    It worked! Thank you so much!

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,545
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    Awesome! Glad it's working. Please mark the thread solved so the searchers will find it. https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Jan 2009
    Location
    Belgium (Ghent)
    Beans
    481
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    Quote Originally Posted by chili555 View Post
    I suggest you try the infamous trick for these devices. Please open a terminal and do:
    Code:
    sudo -i
    echo "options iwlwifi 11n_disable=1"  >>  /etc/modprobe.d/iwlwifi.conf
    exit
    Reboot and tell us if there is any improvement.
    It's very interesting to read it is solved.

    But, what does this command? Can you explain it a little bit. I think that there are more people with low speed wifi-connection who can benefit of this.
    Is it something to do with the channel 11 you disable? (what I can make out of it by seeing '11n' and 'disable')
    ThanX in advance!
    Last edited by heir4c; November 30th, 2013 at 06:48 PM.
    Dutch speaking; understand English, writing is a bit difficult. Member of: http://forum.ubuntu-nl.org
    be Open be Free be Ubuntu Reg. User #485479
    Ubuntu 13.10 Saucy Salamander - Ubuntu 14.04 Trusty Tahr

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,545
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    Quote Originally Posted by heir4c View Post
    It's very interesting to read it is solved.

    But, what does this command? Can you explain it a little bit. I think that there are more people with low speed wifi-connection who can benefit of this.
    Is it something to do with the channel 11 you disable? (what I can make out of it by seeing '11n' and 'disable')
    ThanX in advance!
    The driver iwlwifi has a problem with 802.11N as implemented by some router manufacturers. I suspect that there is a lot of finger-pointing going on ("No, my way is right and your way is wrong!"). The temporary solution is to use a driver parameter in iwlwifi to disable 802.11N capabilities.

    This is ONLY applicable to iwlwifi and another iwlxxx driver. If you are not using iwlwifi, this is not appropriate for you.

    From modinfo iwlwifi:
    Code:
    filename:       /lib/modules/3.11.0-13-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
    license:        GPL
    author:         Copyright(c) 2003-2013 Intel Corporation <ilw@linux.intel.com>
    version:        in-tree:
    description:    Intel(R) Wireless WiFi driver for Linux
    <snip>
    parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: agg TX, 4: agg RX (uint)
    For what it's worth, my Intel 6200 works perfectly at N speeds with a Linksys EA6300 router.

    Most people don't really care much about N speeds since they aren't streaming 4K video to watch on a laptop.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #9
    Join Date
    Jul 2013
    Beans
    23

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    I have to reopen this thread because it turns out that the problem is not solved after all. It worked once, but it didn't keep working, so now I'm back to the square one.

    Perhaps it was never really solved to begin with. It occurred to me that perhaps it makes a difference that the laptop connected to the router just fine in the living room and then I carried it (open) to my bedroom so it never disconnected.
    Last edited by Rachel_Bunker; December 1st, 2013 at 12:22 AM. Reason: Thought added

  10. #10
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,545
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Intel Centrino Advanced-N 6235 / Dell XPS 15

    Here are a few things you might try. First, let's set the regulatory domain explicitly. Sometimes, the driver assigns a one size (maybe) fits all CRDA. Let's set it for certain. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1 Then set it:
    Code:
    sudo iw reg set XX
    Where XX is your actual country code. For example, I would set:
    Code:
    sudo iw reg set US
    Does that help you connect? If so, we'll make it persistent.

    Second, the driver suite often connects and then drops if it doesn't hear a probe response from the router quickly. Let's extend the time:
    Code:
    sudo -i
    echo "options mac80211 probe_wait_ms=3000"  >>  /etc/modprobe.d/mac80211.conf
    exit
    Reboot. Any improvement?

    Next, is the behavior the same with the router set to other, less populous channels, like channels 1 or 11? My super-duper go-fast router has an Auto channel mode where it selects the best channel on the fly. If yours does the same, I suggest you try with and without Auto channel.

    Finally, if these steps don't help, please let us review your log after you tried and failed to connect:
    Code:
    cat /var/log/syslog | grep -e wlan -e iwl -e etwork | tail -n25
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •