Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: BCM4313 wireless chip driver

  1. #1
    Join Date
    Nov 2009
    Beans
    8

    Unhappy BCM4313 wireless chip driver

    hey guys:
    i still can't believe what happend!
    The other PCs or devices connected to WIFI will lose their connection once my PC connected to the same WIFI AP.
    I don't know why.
    But when i using WIN7 this wouldn't happend!(I have double OS, UBUNTU & WIN7)

    could some one help me? Thanks!

  2. #2
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: could someone help me? about BCM4313 wireless chip driver

    Welcome. Please tell us the release you are using and provide the output of these two commands from a terminal:

    Code:
    iwconfig
    sudo lshw -C network
    Also, let us know what you have done to alter network setup on your local machine, if anything, what you have tried to fix it, if anything, and a precise idea of the setup you have with the network. Thanks.

  3. #3
    Join Date
    Nov 2009
    Beans
    8

    Re: could someone help me? about BCM4313 wireless chip driver

    Thanks for your reply!
    13.04 & 12.04(64) has the same problem.

    bloceanc@bloceanc-ThinkPad:~/Downloads$ iwconfig
    lo no wireless extensions.

    eth1 IEEE 802.11abg ESSID:"happy"
    Mode:Managed Frequency:2.437 GHz Access Point: 14:E6:E4:6E:8A:84
    Retry long limit:7 RTS thrff Fragment thrff
    Power Managementff

    eth0 no wireless extensions.

    bloceanc@bloceanc-ThinkPad:~/Downloads$ sudo lshw -C network
    [sudo] password for bloceanc:
    *-network
    description: Wireless interface
    product: BCM4313 802.11b/g/n Wireless LAN Controller
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: eth1
    version: 01
    serial: 08:ed:b9:e2:1b:21
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) ip=192.168.1.104 latency=0 multicast=yes wireless=IEEE 802.11abg
    resources: irq:17 memory:cdd00000-cdd03fff
    *-network
    description: Ethernet interface
    product: RTL8111/8168B PCI Express Gigabit Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:0c:00.0
    logical name: eth0
    version: 07
    serial: b8:88:e3:30:8f:b4
    size: 10Mbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
    resources: irq:43 ioport:2000(size=256) memory:cc404000-cc404fff memory:cc400000-cc403fff
    bloceanc@bloceanc-ThinkPad:~/Downloads$
    bloceanc@bloceanc-ThinkPad:~/Downloads$
    bloceanc@bloceanc-ThinkPad:~/Downloads$ arp
    Address HWtype HWaddress Flags Mask Iface
    192.168.1.1 ether 14:e6:e4:6e:8a:84 C eth1
    bloceanc@bloceanc-ThinkPad:~/Downloads$ ^C
    bloceanc@bloceanc-ThinkPad:~/Downloads$

    first i use 13.04 and download boot-repair, i found the problem.
    then i changed to 12.04(reinstall linux)! it has the same problem.

    nothing else has been done.

    thank again!

  4. #4
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: could someone help me? about BCM4313 wireless chip driver

    So you are now on 12.04? Let's stick to the one release to avoid confusion.

    I did notice one thing, although don't know if this would have anything to do with it.

    logical name: eth1

    The logical name for the wireless generally starts with 'wlan' not 'eth', as in 'logical name: wlan1' (or 0).

  5. #5
    Join Date
    Nov 2009
    Beans
    8

    Re: could someone help me? about BCM4313 wireless chip driver

    yes, i'm using 12.04 now.
    generally logical name starts with "wlan", but it changed to 'eth' after one reboot.
    It did nothing to do with my own connection. Ubuntu can access net but other PCs becoming slowly, very slowly with net.

  6. #6
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: could someone help me? about BCM4313 wireless chip driver

    Well, that is really peculiar. Is this noticable as soon as you switch on???

    Also, was it always like this or was it fine when it was wlan?

  7. #7
    Join Date
    Nov 2009
    Beans
    8

    Re: could someone help me? about BCM4313 wireless chip driver

    Well, that is really peculiar. Is this noticable as soon as you switch on??? No, it needs some seconds. after a while, some seconds. the accessing of other device with WIFI will become very slowly.Also, was it always like this or was it fine when it was wlan? It always like this even installing ubuntu with under WIFI connected!

  8. #8
    Join Date
    Nov 2009
    Beans
    8

    Re: could someone help me? about BCM4313 wireless chip driver

    I thougt it maybe can't work fun with my TP-Link(a home gateway router).but it works fun with my WIN7 in the same laptop!

  9. #9
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: could someone help me? about BCM4313 wireless chip driver

    So, you're saying the other machines disconnect or slow down, as you mentioned both? Is the speed in Ubuntu normal or does that slow and the other machines disconnect/slow down?

    When you are booted into Ubuntu please have a look at the network activity in System Monitor. Without Firefox or any other net activity, but connected to the net, does it show any activity? Also, does the same disconnect/slowness happen when you connect with a cable?

  10. #10
    Join Date
    Nov 2009
    Beans
    8

    Re: could someone help me? about BCM4313 wireless chip driver

    I tried without data transition, just connecting.it is no help.
    But, i did not test with cable, i will test it sometimes.
    I found someone had the same problem: http://askubuntu.com/questions/35711...ices-very-slow

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •