Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Samba has to be restarted on client reboot

  1. #11
    Join Date
    Jul 2013
    Beans
    8

    Re: Samba has to be restarted on client reboot

    Quote Originally Posted by bab1 View Post
    No shares listed. I guess you used the GUI to create the shares.
    I didn't realise that you needed to list shares on the client smb.conf? The server smb.conf is in the top post, if that is what you meant?

    Either way let's see what shows with this command
    Code:
    smbclient -L <SERVER_NAME>
    ...where <SERVER_NAME> is the name of your Samba server. You can use the IP address if you like.
    This gives me (with both name and IP):

    Code:
    session setup failed: NT_STATUS_LOGON_FAILURE
    Thanks for the help

  2. #12
    Join Date
    May 2008
    Location
    SoCal
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Samba has to be restarted on client reboot

    Quote Originally Posted by rathershocked View Post
    I didn't realise that you needed to list shares on the client smb.conf? The server smb.conf is in the top post, if that is what you meant?
    You DO NOT need to declare the shares on the client smb.conf. That was my oversight.


    This gives me:

    Code:
    session setup failed: NT_STATUS_LOGON_FAILURE
    Thanks for the help
    It looks like the Samba server does not know who you are. Do you have an Linux account on the Server? Does that Linux account also have a Samba user account (smbpasswd -a)?

    Edit: to show the accounts you use these commands
    Code:
    getent passwd <username>
    
    sudo pdbedit -L
    The first one is the Linux user. The second one is the listing of all Samba users.
    Last edited by bab1; November 21st, 2013 at 09:19 AM.
    -BAB1

  3. #13
    Join Date
    Jul 2013
    Beans
    8

    Re: Samba has to be restarted on client reboot

    Code:
    getent passwd matt
    
    matt:x:1000:1000:[real name],,,:/home/matt:/bin/bash
    
    
    sudo pdbedit -L
    
    matt:1000:[real name]
    Edit: More info..

    Checked on my netbook..the problem persists on there too (not sure why it worked before)..and is solved by the same process.

    Putting guest to 'yes' in smb.conf does absolutely nothing, still can't display that share without restarting smbd.
    Last edited by rathershocked; November 21st, 2013 at 01:00 PM.

  4. #14
    Join Date
    Dec 2009
    Beans
    5,368

    Re: Samba has to be restarted on client reboot

    *** I was hoping for some kind of anomaly in the smb.conf on the client but it appears to be the standard default.

    *** This is probably another rat hole since so far nothing explains why a restart of smbd on the server fixes everything but ....
    Do you have any content in /etc/samba/smbusers on the server?

    *** Restarting smbd wouldn't be the correct fix for this either but is there a duplication of ip addresses in this network?

    EDIT: Didn't see your edit:
    Putting guest to 'yes' in smb.conf does absolutely nothing, still can't display that share without restarting smbd.
    Well, in all likelihood you needed to restart smbd for the change to guest access to take affect so I'm not sure if that tells us anything - unless you also rebooted the client.
    Last edited by Morbius1; November 21st, 2013 at 04:10 PM.

  5. #15
    Join Date
    Jul 2013
    Beans
    8

    Re: Samba has to be restarted on client reboot

    Quote Originally Posted by Morbius1 View Post
    *** I was hoping for some kind of anomaly in the smb.conf on the client but it appears to be the standard default.

    *** This is probably another rat hole since so far nothing explains why a restart of smbd on the server fixes everything but ....
    Do you have any content in /etc/samba/smbusers on the server?

    *** Restarting smbd wouldn't be the correct fix for this either but is there a duplication of ip addresses in this network?

    EDIT: Didn't see your edit:

    Well, in all likelihood you needed to restart smbd for the change to guest access to take affect so I'm not sure if that tells us anything - unless you also rebooted the client.
    Hello!

    In the smbusers, it just says "matt=matt" when opened with nano, though given that it does the same thing when trying to access as guest, I'm not sure if that's where the problem lies...and yep, I rebooted the server then rebooted the client - every time I try something I do the same.

    I'm not sure how to test for duplication of IP addresses, sorry =/

    I'll try purging everything samba flavoured from my server and reinstalling, but I've kinda already tried that, so I'm not hopeful

    Anyway, I really appreciate the help from both of you, but I suspect I'm going to actually get off my lazy **** and learn more about how networking and samba work.

  6. #16
    Join Date
    May 2008
    Location
    SoCal
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Samba has to be restarted on client reboot

    Quote Originally Posted by rathershocked View Post
    Hello!

    In the smbusers, it just says "matt=matt" when opened with nano, though given that it does the same thing when trying to access as guest, I'm not sure if that's where the problem lies...and yep, I rebooted the server then rebooted the client - every time I try something I do the same.

    I'm not sure how to test for duplication of IP addresses, sorry =/

    I'll try purging everything samba flavoured from my server and reinstalling, but I've kinda already tried that, so I'm not hopeful

    Anyway, I really appreciate the help from both of you, but I suspect I'm going to actually get off my lazy **** and learn more about how networking and samba work.
    If you purge everything and start over, just install samba (not Samba4). No helper applications. The configuration is trivial once you understand how it works. Both @ Morbius1 and I understand and can help you. There are only 3 things to setup in a typical small LAN. These are the netbios name = and name resolve order = directives and the actual shares. The first 2 take care of the networking.

    What have you actually used to configure Samba? What have you modified other than the smb.conf file?
    -BAB1

  7. #17
    Join Date
    Dec 2009
    Beans
    5,368

    Re: Samba has to be restarted on client reboot

    I'm not sure how to test for duplication of IP addresses, sorry =/
    Just run one of the following commands on each Linux box:
    Code:
    nm-tool
    ifconfig
    The only time this is usually an issue is if you set a static ip address on a box and it fell within the range of ip addresses that the router is giving out via DHCP. Under those conditions it's possible that there could be 2 machines with the same ip address depending on the sequence of which machine was booted. If this was the problem restarting smbd would do nothing but I'm just trying to eliminate the usual suspects.

    *** If you are or already have reinstalled samba make sure you include samba-common since that's where smb.conf comes from.

    *** If you are starting from the beginning you could do the "netbios name" and "name resolve order" thing by adding to the [global] section of smb.conf the following lines - I would put them right under the workgroup line:
    Code:
    netbios name = bigmomma
    name resolve order = bcast host lmhosts wins
    I wouldn't get too hung up on the netbios thing at the beginning - in an all Linux or Linux / OSX network you can make it work with the whole netbios / name resolve process disabled if you wanted. I would do all experiments using the ip address of the server so as to eliminate any peripheral issues:
    Code:
    nautilus smb://192.168.0.100
    Last edited by Morbius1; November 22nd, 2013 at 03:18 PM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •