Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Lubuntu 13.10 Lost Intel 2200bg Wifi

  1. #1
    Join Date
    Nov 2008
    Beans
    61

    Lubuntu 13.10 Lost Intel 2200bg Wifi

    Hi folks,

    I recently upgraded from Lubuntu 12.10 to 13.10 on my HP NX6110 Laptop with a Intel Pro 2200BG wifi adapter. The wifi worked fine on 12.10.....at first it worked fine on 13.10 as well. This afternoon after running for a hour or so, the wifi adapter just quit working. I cannot figure out what happened to it, although the system still sees the adapter....I cannot enable it. If I put my old Lubuntu 12.10 cd back into the laptop and run the live cd, the wifi works just fine.

    So, hoping somebody has some ideas why the Intel 2200bg adapter is no longer working on 13.10????

    Thanks in advance.....

    Ken

  2. #2
    Join Date
    Nov 2013
    Beans
    12

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    I have exactly the same problem with lubuntu and the 2200BG. I posted here yesterday, but no-one has been able to offer any advice yet:
    http://ubuntuforums.org/showthread.php?t=2188725

    Makes me feel more confident that this is a software problem and not a hardware issue (my laptop is nearly 8 years old, but worked perfectly until I upgraded).

    Have you tried entering this and then rebooting:
    Code:
    sudo rfkill unblock all
    That worked for me in terms of getting the wi-fi working, but I then got freezes.

    Andrew

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,309
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    Would both of you please run and post:
    Code:
    rfkill list all
    dmesg | grep ipw
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #4
    Join Date
    Nov 2008
    Beans
    61

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    Here is the results for my sudo rfkill list and dmesg | grep ipw. I have tried the sudo rfkill unblock all...which causes the wifi light to start blinking, but am still not able to enable it in the connection window.


    kenneth@kenneth-HP-Compaq-nx6110-PC419AV:~$ sudo rfkill list
    [sudo] password for kenneth:
    0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    1: hp-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

    kenneth@kenneth-HP-Compaq-nx6110-PC419AV:~$ dmesg | grep ipw
    [ 12.980069] libipw: 802.11 data/management/control stack, git-1.1.13
    [ 12.980072] libipw: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
    [ 13.007222] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
    [ 13.007228] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    [ 13.146548] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    [ 13.365531] ipw2200: Radio Frequency Kill Switch is On:
    [ 13.370226] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)


    Then I tried to unblock all ..................


    kenneth@kenneth-HP-Compaq-nx6110-PC419AV:~$ sudo rfkill unblock all
    kenneth@kenneth-HP-Compaq-nx6110-PC419AV:~$ sudo rfkill list
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    kenneth@kenneth-HP-Compaq-nx6110-PC419AV:~$

    kenneth@kenneth-HP-Compaq-nx6110-PC419AV:~$ dmesg | grep ipw
    [ 12.980069] libipw: 802.11 data/management/control stack, git-1.1.13
    [ 12.980072] libipw: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
    [ 13.007222] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
    [ 13.007228] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    [ 13.146548] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    [ 13.365531] ipw2200: Radio Frequency Kill Switch is On:
    [ 13.370226] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
    kenneth@kenneth-HP-Compaq-nx6110-PC419AV:~$


    After the unblock all command, my wifi light flashes...still no way to enable the wifi adapter again. From the second dmesg | grep ipw, it almost appears like radio frequency kill switch is not being turned off????? Also...upon reboot, the rfkill list goes back to blocked again.

    Any ideas???? Still baffled how this worked for a day and then quit...........

    Ken

  5. #5
    Join Date
    Nov 2013
    Beans
    12

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    And here's mine:

    andrew@andrew-laptop:~$ rfkill list all
    0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    andrew@andrew-laptop:~$ dmesg | grep ipw
    [ 20.996940] libipw: 802.11 data/management/control stack, git-1.1.13
    [ 20.996945] libipw: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
    [ 20.999993] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
    [ 20.999997] ipw2200: Copyright(c) 2003-2006 Intel Corporation

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,309
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    Quote Originally Posted by Farfrae View Post
    And here's mine:
    Yours ought to work fine. Does it scan?
    Code:
    sudo iwlist eth1 scan
    If it scans, it ought to connect. Does Network Manager see networks? Does it try?

    My old 2200 was not capable of WPA and WPA2; is yours?
    Code:
    sudo iwlist eth1 auth
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Nov 2013
    Beans
    12

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    I'll also mention that mucking about with various options in ROM setup, I can occasionally get the wifi working, but everything locks up after a minute or two. The circumstances when it works and doesn't work don't seem to be consistent.

    With a wire in it from the modem, all is well and the computer behaves impeccably.

    Thanks for your help - and to Ken for my tagging along on this thread.

    Andrew

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,309
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    Quote Originally Posted by kjacobs View Post
    Here is the results for my sudo rfkill list and dmesg | grep ipw. I have tried the sudo rfkill unblock all...which causes the wifi light to start blinking, but am still not able to enable it in the connection window.



    After the unblock all command, my wifi light flashes...still no way to enable the wifi adapter again. From the second dmesg | grep ipw, it almost appears like radio frequency kill switch is not being turned off????? Also...upon reboot, the rfkill list goes back to blocked again.

    Any ideas???? Still baffled how this worked for a day and then quit...........

    Ken
    The dmesg is the same as before, see the timestamp?
    [ 13.365531] ipw2200: Radio Frequency Kill Switch is On:
    You just read the file again from the start, not forward from where you left off.

    Let's try a thing or two:
    Code:
    gksudo gedit /etc/rc.local
    Right above exit 0, add a new line:
    Code:
    rfkill unblock all
    Proofread, save and close gedit. Now do:
    Code:
    sudo rfkill unblock all
    sudo iwlist eth1 scan
    You don't have to post all the results, just tell me if you got results. If not, what was the message?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #9
    Join Date
    Nov 2013
    Beans
    12

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    At the moment the options Network Manager is not seeing anything to connect to. Not even an option to connect to Wifi but I booted with the wire in, so perhaps that's why.

    $ sudo iwlist eth1 scan


    eth1 Interface doesn't support scanning.

    $ sudo iwlist eth1 auth

    eth1 no authentication information.




    I'll reboot without the wire and see if that makes a difference.

  10. #10
    Join Date
    Nov 2013
    Beans
    12

    Re: Lubuntu 13.10 Lost Intel 2200bg Wifi

    No same as above without the wire. No recognition of wireless although my wireless light is lit on the hard button (it's a button rather than a switch - showing on).

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •