Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: PCMan as Root

  1. #1
    Join Date
    Aug 2006
    Location
    London, UK
    Beans
    Hidden!

    PCMan as Root

    I have pcman latest version working in Ubunutu.

    To run it as root they advise that I create a file in file-manager/actions (http://wiki.lxde.org/en/PCManFM#Run_as_root)

    I have created a file /home/robins/.local/share/file-manager/actions/root_pcman

    In it I have placed:

    Desktop Entry]
    Name = Open as Root
    Tooltip = Open the folder as root
    Icon = terminal
    Profiles = on_folder;

    [X-Action-Profile on_folder]
    Name = Open as Root
    MimeTypes = inode/directory;
    SelectionCount = 1
    Exec = gksudo pcmanfm %s

    I do not know what to do next to open PCMan as root as the instrucions seem to stop at that point.

    Could you please have a look at the reference above and suggest how I actually load PCMan as root.



    Robin

  2. #2
    Join Date
    Aug 2006
    Location
    London, UK
    Beans
    Hidden!

    Re: PCMan as Root

    Could someone please comment on my question because I do not understand how to proceed.

  3. #3
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: PCMan as Root

    Please do not bump your threads any more often than 24 hours. As you know, this is a world-wide community of volunteers who take time from our busy lives as we can.

    Please give the community time to respond.

  4. #4
    Join Date
    Aug 2006
    Location
    London, UK
    Beans
    Hidden!

    Re: PCMan as Root

    I have got a bit further by following the advice at

    http://www.howopensource.com/2012/10...-ubuntu-12-10/

    and so I put the launcher file into

    /home/robins/.local/share/applications

    and called the file pcman_root.desktop

    with its contents:
    [Desktop Entry]
    Name = pcman_root
    Tooltip = Open the folder as root
    Icon = terminal
    Profiles = on_folder;

    [X-Action-Profile on_folder]
    Name = Open as Root
    MimeTypes = inode/directory;
    SelectionCount = 1
    Exec = gksudo pcmanfm %s


    Searched for it in Unity and dragged it to the unity launcher and it did not work!!

    Any ideas what I need to change?

  5. #5
    Join Date
    May 2012
    Location
    UK
    Beans
    613

    Re: PCMan as Root

    ok you have got yourself into a little muddle. it seems all you wanted was to be able to open the file manager as root. you can either run the command gksudo pcmanfm or follow that guide as you did, from what i understand the guide is to provide an option in the tools menu or right-click menu in the file manager, to open as root.

    there is another way you can do this, and thats to copy the pcmanfm menu file from /usr/share/applications to /.local/share/applications. change the file name to "pcmanfm root" or something. then open the file in a text editor and edit the line starting Exec= to look like this: Exec=gksudo pcmanfm. actually changing the line starting Name= would probably be good too, check for other name lines which might apply to you, like for me there is default and en_GB line.

    now you should have 2 menu entries for the file manager, one being for root only.
    Last edited by black veils; November 20th, 2013 at 12:40 PM.

  6. #6
    Join Date
    Feb 2008
    Location
    ɹǝpun uʍop
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: PCMan as Root

    Why do you want to open it as root??? You want to be REAL careful doing that as you can cause SERIOUS breakage.

    If you want to access a folder that won't open any other way, open a terminal and 'gksudo pcmanfm'. That's it. Do what you need to do and then close the windows pronto. You can also access it via a terminal by using sudo.

    Opening any file browser as root is not a great idea unless there is no other way.

  7. #7
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,737
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: PCMan as Root

    Quote Originally Posted by Bucky Ball View Post
    Why do you want to open it as root??? You want to be REAL careful doing that as you can cause SERIOUS breakage. ...
    +1.
    All the same, PCManFM has the facility to open the current folder as root under Tools.
    de gustibus et coloribus non est disputandum -- Wiktionary

  8. #8
    Join Date
    Feb 2008
    Location
    ɹǝpun uʍop
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: PCMan as Root

    Quote Originally Posted by vasa1 View Post
    +1.
    All the same, PCManFM has the facility to open the current folder as root under Tools.
    You learn something everyday! So it does. Thanks for that tip.

  9. #9
    Join Date
    Aug 2006
    Location
    London, UK
    Beans
    Hidden!

    Re: PCMan as Root

    Actually the latest version on the pcman website does not have the root option any more. I am using that one not the one in our repository.

  10. #10
    Join Date
    Aug 2006
    Location
    London, UK
    Beans
    Hidden!

    Re: PCMan as Root

    Quote Originally Posted by black veils View Post
    ok you have got yourself into a little muddle. it seems all you wanted was to be able to open the file manager as root. you can either run the command gksudo pcmanfm or follow that guide as you did, from what i understand the guide is to provide an option in the tools menu or right-click menu in the file manager, to open as root.

    there is another way you can do this, and thats to copy the pcmanfm menu file from /usr/share/applications to /.local/share/applications. change the file name to "pcmanfm root" or something. then open the file in a text editor and edit the line starting Exec= to look like this: Exec=gksudo pcmanfm. actually changing the line starting Name= would probably be good too, check for other name lines which might apply to you, like for me there is default and en_GB line.

    now you should have 2 menu entries for the file manager, one being for root only.

    I have followed your second route leaving the previous version in the files. If I double click the version in .local/share/applications it opens and requests the admin password. However I am not seeing the file in the file manager. What more should I have done to get it there?

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •