Results 1 to 4 of 4

Thread: Copying large amounts of files across NTFS partitions may cause system 'lockup'

Threaded View

  1. #1
    Join Date
    Oct 2013
    Location
    europe
    Beans
    46
    Distro
    Lubuntu 14.04 Trusty Tahr

    Exclamation Copying large amounts of files across NTFS partitions may cause system 'lockup'

    Well, even though I feel that this cannot be a Lubuntu-only problem, I've tagged it as such for the time being.

    This problem will occur on my Lubuntu Saucy box when copying files - especially from one NTFS-formatted partition to another - via console commands as well as a GUI based file-manager (PcManFM, Nautilus, Dolphin...).
    It has even proved to be a reason for power-cycling the system, read the following ...

    ---------------------------------------------------------------------------------------------------
    ...test case...

    - Have a real HUGE amount of files ready, e. g. one whole 50 GB partition with preferably lots of small files
    (a full-blown, Windows 7 system partition with a huge registry and lots of stuff installed would be ideal)

    - Copy everything from A to B and wait.

    On my PC, the following will occur very frequently after about 80% is copied:

    - (When using GUI-based file manager) Dialog window will freeze at where it currently is
    - CPU load will go up to 100% and stay there
    - Sound playing (even a simple 'mplayer' in console) will stop ABRUPTLY
    - After about 2 minutes, you will get a kernel message that mount.ntfs has not responded for 120 seconds.
    - You cannot even login as root (!) on the emergency consoles anymore (e. g. CTRL-ALT-F2) since it doesn't even make it to the 'Password:' prompt
    - Alt-PrtSc-K does not work either [1] edit: solved: see footnote
    ---------------------------------------------------------------------------------------------------

    Does this sound familiar to anybody? No?

    Lastly, let me tell you that the standard answer in this case "your cabling is faulty", "some of your HDDs needs to be replaced" does *NOT* apply. I got sick and tired of the problem and did my "partition copy" task by firing up an old 6.X Knoppix CD, and yes, it worked flawlessly. A second one had 130 GB to be copied later, and still no problems.
    So this issue must have been introduced only recently...

    ----
    footnote:
    [1] Gee, turned out "emergency keys" Alt-PrtSc-K (and friends) were disabled in Lubuntu, and so was the whole keyboard control of the "Magic Keys"!! My, my...
    "Fix": (was 176). True root shell required. Does not work by 'sudoing'.
    Code:
    # echo 180 > /proc/sys/kernel/sysrq
    When counting the LSB as Bit 0, it turned out that Bit 2 was not set. Original bitmask was $B0, but it must be $B0 OR $4, which is $B4 (180).
    Wonder whoever got the idiotic idea of disabling this??
    If you want to get this change permanent: the value is stored in /etc/sysctl.d/10-magic-sysrq.conf
    I've instantly made that change, since I'm sure I will at least be more able to intervene next time it locks up.
    Last edited by syntaxerror74; November 14th, 2013 at 12:55 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •