Page 3 of 9 FirstFirst 12345 ... LastLast
Results 21 to 30 of 87

Thread: trouble with apt-get upgrade

  1. #21
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    5,996
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: trouble with apt-get upgrade

    slgtheindividual; Hi !

    In this case, no news is bad news. I have not given up, but I have not found a way to proceed.

    this is a process in learning
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  2. #22
    Join Date
    Jul 2013
    Location
    Wisconsin
    Beans
    1,177

    Re: trouble with apt-get upgrade

    Quote Originally Posted by slgtheindividual View Post
    Code:
    ~$ cat /etc/init/mountkernfs.sh.conf
    # mountkernfs.sh - compatibility job for sysvinit dependencies
    #
    # This job runs once virtual filesystems are mounted, to signal startpar
    # that other rcS jobs relying on the historic mountkernfs.sh interface can
    # continue.
    
    
    description    "Signal sysvinit that virtual filesystems are mounted"
    
    
    start on virtual-filesystems
    no, I'm not running a VM or doing anything VM related, just a normal ubuntu desktop 13.10 on my laptop (acer aspire e1-571) dual booting with windows 8 efi, had no problems since I got it until now.
    "Virtual" in this case doesn't mean a VM - it means the "virtual" local filesystem interface.
    And it's no surprise you can't find the running service - there isn't one.

    This particular script is a compatibility tail. Older processes like procps depend on mountkernfs running before they can start. All this file does is emit a signal at the right point in boot that those sysvinit scripts are listening for.

    You can emit the same signal two ways:
    1) by rebooting
    2) with the command sudo initctl emit mountkernfs
    3) or you can ignore mountkernfs completely and start procps directly with sudo service procps start

    So, if you're willing, try
    Code:
    sudo initctl emit mountkernfs
    sudo apt-get --configure -a
    or

    Code:
    sudo service procps start
    sudo apt-get --configure -a
    and see if one of those kickstarts the process.

  3. #23
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    5,996
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: trouble with apt-get upgrade

    @ ian-weisser; Thanks !

    See it is a process of learning... I learned something here !
    Interesting to see what does result .

    where there is a will there is a way
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  4. #24
    Join Date
    Apr 2010
    Beans
    156

    Re: trouble with apt-get upgrade

    Quote Originally Posted by ian-weisser View Post
    Code:
    sudo initctl emit mountkernfs
    sudo apt-get --configure -a
    or

    Code:
    sudo service procps start
    sudo apt-get --configure -a
    and see if one of those kickstarts the process.
    Ok thank you for these suggestions, I tried these but to no avail, my output is beow:

    Code:
    ~$ sudo initctl emit mountkernfs
    ~$ sudo apt-get --configure -a
    E: Command line option --configure is not understood
    and

    Code:
    ~$ sudo service procps start
    procps stop/waiting
    ~$ sudo apt-get --configure -a
    E: Command line option --configure is not understood

  5. #25
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    5,996
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: trouble with apt-get upgrade

    slgtheindividual; Hey:

    Try that command as :
    Code:
    sudo dpkg --configure -a
    see what results, and carry forth.

    we be try'n
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  6. #26
    Join Date
    Apr 2010
    Beans
    156

    Re: trouble with apt-get upgrade

    Ok still no luck I'm afraid:

    Code:
    ~$ sudo initctl emit mountkernfs
    ~$ sudo dpkg --configure -a
    Setting up procps (1:3.3.4-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: Service mountkernfs has to be enabled to start service procps
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing procps (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of udev:
     udev depends on procps; however:
      Package procps is not configured yet.
    
    
    dpkg: error processing udev (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     procps
     udev
    and

    Code:
    ~$ sudo service procps start
    procps stop/waiting
    ~$ sudo dpkg --configure -a
    Setting up procps (1:3.3.4-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: Service mountkernfs has to be enabled to start service procps
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing procps (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of udev:
     udev depends on procps; however:
      Package procps is not configured yet.
    
    
    dpkg: error processing udev (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     procps
     udev

  7. #27
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    5,996
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: trouble with apt-get upgrade

    slgtheindividual; & ian-weisser --

    I am still stuck on this. I see it as a corrupted header file - some where.
    update-rc.d: warning:
    //

    Looking for a good reason why mountkernfs is not set by default...seeking a means to determine the initiating script, and once more I am not making much headway. A failure on my part to understand what is going on with upstart (??).

    what we have here is a failure to communicate !
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  8. #28
    Join Date
    Jul 2013
    Location
    Wisconsin
    Beans
    1,177

    Re: trouble with apt-get upgrade

    Hmmm.
    Does the same error occur after a reboot?

  9. #29
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    5,996
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: trouble with apt-get upgrade

    Ian, Hello;

    I am still mystified that "mountkernfs" will not start, even manually:
    ~$ sudo initctl emit mountkernfs
    ~$ sudo dpkg --configure -a
    Setting up procps (1:3.3.4-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: Service mountkernfs has to be enabled to start service procps
    Now from "cat /etc/init/mountkernfs.sh.conf" -which appears to be valid
    there is:
    start on virtual-filesystems
    Can we imply that "mountkernfs will not start so long as "virtual-filesystems" is not started ?

    and what is this relationship ?
    update-rc.d: error: insserv rejected the script header
    Which brings me back to the original question ... "What script header" ?? As it does not appear to be "mountkernfs.sh.conf" -> "/etc/insserv.conf" and I do not see a relationship there to either "mountkernfs" or "procps".

    as around and round I go
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  10. #30
    Join Date
    Jul 2013
    Location
    Wisconsin
    Beans
    1,177

    Re: trouble with apt-get upgrade

    start on virtual-filesystems
    When init hears the virtual-filesystems signal (offhand, I don't know which .conf sends it),
    then it starts the mountkernfs service. Your assumption that A must run for B to run is usually correct.

    Setting up procps (1:3.3.4-2) ...
    Hang on, that's a not-current version of procps.
    Consider deleting it from the package cache ( sudo apt-get clean procps ) and redownloading ( sudo apt-get update && sudo apt-get upgrade )

    Code:
    $ rmadison -u ubuntu procps
    [...]
        procps | 1:3.3.3-2ubuntu9 | saucy-updates | source, amd64, arm64, armhf, i386, powerpc
    [...]

Page 3 of 9 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •