Page 1 of 9 123 ... LastLast
Results 1 to 10 of 87

Thread: trouble with apt-get upgrade

  1. #1
    Join Date
    Apr 2010
    Beans
    156

    trouble with apt-get upgrade

    Hi, I'm having problems when trying to run apt-get upgrade

    Code:
    $sudo apt-get upgrade;
    
    
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be upgraded:
      gir1.2-gtk-3.0 google-chrome-stable hud indicator-appmenu initramfs-tools initramfs-tools-bin kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools libavcodec53
      libavformat53 libavutil51 libgail-3-0 libgnome-media-profiles-3.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libhud-client2 libido3-0.1-0 libkcmutils4
      libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4
      libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4 libkpty4 libkrosscore4 libktexteditor4
      libkunitconversion4 liblxc0 libnepomuk4 libnepomukquery4a libnepomukutils4 libplasma3 libpostproc52 libsolid4 libswscale2 libthreadweaver4 lxc lxc-templates
      python3-lxc shim-signed
    59 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    Need to get 67.6 MB of archives.
    After this operation, 9,352 kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://dl.google.com/linux/chrome/deb/ stable/main google-chrome-stable amd64 31.0.1650.48-1 [48.7 MB]
    Get:2 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libavutil51 amd64 6:0.8.9-0ubuntu0.13.10.1 [56.3 kB]
    Get:3 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libavcodec53 amd64 6:0.8.9-0ubuntu0.13.10.1 [2,321 kB]
    Get:4 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libavformat53 amd64 6:0.8.9-0ubuntu0.13.10.1 [434 kB]
    Get:5 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libgtk-3-common all 3.8.6-0ubuntu2 [155 kB]
    Get:6 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libgail-3-0 amd64 3.8.6-0ubuntu2 [20.2 kB]
    Get:7 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libgtk-3-0 amd64 3.8.6-0ubuntu2 [1,850 kB]
    Get:8 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libhud-client2 amd64 13.10.1+13.10.20131031-0ubuntu1 [34.7 kB]
    Get:9 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libido3-0.1-0 amd64 13.10.0+13.10.20131031-0ubuntu1 [58.3 kB]
    Get:10 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main lxc-templates all 1.0.0~alpha1-0ubuntu13 [41.6 kB]
    Get:11 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main python3-lxc amd64 1.0.0~alpha1-0ubuntu13 [18.2 kB]
    Get:12 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main liblxc0 amd64 1.0.0~alpha1-0ubuntu13 [137 kB]
    Get:13 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main lxc amd64 1.0.0~alpha1-0ubuntu13 [140 kB]
    Get:14 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libpostproc52 amd64 6:0.8.9-0ubuntu0.13.10.1 [35.9 kB]
    Get:15 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libswscale2 amd64 6:0.8.9-0ubuntu0.13.10.1 [76.6 kB]
    Get:16 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main initramfs-tools-bin amd64 0.103ubuntu1.1 [9,872 B]
    Get:17 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main initramfs-tools all 0.103ubuntu1.1 [49.1 kB]
    Get:18 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main gir1.2-gtk-3.0 amd64 3.8.6-0ubuntu2 [169 kB]
    Get:19 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main hud amd64 13.10.1+13.10.20131031-0ubuntu1 [166 kB]
    Get:20 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main indicator-appmenu amd64 13.01.0+13.10.20131031-0ubuntu1 [29.5 kB]
    Get:21 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libknotifyconfig4 amd64 4:4.11.2-0ubuntu2.1 [39.4 kB]
    Get:22 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libplasma3 amd64 4:4.11.2-0ubuntu2.1 [885 kB]
    Get:23 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libknewstuff3-4 amd64 4:4.11.2-0ubuntu2.1 [151 kB]
    Get:24 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libknewstuff2-4 amd64 4:4.11.2-0ubuntu2.1 [132 kB]
    Get:25 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkunitconversion4 amd64 4:4.11.2-0ubuntu2.1 [81.5 kB]
    Get:26 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/universe kdelibs5-plugins amd64 4:4.11.2-0ubuntu2.1 [925 kB]
    Get:27 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkhtml5 amd64 4:4.11.2-0ubuntu2.1 [1,918 kB]
    Get:28 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libktexteditor4 amd64 4:4.11.2-0ubuntu2.1 [96.2 kB]
    Get:29 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkprintutils4 amd64 4:4.11.2-0ubuntu2.1 [27.9 kB]
    Get:30 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkmediaplayer4 amd64 4:4.11.2-0ubuntu2.1 [29.2 kB]
    Get:31 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkdewebkit5 amd64 4:4.11.2-0ubuntu2.1 [61.8 kB]
    Get:32 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkde3support4 amd64 4:4.11.2-0ubuntu2.1 [295 kB]
    Get:33 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkparts4 amd64 4:4.11.2-0ubuntu2.1 [118 kB]
    Get:34 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkfile4 amd64 4:4.11.2-0ubuntu2.1 [215 kB]                                                            
    Get:35 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkemoticons4 amd64 4:4.11.2-0ubuntu2.1 [41.4 kB]                                                      
    Get:36 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main kdoctools amd64 4:4.11.2-0ubuntu2.1 [172 kB]                                                            
    Get:37 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main kdelibs-bin amd64 4:4.11.2-0ubuntu2.1 [199 kB]                                                          
    Get:38 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkio5 amd64 4:4.11.2-0ubuntu2.1 [826 kB]                                                              
    Get:39 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libsolid4 amd64 4:4.11.2-0ubuntu2.1 [265 kB]                                                            
    Get:40 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libnepomukutils4 amd64 4:4.11.2-0ubuntu2.1 [85.4 kB]                                                    
    Get:41 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libnepomukquery4a amd64 4:4.11.2-0ubuntu2.1 [107 kB]                                                    
    Get:42 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libnepomuk4 amd64 4:4.11.2-0ubuntu2.1 [203 kB]                                                          
    Get:43 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkjsembed4 amd64 4:4.11.2-0ubuntu2.1 [303 kB]                                                         
    Get:44 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkjsapi4 amd64 4:4.11.2-0ubuntu2.1 [257 kB]                                                           
    Get:45 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkrosscore4 amd64 4:4.11.2-0ubuntu2.1 [55.7 kB]                                                       
    Get:46 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkidletime4 amd64 4:4.11.2-0ubuntu2.1 [37.4 kB]                                                       
    Get:47 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkdnssd4 amd64 4:4.11.2-0ubuntu2.1 [66.1 kB]                                                          
    Get:48 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkdeclarative5 amd64 4:4.11.2-0ubuntu2.1 [38.5 kB]                                                    
    Get:49 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkcmutils4 amd64 4:4.11.2-0ubuntu2.1 [92.0 kB]                                                        
    Get:50 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkdeui5 amd64 4:4.11.2-0ubuntu2.1 [1,261 kB]                                                          
    Get:51 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libthreadweaver4 amd64 4:4.11.2-0ubuntu2.1 [46.7 kB]                                                    
    Get:52 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkdesu5 amd64 4:4.11.2-0ubuntu2.1 [50.9 kB]                                                           
    Get:53 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkpty4 amd64 4:4.11.2-0ubuntu2.1 [32.7 kB]                                                            
    Get:54 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkntlm4 amd64 4:4.11.2-0ubuntu2.1 [28.5 kB]                                                           
    Get:55 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libkdecore5 amd64 4:4.11.2-0ubuntu2.1 [899 kB]                                                          
    Get:56 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main kdelibs5-data all 4:4.11.2-0ubuntu2.1 [2,579 kB]                                                        
    Get:57 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/universe libgnome-media-profiles-3.0-0 amd64 3.0.0-1ubuntu2 [54.3 kB]                                        
    Get:58 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main libgtk-3-bin amd64 3.8.6-0ubuntu2 [18.2 kB]                                                             
    Get:59 http://gb.archive.ubuntu.com/ubuntu/ saucy-updates/main shim-signed amd64 1.5~13.10.1+0.4-0ubuntu4 [432 kB]                                                     
    Fetched 67.6 MB in 18s (3,636 kB/s)                                                                                                                                    
    Extract templates from packages: 100%
    Setting up procps (1:3.3.4-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: Service mountkernfs has to be enabled to start service procps
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing procps (--configure):
     subprocess installed post-installation script returned error exit status 1
    configured to not write apport reports
                                          dpkg: dependency problems prevent configuration of udev:
     udev depends on procps; however:
      Package procps is not configured yet.
    
    
    dpkg: error processing udev (--configure):
     dependency problems - leaving unconfigured
    configured to not write apport reports
                                          Errors were encountered while processing:
     procps
     udev
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    also

    Code:
    $ sudo dpkg --configure -a
    
    Setting up procps (1:3.3.4-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: Service mountkernfs has to be enabled to start service procps
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing procps (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of udev:
     udev depends on procps; however:
      Package procps is not configured yet.
    
    
    dpkg: error processing udev (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     procps
     udev
    Code:
    ~$ sudo apt-get -f install
    
    
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 59 not upgraded.
    2 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up procps (1:3.3.4-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: Service mountkernfs has to be enabled to start service procps
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing procps (--configure):
     subprocess installed post-installation script returned error exit status 1
    configured to not write apport reports
                                          dpkg: dependency problems prevent configuration of udev:
     udev depends on procps; however:
      Package procps is not configured yet.
    
    
    dpkg: error processing udev (--configure):
     dependency problems - leaving unconfigured
    configured to not write apport reports
                                          Errors were encountered while processing:
     procps
     udev
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Code:
    ~$ sudo apt-get dist-upgrade
    
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following packages will be upgraded:
      gir1.2-gtk-3.0 google-chrome-stable hud indicator-appmenu initramfs-tools initramfs-tools-bin kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools libavcodec53
      libavformat53 libavutil51 libgail-3-0 libgnome-media-profiles-3.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libhud-client2 libido3-0.1-0 libkcmutils4
      libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4
      libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4 libkpty4 libkrosscore4 libktexteditor4
      libkunitconversion4 liblxc0 libnepomuk4 libnepomukquery4a libnepomukutils4 libplasma3 libpostproc52 libsolid4 libswscale2 libthreadweaver4 lxc lxc-templates
      python3-lxc shim-signed
    59 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    Need to get 0 B/67.6 MB of archives.
    After this operation, 9,352 kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Extract templates from packages: 100%
    Setting up procps (1:3.3.4-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: Service mountkernfs has to be enabled to start service procps
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing procps (--configure):
     subprocess installed post-installation script returned error exit status 1
    configured to not write apport reports
                                          dpkg: dependency problems prevent configuration of udev:
     udev depends on procps; however:
      Package procps is not configured yet.
    
    
    dpkg: error processing udev (--configure):
     dependency problems - leaving unconfigured
    configured to not write apport reports
                                          Errors were encountered while processing:
     procps
     udev
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    I have no idea what the error codes mean, any help would be greatly appreciated

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    7,509
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: trouble with apt-get upgrade

    slgtheindividual; Hi !

    All the errors point back to "procps" not configured .
    Let's see what results when it is (re-)configured, and maybe get some more information.
    Post back - between code tags - the out put of Terminal codes:
    Code:
    dpkg -l procps
    sudo dpkg-reconfigure procps
    Maybe get an idea of what is not going on.

    inquiring minds want to know
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  3. #3
    Join Date
    Feb 2008
    Location
    In my skin.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: trouble with apt-get upgrade

    Just a note. ALWAYS run 'sudo apt-get update' prior to 'sudo apt-get upgrade'. Just in case you don't.

  4. #4
    Join Date
    Apr 2010
    Beans
    156

    Re: trouble with apt-get upgrade

    Thank you for the reply.
    Here is what I got for both:

    Code:
    ~$ dpkg -l procps
    
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name           Version      Architecture Description
    +++-==============-============-============-=================================
    iF  procps         1:3.3.4-2    amd64        /proc file system utilities
    Code:
    ~$ sudo dpkg-reconfigure procps
    
    /usr/sbin/dpkg-reconfigure: procps is broken or not fully installed.

    Ok, I always do, but thank you for the info, why is it that it should be that way? Thank you for any help you can give
    Last edited by slgtheindividual; November 14th, 2013 at 02:25 AM.

  5. #5
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    7,509
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: trouble with apt-get upgrade

    slgtheindividual; Hey .

    due to this notice:
    procps is broken or not fully installed.
    let's see what results when we do install it:
    Code:
    sudo apt-get install procps
    Looking to get additional information as to what is missing.

    As to why run "update" ..The package management system relies on numerous index and control files, amongst which are data bases on what is actually installed. In the "update" process these databases are compared with the databases residing on the mirror, and the databases on your system are updated to correspond to what is available and installable from that mirror.

    where there is cause there is effect
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  6. #6
    Join Date
    Apr 2010
    Beans
    156

    Re: trouble with apt-get upgrade

    ok I did that and got the following

    Code:
    ~$ sudo apt-get install procps
    
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    procps is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 61 not upgraded.
    2 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up procps (1:3.3.4-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    insserv: Service mountkernfs has to be enabled to start service procps
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing procps (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of udev:
     udev depends on procps; however:
      Package procps is not configured yet.
    
    
    dpkg: error processing udev (--configure):
     dependency problems - leaving unconfigured
    configured to not write apport reports
                                          configured to not write apport reports
                                                                                Errors were encountered while processing:
     procps
     udev
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ok cool thanx

  7. #7
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    7,509
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: trouble with apt-get upgrade

    slgtheindividual; Well !

    That was an exercise in futility . Did not tell us anything we did not know, and no closer to what is wrong.
    Punting:
    what returns from :
    Code:
    dpkg -l initscripts
    because we see:
    update-rc.d: error: insserv rejected the script header
    we be look'n
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  8. #8
    Join Date
    Apr 2010
    Beans
    156

    Re: trouble with apt-get upgrade

    that gives me the following:

    Code:
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name           Version      Architecture Description
    +++-==============-============-============-=================================
    ii  initscripts    2.88dsf-41ub amd64        scripts for initializing and shut
    also just to note, I don't know what any of this means, I'm not exactly an advanced user, but I really appreciate all of the help, thank you all

  9. #9
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    7,509
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: trouble with apt-get upgrade

    slgtheindividual; Hey,

    Presently I am a bit confused:
    <launchpad>
    Steve Langasek (vorlon) wrote on 2011-09-19: #3
    As discussed on IRC, all Ubuntu systems are supposed to have a /etc/init.d/.legacy-bootordering flag file telling update-rc.d (and /etc/init.d/rc) not to use insserv/startpar, which will fail terribly on Ubuntu.
    Is the file in question existent ?
    Code:
    ls -la /etc/init.d/.legacy-bootordering
    and what returns from this check:
    Code:
    /usr/share/insserv/check-initd-order
    In the process of fault isolation ->
    do not know where this leads
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  10. #10
    Join Date
    Apr 2010
    Beans
    156

    Re: trouble with apt-get upgrade

    ok so this is what I get:

    Code:
    ~$ ls -la /etc/init.d/.legacy-bootordering
    
    -rw-r--r-- 1 root root 0 Oct 16 19:59 /etc/init.d/.legacy-bootordering
    the second command returns nothing:
    Code:
    ~$ /usr/share/insserv/check-initd-order
    
    ~$

Page 1 of 9 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •