Results 1 to 1 of 1

Thread: network issue - can't configure eth0 with .24 address as gateway

  1. #1
    Join Date
    Nov 2013

    network issue - can't configure eth0 with .24 address as gateway

    I am configuring a server on my network. I have an IPv4 address block riding on top of a /30 block. My router has an address on the /30 block as the WAN interface, and .24/29 ( as the DMZ interface, per instructions from the network engineer, which in theory gives me .25-.29 as available addresses for servers.

    This configuration works fine in Windows Server. I add an ip address ( net mask ( and gateway ( and the network is up. In Ubuntu, when I assign the address and net mask, the OS assigns .24 as the network address of the IP block. If I manually assign .30 as the network address and .24 as the gateway, I can ping the .25 server, but everything else is cut off.

    I had a similar problem when changing routers. My current router running OpenWRT handles the .24 gateway fine, but the router I originally wanted to run (a Ubiquiti EdgeMax router) refused to work with .24/29 configured as the DMZ interface. On that router I had to use .30/29, and the gateway on the servers became, which worked OK when configured.

    Has anyone seen this problem before? I am not a networking guru and have no idea why different OS / network stacks would treat the same block differently.

    Any help is appreciated.


    EDIT: I just changed the DMZ interface to .30/29 and tried these settings for eth0 on my server:


    These settings did not work. This is a Supermicro server with Intel Gige nics, Ubuntu seems to recognize the nics fine but I am going to check the driver situation anyway.

    Incidentally, I had this same issue trying to run an Ubuntu VM on top of Windows Hyper-V on identical hardware.

    EDIT: Further investigation: the server is running Intel 82574L GigE NICs. An older thread: reports problems with the supplied driver for this chipset, and a solution using kernel ppa. I am going to check the advice from this thread, any suggestions otherwise are appreciated.

    EDIT: OK, so I typed
    route add default gateway
    ifconfig eth0

    and now the NIC is working. I want to make this change permanent, but these settings in /etc/network/interfaces does not seem to work from boot. Suggestions?
    Last edited by robert.d.munn; November 8th, 2013 at 03:37 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts