Results 1 to 7 of 7

Thread: PostFix problem SMTP

  1. #1
    Join Date
    Nov 2013
    Beans
    5

    PostFix problem SMTP

    Hi I'm new in the forum .... and sorry for my english I'm a french-canadien.

    I'm on ubuntu about a lot of time.... like 10years. But It's the first time I build a Mail server.
    All work good , but I got a message when I try to send a email by thunderbird on my PC. If I send a email using telnet or postfixadmin, that working.

    My error is :

    NOQUEUE: reject: RCPT from 69-165-196-215.cable.teksavvy.com[69.165.196.215]: 554 5.7.1 <giroux.oli@gmail.com>: Relay access denied; from=<ogiroux@infonuage.com .....

    So... This is my /etc/postfix/main.cf file

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    disable_vrfy_command = yes
    smtpd_helo_required = yes


    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_auth_only = no
    smtpd_use_tls = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    smtpd_recipient_limit = 100
    smtpd_helo_restrictions = reject_invalid_hostname
    smtpd_sender_restrictions = reject_unknown_address


    # appending .domain is the MUA's job.
    append_dot_mydomain = no


    myhostname = mail.infonuage.com
    myorigin = mail.infonuage.com
    mydestination =mailhost.infonuage.com, smtp.infonuage.com, imap.infonuage.com, mail.infonuage.com, localhost.mail.infonuage.com, localhost
    relayhost =
    mynetworks = 127.0.0.0/8, 184.170.128.38
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    mydomain=mail.infonuage.com




    virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf
    virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
    virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
    virtual_uid_maps = static:5000

    virtual_gid_maps = static:5000
    virtual_mailbox_base = /home/vmail


    #relay
    #smtpd_relay_restrictions =
    # permit_mynetworks,
    # permit_sasl_authenticated,
    # reject_unauth_destination,
    # reject_non_fqdn_recipient


    #adresses d'expedition
    smtpd_sender_restrictions =
    permit_mynetworks,
    permit_tls_clientcerts,
    permit_sasl_authenticated,
    warn_if_reject reject_unverified_sender


    #adresses de destination
    smtpd_recipient_restrictions=
    permit_mynetworks,
    permit_sasl_authenticated,
    permit_tls_clientcerts,
    reject_unauth_destination,
    reject_non_fqdn_recipient,
    reject_unknown_sender_domain,
    reject_non_fqdn_sender,
    reject_unknown_recipient_domain,
    reject_invalid_helo_hostname,
    reject_unlisted_recipient,
    reject_unlisted_sender,
    reject_non_fqdn_helo_hostname




    # client
    smtpd_client_restrictions =
    permit_mynetworks,
    permit_sasl_authenticated,
    permit_tls_clientcerts


    I'm using TLS security. Must need to pass to SSL ????

  2. #2
    Join Date
    Mar 2010
    Location
    Metro-ATL; PM free zone.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: PostFix problem SMTP

    teksavvy.com is rejecting your attempts to use them as an email relay. Get the settings and requirements to use them as a relay from them. Some ISPs do not allow relaying at all or they require an added service to be purchased. My ISP doesnt require anything other than being on a specific subnet with static IPs - in fact, they do not require relaying at all. Sorry, that means I cannot directly help solve that part of the issue.

    Unrelated, but probably NOT what you want
    Code:
    mydomain=mail.infonuage.com
    - probably incorrect
    should be
    Code:
    mydomain=infonuage.com
    I looked at your MX records ... seems odd to have 3 MX records all pointing to the same IP. Is that intentional?

    This link http://www.postfix.org/SMTPD_ACCESS_README.html seems to be around what you are asking. Hope it helps.
    Last edited by TheFu; November 3rd, 2013 at 02:31 PM.

  3. #3
    Join Date
    Nov 2013
    Beans
    5

    Re: PostFix problem SMTP

    Hi thank for your reply.

    Must need to pass in a SSL if I want to log whatever the place... ?

    I have write mai.infonuage.com in "mydomain=" option because infonuage.com pointing in to a other server....

    If a put my IP of my home , that working. I don't want to have my email just at my home....

    Sorry i'm a little noob with the mail server and DNS...

    Thank in advance....

  4. #4
    Join Date
    Mar 2010
    Location
    Metro-ATL; PM free zone.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: PostFix problem SMTP

    Quote Originally Posted by giroux.oli View Post
    Must need to pass in a SSL if I want to log whatever the place... ?
    What does the ISP say?

    Quote Originally Posted by giroux.oli View Post
    I have write mai.infonuage.com in "mydomain=" option because infonuage.com pointing in to a other server....
    This mydomain setting is for email and needs to match the MX record. The prior correction is 99.9999% correct.

    Quote Originally Posted by giroux.oli View Post
    If a put my IP of my home , that working. I don't want to have my email just at my home....
    I dont understand this. _put IP of home_ where? There are differences between sending and receiving email. These do not need to be on the same server at all. In my company, the sending email server is different from the receiving email server ... security considerations.

    Quote Originally Posted by giroux.oli View Post
    Sorry i'm a little noob with the mail server and DNS...
    We all were at some point. I still am when it comes to using a relay host that demands authenticated connections. Google found this: https://bbs.archlinux.org/viewtopic.php?id=165665

  5. #5
    Join Date
    Nov 2013
    Beans
    5

    Re: PostFix problem SMTP

    Finally ,

    The Post is solved.

    I fix the problem Just add 2 line in my main.cf file.

    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth

    with that postfix use the SSL authentification of Dovecot. Now I can connect, send and receive email everywhere.

    Thank You for your Help TheFu

  6. #6
    Join Date
    Nov 2013
    Beans
    5

    Re: PostFix problem SMTP (SOLVED)

    thank you

  7. #7
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    10,616
    Distro
    Lubuntu 15.04 Vivid Vervet

    Re: PostFix problem SMTP

    Please mark the thread 'solved' using 'thread tools'.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •