Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Gnome 13.10 Blank Screen when resume from suspend

  1. #1
    Join Date
    Jan 2010
    Location
    Texas
    Beans
    191
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Gnome 13.10 Blank Screen when resume from suspend

    I have been searching for a few days and and even thought my problem was related to a reported bug but it seems different.

    I apologized if this is reported already and I missed it.

    When I resume from suspend UbuntuGnome 13.10 x64 the screen is black and I cannot recover without power down.

    1. This is my home built desktop and I have Nvidia GT9800 video card and I have tried both Nouveau and proprietary Nvidia 3.19 driver which I used previous in Ubuntu 12.10 (not Gnome)
    2. My monitor is getting a signal on resume because it comes out of sleep mode. In fact it goes from the gray screen to solid black after resume.
    3. Ctrl+Alt+F1 does Not bring up a tty session. Going back to Ctrl+Alt+F7 does not help either.
    4. I tried changing Settings > Brightness & Lock to Never turn off screen but no help.
    5. During normal operation if I let the screen blank after 5 mins (not suspend) it works just fine.
    6. I have been using this desktop for many years and suspend with Ubuntu 11.x, 12.x (not Gnome) was no problem.

    I have Ubuntu Gnome 13.10 32 bit running on a laptop and it resumes fine although I am not sure that means much for this problem.

    My next step is to try Ubuntu 13.10 live usb key and see if I can suspend / resume. I will try the same version Gnome Ubuntu 13.10 on a live key and see what happens there as well.

    Any other ideas?

    Thanks in advance.

  2. #2
    Join Date
    Jan 2010
    Location
    Texas
    Beans
    191
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Gnome 13.10 Blank Screen when resume from suspend

    Update on my testing

    Desktop Computer with Nvidia GT9800 video card with Nouveau or Prorietary Nvidia Driver

    Ubuntu Gnome 13.10 x64 & 32bit = Fail to Resume
    Ubuntu 13.10 = Fail to Resume
    Xubuntu 13.10 = Fail to Resume

    Ubuntu 13.04 = Successfully Resumes
    Ubuntu 12.10 = Successfully Resumes
    Ubuntu 12.04 = Successfully Resumes

    very old Laptop Test Computer
    Ubuntu Gnome 13.10 = Successfully Resumes

    Netbook Computer
    Xubuntu 13.10 = Successfully Resumes

    I was thinking this was a Gnome problem somehow but that is not correct. I was willing to go to Xubuntu since I use it on my Netbook very successfully but that will not help.

    Conclusion is something is broken in any of the Ubuntu 13.10 versions I tried for my Desktop computer.

  3. #3
    Join Date
    Jan 2010
    Location
    Texas
    Beans
    191
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Gnome 13.10 Blank Screen when resume from suspend

    Spent a few more hours troubleshooting and I have spent way too much time on this problem already. I will wait to see if it is resolved in a later update. I am really enjoying Gnome Ubuntu 13.10 and this is the only item I have not been able to resolve.

    My work around is going to be Hibernate. I quit using Hibernate years ago since it was unreliable and really slow but after running some tests and getting it added to the menu it seems to work pretty well. My computer boots pretty fast any way so this is only a 2 minute delay.

  4. #4
    Join Date
    Jan 2010
    Location
    Texas
    Beans
    191
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Gnome 13.10 Blank Screen when resume from suspend

    Update on 2 more tests.

    Loaded updated Nvidia 319.60 driver in Ubuntu 13.10 but suspend / resume still fails

    Run live version of Gnome Ubuntu 13.04 Raring and suspend / resume works normally.

    So the video driver makes no difference in Ubuntu 13.10. This version has something else broken.

    Previous versions of Ubuntu 13.04, 12.10, 12.04 and 11.10 all work fine on the computer an video card.

    I have sent the crash report in.

  5. #5
    Join Date
    Jun 2008
    Location
    Delaware - USA
    Beans
    80
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Gnome 13.10 Blank Screen when resume from suspend

    Any word on this? I am having same issues.

    Never had a problem with any previous release. Updated to 13.10 and any time I close lid on laptop and re-open I have a black screen which is completely unresponsive to any input.

    I have to using "off" button to completely shut down my laptop and then restart after waiting a minute.

    Would love to hear some suggestions on how to fix this.

  6. #6
    Join Date
    Jan 2010
    Location
    Texas
    Beans
    191
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Gnome 13.10 Blank Screen when resume from suspend

    No progress at all for me. My older laptop that I tested does work fine but my desktop just will not work.

    I believe my old laptop is using Intel graphics instead of Nvidia though.

  7. #7
    Join Date
    Jun 2008
    Location
    Delaware - USA
    Beans
    80
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Gnome 13.10 Blank Screen when resume from suspend

    So here's what I think I've found.

    I upgraded from 13.04 to 13.10 through my wi-fi with the standard update kinda thing. After trying unsuccessfully to "fix" issue, I made a larger boo-boo and ended up doing a complete re-install from a live-cd I made.

    All my issues appear to be solved. (knocking on wood.....)

    I'd suggest trying a complete re-install from a current live-cd if you are still having issues.

  8. #8
    Join Date
    Jan 2010
    Location
    Texas
    Beans
    191
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Gnome 13.10 Blank Screen when resume from suspend

    Thanks but I did a complete fresh install to start with. I can run any 13.04 version of Ubuntu, Xubuntu, Gnome Ubuntu from a Live USB key and it will suspend / resume perfectly. If I run any 13.10 of the same flavors it fails. I have used every version of Nvidia driver available as well as the open source Nouveau and they all fail on 13.10. It is not the video driver and it is not my hardware which a has run perfectly on previous versions going back to 11.10.

  9. #9
    Join Date
    May 2011
    Beans
    3

    Re: Gnome 13.10 Blank Screen when resume from suspend

    Any news with this, I am also stuck with it not working despite trying various "fixes" I still get the black screen on resume

  10. #10
    Join Date
    Sep 2007
    Beans
    22

    Re: Gnome 13.10 Blank Screen when resume from suspend

    Yes, any news on this? I have a laptop with the same issue on a Toshiba Satellite S75-A7221.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •