Page 21 of 40 FirstFirst ... 11192021222331 ... LastLast
Results 201 to 210 of 395

Thread: GNOME Classic & Flashback sessions

  1. #201
    Join Date
    Oct 2010
    Location
    Niigata, JAPAN
    Beans
    828
    Distro
    Ubuntu Development Release

    Re: Trusty GNOME Classic & Flashback sessions

    Hi kansasnoob

    I've also living with this dirty workaround:

    1. Remove the gnome-panel entry within gome-session kicking sequence
    In /usr/share/gnome-session/sessions/gnome-flashback.session, Those components would be defined like this:
    Code:
    RequiredComponents=gnome-settings-daemon;gnome-screensaver;nautilus-classic;metacity;gnome-panel;
    So remove this red part to avoid kicking gnome-panel within session init.

    2. Add autostart desktop file for gnome-panel with some "Delay"
    Something like this named 'gnome-panel.desktop' in $HOME/.config/autostart/:
    Code:
    [Desktop Entry]
    Type=Application
    Exec=gnome-panel
    Hidden=false
    NoDisplay=false
    X-GNOME-Autostart-enabled=true
    X-GNOME-Autostart-Delay=2
    Name[en_US]=Gnome-Panel
    Name=Gnome-Panel
    Comment[en_US]=
    Comment=
    This could work for my flashback session...
    I suppose gnome-setting-daemon in trusty might need a bit more time to load their plugins, or indicators-applet would need some tricks to load into gnome-panel?

    Regards,
    Tista
    -- Lazulum Gtk3 theming PPA: "Lazulum" New clean gtk3 theme Project.

  2. #202
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,504
    Distro
    Ubuntu Development Release

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by kansasnoob View Post
    One of the Edubuntu devs posted a workaround for that desktop-loading-slowly bug:

    https://bugs.launchpad.net/ubuntu/+s...961/comments/8

    I gave it a try:

    Code:
    lance@lance-desktop:~$ sudo -i
    [sudo] password for lance: 
    root@lance-desktop:~#  echo '#!/bin/sh
    >  /usr/bin/gnome-panel &' > /usr/local/bin/gnome-panel
    root@lance-desktop:~#  chmod +x /usr/local/bin/gnome-panel
    root@lance-desktop:~#
    And it does work in a metacity session

    So hopefully that will help find a true fix
    Works in compiz session +1!
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  3. #203
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    6,775
    Distro
    Ubuntu Development Release

    Re: Trusty GNOME Classic & Flashback sessions

    Would somebody like to help this uneducated peasant and explain what those commands do?

    My first guess was that they create a script. But I could not see what was to be put in the script. My second guess, after a little research (including that Launchpad link), is that they change the permissions of a bin/executable file called gnome-panel. I am now guessing that the plus sign ( + ) in front of the x = execute sign causes a delay in the executing of gnome-panel.

    Oh, I do already know what the echo command does.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  4. #204
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,855
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Trusty GNOME Classic & Flashback sessions

    Create folder (it did not exist on my machine) (it is included in the PATH env.var. before /usr/bin so it is OK) and open file for editing
    Code:
    sudo mkdir /usr/local/bin
    sudo nano /usr/local/bin/gnome-panel
    Put into that file:
    Code:
    #!/bin/sh
    /usr/bin/gnome-panel &
    Make it executable
    Code:
    sudo chmod +x /usr/local/bin/gnome-panel
    All this makes easy get-back path:
    Code:
    sudo rm /usr/local/bin/gnome-panel
    with possible addition of erasing even folder if iw was not there before this operation...
    For the sake of security I will not give code for that erasure since (if it was there before and had some files) that could make certain problems to someone who does copy&paste blindly...
    Last edited by zika; December 23rd, 2013 at 05:17 PM.

  5. #205
    Join Date
    Apr 2008
    Beans
    10,651

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by grahammechanical View Post
    Would somebody like to help this uneducated peasant and explain what those commands do?

    My first guess was that they create a script. But I could not see what was to be put in the script. My second guess, after a little research (including that Launchpad link), is that they change the permissions of a bin/executable file called gnome-panel. I am now guessing that the plus sign ( + ) in front of the x = execute sign causes a delay in the executing of gnome-panel.

    Oh, I do already know what the echo command does.

    Regards.
    I really didn't bother trying to figure it out, I just considered the source:

    https://launchpad.net/~alkisg

    But if I blow up a test install I don't care a whole bunch

  6. #206
    Join Date
    Aug 2009
    Beans
    3,228
    Distro
    Ubuntu Development Release

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by kansasnoob View Post
    One of the Edubuntu devs posted a workaround for that desktop-loading-slowly bug:

    https://bugs.launchpad.net/ubuntu/+s...961/comments/8

    I gave it a try:

    Code:
    lance@lance-desktop:~$ sudo -i
    [sudo] password for lance: 
    root@lance-desktop:~#  echo '#!/bin/sh
    >  /usr/bin/gnome-panel &' > /usr/local/bin/gnome-panel
    root@lance-desktop:~#  chmod +x /usr/local/bin/gnome-panel
    root@lance-desktop:~#
    And it does work in a metacity session

    So hopefully that will help find a true fix
    +1 That worked great on my compiz session. I just logged out and back in and it worked.
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Ubuntu 12.04 | 14.04 | 14.10 | 14.10 Mate | Mint 13 | Mint 17 | Windows 7 | All 64 bit

  7. #207
    Join Date
    Apr 2008
    Beans
    10,651

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by zika View Post
    Create folder (it did not exist on my machine) (it is included in the PATH env.var. before /usr/bin so it is OK) and open file for editing
    Code:
    sudo mkdir /usr/local/bin
    sudo nano /usr/local/bin/gnome-panel
    Put into that file:
    Code:
    #!/bin/sh
    /usr/bin/gnome-panel &
    Make it executable
    Code:
    sudo chmod +x /usr/local/bin/gnome-panel
    All this makes easy get-back path:
    Code:
    sudo rm /usr/local/bin/gnome-panel
    with possible addition of erasing even folder if iw was not there before this operation...
    For the sake of security I will not give code for that erasure since (if it was there before and had some files) that could make certain problems to someone who does copy&paste blindly...
    Thanks for clarifying that

  8. #208
    Join Date
    Apr 2008
    Beans
    10,651

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by tista View Post
    Hi kansasnoob

    I've also living with this dirty workaround:

    1. Remove the gnome-panel entry within gome-session kicking sequence
    In /usr/share/gnome-session/sessions/gnome-flashback.session, Those components would be defined like this:
    Code:
    RequiredComponents=gnome-settings-daemon;gnome-screensaver;nautilus-classic;metacity;gnome-panel;
    So remove this red part to avoid kicking gnome-panel within session init.

    2. Add autostart desktop file for gnome-panel with some "Delay"
    Something like this named 'gnome-panel.desktop' in $HOME/.config/autostart/:
    Code:
    [Desktop Entry]
    Type=Application
    Exec=gnome-panel
    Hidden=false
    NoDisplay=false
    X-GNOME-Autostart-enabled=true
    X-GNOME-Autostart-Delay=2
    Name[en_US]=Gnome-Panel
    Name=Gnome-Panel
    Comment[en_US]=
    Comment=
    This could work for my flashback session...
    I suppose gnome-setting-daemon in trusty might need a bit more time to load their plugins, or indicators-applet would need some tricks to load into gnome-panel?

    Regards,
    Tista
    I'll try that soon on a fresh install.

  9. #209
    Join Date
    Apr 2008
    Beans
    10,651

    Re: Trusty GNOME Classic & Flashback sessions

    I've finally begun updating post #1 for the benefit of those new to Ubuntu +1, please let me know if you see any missing parts

  10. #210
    Join Date
    Apr 2008
    Beans
    10,651

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by zika View Post
    If You go with dconf-editor on that address You can choose from 3 different settings, or You can list that switch with the same tool as above.
    Referring to the scrollbar settings in dconf described here:

    http://ubuntuforums.org/showthread.p...3#post12850773

    Hmmm, one of three is obviously the default, and another is "normal", but what is the third?
    Last edited by kansasnoob; December 29th, 2013 at 07:56 PM.

Page 21 of 40 FirstFirst ... 11192021222331 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •