Page 19 of 40 FirstFirst ... 9171819202129 ... LastLast
Results 181 to 190 of 395

Thread: GNOME Classic & Flashback sessions

  1. #181
    Join Date
    Apr 2008
    Beans
    10,817

    Re: Trusty GNOME Classic & Flashback sessions

    Oh, both delete and add panel still work as expected in a metacity session.

  2. #182
    Join Date
    Apr 2008
    Beans
    10,817

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by PJs Ronin View Post
    I am trying to do this, I really am... but I'm having no luck at all getting Gnome-Compiz or Gnome-Metacity to play nice.
    I, for one, can't even do that. My top panel is blank and no amount CTRL-ALT left/right mouse on the panel does anything.

    I'm really forming the opinion that Gnome-dodo is just that.
    This won't make much sense right now so bear with me through a couple of edits

    The configurability of the "panels" is quite dependent on what session and window manager you're running.

    You can run this command to see what session you're running:

    Code:
    echo $DESKTOP_SESSION
    Or you can install 'wmctrl' and then run this command:

    Code:
    wmctrl -m
    For instance I'm currently running a flashback/metacity session so I get this output:

    Code:
    lance@lance-desktop:~$ sudo apt-get install wmctrl
    [sudo] password for lance: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      linux-headers-3.11.0-12 linux-headers-3.11.0-12-generic
      linux-headers-3.12.0-1 linux-headers-3.12.0-1-generic linux-headers-3.12.0-2
      linux-headers-3.12.0-2-generic linux-image-3.11.0-12-generic
      linux-image-3.12.0-1-generic linux-image-3.12.0-2-generic
      linux-image-extra-3.11.0-12-generic linux-image-extra-3.12.0-1-generic
      linux-image-extra-3.12.0-2-generic linux-image-extra-3.12.0-3-generic
    Use 'apt-get autoremove' to remove them.
    The following NEW packages will be installed:
      wmctrl
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 21.3 kB of archives.
    After this operation, 79.9 kB of additional disk space will be used.
    Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty/universe wmctrl i386 1.07-7 [21.3 kB]
    Fetched 21.3 kB in 0s (69.5 kB/s) 
    Selecting previously unselected package wmctrl.
    (Reading database ... 319957 files and directories currently installed.)
    Unpacking wmctrl (from .../wmctrl_1.07-7_i386.deb) ...
    Processing triggers for man-db ...
    Setting up wmctrl (1.07-7) ...
    lance@lance-desktop:~$ echo $DESKTOP_SESSION
    gnome-fallback
    lance@lance-desktop:~$ wmctrl -m
    Name: Metacity
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: N/A
    I'll follow up with more info later

    More info #1:

    As you seemed to imply nothing works in a flashback/compiz session right now as far as editing 'gnome-panel', but I've never focused on Compiz because I find it too "heavy" for most of my hardware anyway. OTOH I've found Metacity to run just as "light" as both Xfwm and Openbox in real-time with as little as an 1100Mhz CPU and 500MB of RAM, although 1GB of RAM is preferable for installation.

    Anyway, these are the outputs of those two commands in a Trusty flashback/compiz session:

    Code:
    lance@lance-desktop:~$ echo $DESKTOP_SESSION
    gnome-fallback-compiz
    lance@lance-desktop:~$ wmctrl -m
    Name: Compiz
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: OFF
    Last edited by kansasnoob; December 8th, 2013 at 10:02 AM.

  3. #183
    Join Date
    Apr 2008
    Beans
    10,817

    Re: Trusty GNOME Classic & Flashback sessions

    Thinking out loud again

    Why does the small team of Debian/Edubuntu devs interested in the flashback session need to even support a flashback/compiz session? Only Metacity would be needed to support LTSP installs

  4. #184
    Join Date
    Apr 2008
    Beans
    10,817

    Re: Trusty GNOME Classic & Flashback sessions

    Something odd and interesting, after trying a flashback/compiz session logging out and logging back into a metacity session seems to still display a compiz session for a minute and a half (maybe almost two minutes), so maybe the aforementioned bug has something to do with determining which session should be initiated

  5. #185
    Join Date
    Apr 2008
    Beans
    10,817

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by albertsmuktupavels View Post
    Why are you asking this? I think that you can freely subscribe to any mailing list you want. They are not restricted to devs only.



    Why Metacity? Have you tried to use mutter? If you have time you could install mutter to test it. Than from terminal run:
    Code:
    mutter --replace
    For me mutter session works, but I have no time to actively test it.
    This is mostly a reminder to myself

    I've not forgotten about trying Mutter but I've found Ubuntu GNOME Trusty to be incredibly unstable out-of-box ATM so I'm just waiting for their Alpha 1.

  6. #186
    Join Date
    Apr 2012
    Location
    Oz
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Trusty GNOME Classic & Flashback sessions

    Ok, not sure where all this is going, but here's my story. I rsync'd my saucy partition (has only unity with no xfce/ldx/gnome wizzbangery) into a new partition... then did an insitu upgrade of this new partition to trusty... I then saw a post explaining how to bring in the 'right' gnome so I did a sudo apt-get install gnome-session-flashback gdm... at the GDM login I now have 5 options, Ubuntu, Gnome with Compiz, Gnome with Metacity, Gnome and Default Session. Delete reference to that last option for the remainder of this post.

    So, I tried each method, took a screenie and applied the script mentioned above. Here are the results:

    Unity
    Code:
    wayne@trusty-gnome:~$ echo $DESKTOP_SESSION && echo "-------------------" && wmctrl -m 
    ubuntu
    -------------------
    Name: Compiz
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: OFF
    wayne@trusty-gnome:~$


    Gnome (Compiz) - top panel totally unresponsive
    Code:
    wayne@trusty-gnome:~$ echo $DESKTOP_SESSION && echo "-------------------" && wmctrl -m 
    gnome-fallback-compiz
    -------------------
    Name: Compiz
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: OFF
    wayne@trusty-gnome:~$


    Gnome (Metacity) - top panel totally unresponsive
    Code:
    wayne@trusty-gnome:~$ echo $DESKTOP_SESSION && echo "-------------------" && wmctrl -m
    gnome-fallback
    -------------------
    Name: Metacity
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: N/A
    wayne@trusty-gnome:~$


    Gnome - everything pretty much works
    Code:
    wayne@trusty-gnome:~$ echo $DESKTOP_SESSION && echo "-------------------" && wmctrl -m 
    gnome
    -------------------
    Name: GNOME Shell
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: N/A
    wayne@trusty-gnome:~$


    I really don't want to hijack this thread and would prefer you pursue your original thoughts. Just letting folks know that atm noobs like me are probably going to have problems with gnome-session-flashback installs.
    Last edited by PJs Ronin; December 8th, 2013 at 01:25 PM.

  7. #187
    Join Date
    Jan 2013
    Location
    Riga, Latvia
    Beans
    94
    Distro
    Ubuntu Development Release

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by PJs Ronin View Post
    Ok, not sure where all this is going, but here's my story. I rsync'd my saucy partition (has only unity with no xfce/ldx/gnome wizzbangery) into a new partition... then did an insitu upgrade of this new partition to trusty... I then saw a post explaining how to bring in the 'right' gnome so I did a sudo apt-get install gnome-session-flashback gdm... at the GDM login I now have 5 options, Ubuntu, Gnome with Compiz, Gnome with Metacity, Gnome and Default Session. Delete reference to that last option for the remainder of this post.

    So, I tried each method, took a screenie and applied the script mentioned above. Here are the results:

    Unity
    Code:
    wayne@trusty-gnome:~$ echo $DESKTOP_SESSION && echo "-------------------" && wmctrl -m 
    ubuntu
    -------------------
    Name: Compiz
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: OFF
    wayne@trusty-gnome:~$


    Gnome (Compiz) - top panel totally unresponsive
    Code:
    wayne@trusty-gnome:~$ echo $DESKTOP_SESSION && echo "-------------------" && wmctrl -m 
    gnome-fallback-compiz
    -------------------
    Name: Compiz
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: OFF
    wayne@trusty-gnome:~$
    to

    Gnome (Metacity) - top panel totally unresponsive
    Code:
    wayne@trusty-gnome:~$ echo $DESKTOP_SESSION && echo "-------------------" && wmctrl -m
    gnome-fallback
    -------------------
    Name: Metacity
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: N/A
    wayne@trusty-gnome:~$
    toto

    Gnome - everything pretty much works
    Code:
    wayne@trusty-gnome:~$ echo $DESKTOP_SESSION && echo "-------------------" && wmctrl -m 
    gnome
    -------------------
    Name: GNOME Shell
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: N/A
    wayne@trusty-gnome:~$


    I really don't want to hijack this thread and would prefer you pursue your original thoughts. Just letting folks know that atm noobs like me are probably going to have problems with gnome-session-flashback installs.
    Do you have installed indicator-applet-appmenu? If so uninstall it and try again compiz and/or metacity sessions.

    I know that at least on x64 indicator-applet-appmenu is broken causing all other applets to not show. If you can open system monitor, you can try kill that process to see if applets shows on top panel.

  8. #188
    Join Date
    Apr 2012
    Location
    Oz
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by albertsmuktupavels View Post
    Do you have installed indicator-applet-appmenu? If so uninstall it and try again compiz and/or metacity sessions.

    I know that at least on x64 indicator-applet-appmenu is broken causing all other applets to not show. If you can open system monitor, you can try kill that process to see if applets shows on top panel.
    Ty... I'll try that today.

  9. #189
    Join Date
    Apr 2012
    Location
    Oz
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Trusty GNOME Classic & Flashback sessions

    indicator-applet-appmenu was NOT installed. After I installed it there was no change to not being able to access the top panel in gnome-compiz, however in gnome-metacity I could now access the top panel... briefly. I managed to install the clock app before indicator-applet-appmenu crashed.

  10. #190
    Join Date
    Apr 2008
    Beans
    10,817

    Re: Trusty GNOME Classic & Flashback sessions

    Quote Originally Posted by PJs Ronin View Post
    indicator-applet-appmenu was NOT installed. After I installed it there was no change to not being able to access the top panel in gnome-compiz, however in gnome-metacity I could now access the top panel... briefly. I managed to install the clock app before indicator-applet-appmenu crashed.
    I also found it was not installed.

Page 19 of 40 FirstFirst ... 9171819202129 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •