Hi kansasnoob

I've also living with this dirty workaround:

1. Remove the gnome-panel entry within gome-session kicking sequence
In /usr/share/gnome-session/sessions/gnome-flashback.session, Those components would be defined like this:
Code:
RequiredComponents=gnome-settings-daemon;gnome-screensaver;nautilus-classic;metacity;gnome-panel;
So remove this red part to avoid kicking gnome-panel within session init.

2. Add autostart desktop file for gnome-panel with some "Delay"
Something like this named 'gnome-panel.desktop' in $HOME/.config/autostart/:
Code:
[Desktop Entry]
Type=Application
Exec=gnome-panel
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
X-GNOME-Autostart-Delay=2
Name[en_US]=Gnome-Panel
Name=Gnome-Panel
Comment[en_US]=
Comment=
This could work for my flashback session...
I suppose gnome-setting-daemon in trusty might need a bit more time to load their plugins, or indicators-applet would need some tricks to load into gnome-panel?

Regards,
Tista