Results 1 to 7 of 7

Thread: bluetooth problem in ubuntu 12.04

  1. #1
    Join Date
    Dec 2013
    Beans
    11

    bluetooth problem in ubuntu 12.04

    Hi guys,
    I recently installed windows 8.1 along with ubuntu 12.04 lts on my dell xps l502x machine. Since, the installation of windows 8.1, the control switch for bluetooth which was same for wifi doesn't work. I mean that now with Fn+F2, I can only toggle wifi and bluetooth always remains on. Also, after waking from suspend, bluetooth always turns on. Please can anyone give me a solution to fix this?

    Thanks

  2. #2
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: bluetooth problem in ubuntu 12.04

    We may try rfkill command to toggle it on/off.

    Please try -
    Code:
    rfkill block bluetooth
    If that doesn't help disabling it, please post back the output of -
    Code:
    rfkill list
    PS:
    Have you tried "blueman" yet? It gives better control over bluetooth adapter, and some controls that the default applet doesn't show.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  3. #3
    Join Date
    Dec 2013
    Beans
    121
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: bluetooth problem in ubuntu 12.04

    I have the same problem in Ubuntu 13.10 on Macbook air 5,1...

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: bluetooth problem in ubuntu 12.04

    Quote Originally Posted by zircon_34 View Post
    I have the same problem in Ubuntu 13.10 on Macbook air 5,1...
    Does any of the suggestions I gave in my previous post works for you? If not, please post the same output as I asked for in that post. Much better - post the details along with the outputs in a separate thread of your own in "Apple Users" section of the forums and give us its link here.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  5. #5
    Join Date
    Dec 2013
    Beans
    121
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: bluetooth problem in ubuntu 12.04

    It didn't work. Thats the output:

    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

    I tried the same with the sudo command before the rfkill, then the bluetooth was disabled. But when I open the bluetooth properties (right click) the button is on. So I typed "rfkill list" to check, and again bluetooth is on (soft blocked: no).

    The only way for me to disable it was to click on the bluetooth icon (on top right corner) and select bluetooth, and the icon disappears with bluetooth disabled.

    I found another thread that explains that this command has to be saved in a text file to be remembered at boot up. I might try this and will post a thread if it works. there are other similar problems like the screen brightness is always full per default at startup...
    Last edited by zircon_34; January 16th, 2014 at 06:20 AM.

  6. #6
    Join Date
    Dec 2013
    Beans
    11

    Re: bluetooth problem in ubuntu 12.04

    I tried blueman and it did give me much better control over bluetooth, but still not the exact thing i was looking for. My question is that why doesn't Fn+F2 control bluetooth anymore?

  7. #7
    Join Date
    Nov 2008
    Beans
    30

    Re: bluetooth problem in ubuntu 12.04

    Hi,

    I had the same problem. I blacklisted "acer_wmi" in /etc/modprobe.d/blacklist.conf. Next I added "ath3k" to /etc/modules. Now everything works again.

    Gr. Alexander

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •