Results 1 to 2 of 2

Thread: after ugrade grub problem

  1. #1
    Join Date
    Apr 2011
    Beans
    5

    after ugrade grub problem

    Hello

    I just upgraded my ubuntu and after the first restart its not booting up. Grub rescue console come up, with file not found error.
    I have 2 hdds in raid with encryption
    I tried to boot with live cd and run boot-repair, with the following results
    Code:
    =================== Recommended repair
    Recommended-Repair
    This setting will not act on the MBR.
    The boot flag will be placed on mapper/nvidia_bbaeffhf1.
    Additional repair will be performed:  repair-filesystems
    
    
    Force Unmount all blkid partitions (for fsck) except / /boot /cdrom /dev /etc /home /opt /pas /proc /rofs /sys /tmp /usr /var
    Disk /dev/mapper/nvidia_bbaeffhf1 doesn't contain a valid partition table
    fdisk: unable to read /dev/mapper/nvidia_bbaeffhf2: Inappropriate ioctl for device
    
    fsck -fyM /dev/mapper/nvidia_bbaeffhf1
    fsck from util-linux 2.20.1
    Disk /dev/mapper/nvidia_bbaeffhf1 doesn't contain a valid partition table
    fdisk: unable to read /dev/mapper/nvidia_bbaeffhf2: Inappropriate ioctl for device
    
    fsck -fyM /dev/mapper/nvidia_bbaeffhf5
    fsck from util-linux 2.20.1
    fsck: fsck.crypto_LUKS: not found
    fsck: error 2 while executing fsck.crypto_LUKS for /dev/mapper/nvidia_bbaeffhf5
    mount: unknown filesystem type 'crypto_LUKS'
    mount /dev/mapper/nvidia_bbaeffhf5 : Error code 32
    mount -r /dev/mapper/nvidia_bbaeffhf5 /mnt/boot-sav/mapper/nvidia_bbaeffhf5
    mount: unknown filesystem type 'crypto_LUKS'
    mount -r /dev/mapper/nvidia_bbaeffhf5 : Error code 32
    parted /dev/mapper/nvidia_bbaeffhf set 1 boot on
    
                                                                              
    Information: You may need to update /etc/fstab.
    
    Disk /dev/mapper/nvidia_bbaeffhf1 doesn't contain a valid partition table
    Disk /dev/mapper/nvidia_bbaeffhf5 doesn't contain a valid partition table
    
    Boot successfully repaired.
    
    You can now reboot your computer.
    Could someone help me, how to solve this problem ?

    thanks

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: after ugrade grub problem

    Boot-Repair is trying to run fsck as it cannot see encrypted partition and assumes it needs fsck. Can you mount and unencrypt it before running Boot-Repair or as part of running Boot-Repair?

    Is grub2 & kernels in separate /boot partition outside RAID and encryption or inside it?

    I do not know RAID nor encryption, so cannot help much.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •