Results 1 to 8 of 8

Thread: need help compiling a plug-in for xfce4

  1. #1
    Join Date
    Jul 2013
    Beans
    92

    need help compiling a plug-in for xfce4

    hi,
    I am trying to compile an app for xubuntu 12.04 with the xfce4 desktop 4.8.
    It is the weather plug-in app "xfce4-weather-plugin-0.8.3" ( also, I am beginner at compiling )
    The xfce4-weather-plugin I have now has a date of Nov 19, 2011 and it quit
    working out of the blue for some reason.

    I downloaded the app and extracted to a folder and when I go to compile using these commands:
    Code:
    ./configure; make; make install
    it seems to work ok until the very bottom and then I get these comments:
    Code:
    checking for gtk+-2.0 >= 2.14.0... not found
    *** The required package gtk+-2.0 was not found on your system.
    *** Please install gtk+-2.0 (atleast version 2.14.0) or adjust
    *** the PKG_CONFIG_PATH environment variable if you
    *** installed the package in a nonstandard prefix so that
    *** pkg-config is able to find it.
    make: *** No targets specified and no makefile found.  Stop.
    make: *** No rule to make target `install'.  Stop.
    I can't find a "gtk+-2.0" in synaptic.

    any help appreciated.

    also~ the original location of the app on my system is:
    Code:
    /usr/lib/x86_64-linux-gnu/xfce4/panel-plugins/xfce4-weather-plugin
    "xfce4-weather-plugin" being a "shared library"

  2. #2
    Join Date
    Jun 2011
    Location
    United Kingdom
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: need help compiling a plug-in for xfce4

    I believe you want the libgtk2.0-dev package:

    Code:
    sudo apt-get install libgtk2.0-dev
    Autoconf isn't always very useful for finding package names.

  3. #3
    Join Date
    Jul 2013
    Beans
    92

    Re: need help compiling a plug-in for xfce4

    I installed the libgtk2.0-dev and ran the compile again, and it keep asking me to install other packages,
    which I found in synaptic and I installed. But I got to this one :
    Code:
    checking for libxfce4panel-1.0 >= 4.7.0... not found
    *** The required package libxfce4panel-1.0 was not found on your system.
    *** Please install libxfce4panel-1.0 (atleast version 4.7.0) or adjust
    *** the PKG_CONFIG_PATH environment variable if you
    *** installed the package in a nonstandard prefix so that
    *** pkg-config is able to find it.
    make: *** No targets specified and no makefile found.  Stop.
    make: *** No rule to make target `install'.  Stop.
    and I couldn't find a "libxfce4panel" in synaptic.

  4. #4
    Join Date
    Jul 2013
    Beans
    92

    Re: need help compiling a plug-in for xfce4

    I found that I do have a /usr/lib/x86_64-linux-gnu/libxfce4panel-1.0.so.3.0.0
    and also a libxfce4panel-1.0.so.3 ( a link to libxfce4panel-1.0.so.3.0.0 ) in the
    same folder

    but I don't know how to set the PKG_CONFIG_PATH environment variable
    so that the compile can find them.

  5. #5
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: need help compiling a plug-in for xfce4

    I think that you are going to find that to meet the dependencies of the latest xfce4-weather-plugin for Xfce 4.8, you'll be looking at re-building most of the Xfce components. This in itself, is not a bad learning exercise (though frustrating and tedious). However, there is an easier way. You can install version 4.10 via PPA. This particular PPA comes not only with the 0.8.3 version of the weather plugin, but also with the 4.10 version of Xfce (win-win). More information about installing/using the PPA can be found here.

  6. #6
    Join Date
    Jul 2013
    Beans
    92

    Re: need help compiling a plug-in for xfce4

    thanks for reply Toz.
    I installed the PPA and got the new xfce4-weather-plugin to work, now I have 4.10
    I did notice that Google earth will not run. I had this problem some time back, maybe when I went from
    11.4 to 12.04, not sure.

  7. #7
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: need help compiling a plug-in for xfce4

    Quote Originally Posted by sam_baker2 View Post
    I did notice that Google earth will not run. I had this problem some time back, maybe when I went from
    11.4 to 12.04, not sure.
    If you enter:
    Code:
    google-earth
    ...into a terminal window, what responses do you get?

  8. #8
    Join Date
    Jul 2013
    Beans
    92

    Re: need help compiling a plug-in for xfce4

    it runs Toz!.
    Aparently there is some setting that needed me to run it
    in the terminal to get the settings back.
    Now it will run from the menu like it is supposed to.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •