Results 1 to 2 of 2

Thread: 12.04.3 - Reverse DNS issue - slow ping interval but normal ping value

  1. #1
    Join Date
    Oct 2013
    Beans
    1

    Question 12.04.3 - Reverse DNS issue - slow ping interval but normal ping value

    i'm running ubuntu 12.04.3 x86 desktop in my corporation environment. I join the corp domain by Likewise open. But when I ping another pc, say hostname is pc-test, "ping pc-test" or "ping pc-test.domain.name" returns slow interval (about 5 seconds) but the ping value is below 1 ms. When I use "ping -n pc-test", everything works well. So I conclude this is about reverse DNS issue.

    how to fix this issue? many thanks!

    In my understanding, reverse DNS issue is related to DNS server or Wins server, not only an ubuntu issue, is this right?

    if I wanna fix this issue as much as possible on ubuntu but not on network servers, what to do?

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,763
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: 12.04.3 - Reverse DNS issue - slow ping interval but normal ping value

    Actually it could be that your resolver is not appending the domain to "pc-test" to give a "fully-qualified domain name" like pc-test.yourdomain.name. Either this is a DHCP error, where the DNS search field is not being distributed from the network server or, less likely, an error in your local network client.

    First, see if "pc-test.yourdomain.name" works without a delay while "pc-test" does not. If so, edit the file /etc/dhcp/dhclient.conf as root with sudo. You'll need to make a couple of changes to this section of the file:
    Code:
    #send host-name "andare.fugue.com";
    send host-name = gethostname();
    #send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
    #send dhcp-lease-time 3600;
    #supersede domain-name "fugue.com home.vix.com";
    #prepend domain-name-servers 127.0.0.1;
    request subnet-mask, broadcast-address, time-offset, routers,
            domain-name, domain-name-servers, domain-search, host-name,
            dhcp6.name-servers, dhcp6.domain-search,
            netbios-name-servers, netbios-scope, interface-mtu,
            rfc3442-classless-static-routes, ntp-servers,
            dhcp6.fqdn, dhcp6.sntp-servers;
    #require subnet-mask, domain-name-servers;
    Remove the hash mark from "supersede domain-name" and replace it with "supersede yourdomain.name". I would also remove the "domain-search" parameter from the request list. Restart the network with "sudo service networking restart".

    If your machine could not resolve the name "pc-test.yourdomain.name" either, then you'll have to create static entries in /etc/hosts for machines you want to reach. Suppose that machine has address 10.10.10.10. Then you would edit /etc/hosts as root and add the line:

    Code:
    10.10.10.10     pc-test
    Another possibility is that Likewise doesn't actually provide the Unix DNS server information to your client, just its Netbios name that Windows uses. Take a look at your /etc/network/interfaces file and see what you have for the definition of eth0. If you have a static address, you can edit that file to provide the domain-search parameter like this:
    Code:
    auto eth0
    iface eth0 inet static
    address ...
    netmask ...
    gateway ...
    dns-search yourdomain.name
    and restart networking.
    Last edited by SeijiSensei; October 24th, 2013 at 03:07 PM.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •