Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Ubuntu 12.04 and RTL 8211CL not working

  1. #11
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 12.04 and RTL 8211CL not working

    The major difference is the kernel and respectively the driver version.

    Also, this may be significant -
    Quote Originally Posted by xcMseAD View Post
    lspci -nnk | grep -A3 0200
    This return nothing
    The lshw shows it is on a PCI bus -
    Quote Originally Posted by xcMseAD View Post
    lshw
    *-bridge
    description: Ethernet interface
    ....
    bus info: pci@0000:00:07.0
    [/INDENT]
    It also shows it is "bridged", but what is it bridged to? Does this motherboard have two onboard interfaces?

    Please check -
    Code:
    lspci -nnk | grep -iA3 net
    Does it show the ethernet interface?

    And I would strongly recommend to try a Live CD of 12.04.3 as it uses kernel 3.8, and hopefully, a much better driver.

    Alternatively, you may choose to upgrade the current installation to the latest kernel, along with latest supported hardware enablement stack. But trying 12.04.3 in live mode is a much safer option.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  2. #12
    Join Date
    Oct 2013
    Beans
    10

    Unhappy Re: Ubuntu 12.04 and RTL 8211CL not working

    Hi varunendra,

    I try what you said and nothing...

    sudo lspci -nnk | grep -iA3 net
    Code:
    00:07.0 Bridge [0680]: NVIDIA Corporation MCP61 Ethernet [10de:03ef] (rev a2)
        Subsystem: ASRock Incorporation 939NF6G-VSTA Board [1849:03ef]
        Kernel driver in use: forcedeth
        Kernel modules: forcedeth
    About live CD, I tested both versions 32b and 64b for 12.04.3 in live mode, and network problem didnt change.

    I bought this machine a month ago and I can't use it yet. Also there is another issue with power, it do not shutdown or restart by it self, I have to press the buttons for both actions.

    About motherbiard as far as I know it only has one interface.

    Anyway thanks again for your time and advice.
    Last edited by mstanger; November 5th, 2013 at 04:46 AM. Reason: More information added

  3. #13
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 12.04 and RTL 8211CL not working

    Quote Originally Posted by xcMseAD View Post
    Code:
    00:07.0 Bridge [0680]: NVIDIA Corporation MCP61 Ethernet [10de:03ef] (rev a2)
        Subsystem: ASRock Incorporation 939NF6G-VSTA Board [1849:03ef]
        Kernel driver in use: forcedeth
        Kernel modules: forcedeth
    ....
    About motherbiard as far as I know it only has one interface.
    Apparently, you added the "it only has one interface" part one day later, which now makes me even more confused.

    Its PCI bus address (0680) is strange for me and the mode "Bridged" is mysterious. The driver "forcedeth" is not very uncommon though, so you shouldn't be out of luck yet.

    Unfortunately, as late as I am replying to this (and that too after being reminded by PM..), I may get even busier for next few days. So I'm not sure when (and if) I'd be able to dig up and post something meaningful, I'm not very good with ethernet issues anyway.

    I don't have any experience with such 'bridged' interface, and am absolutely clueless at this point. Sooo.. I'm posting this just as a BUMP, and a CALL FOR HELP !! Anyone reading this post, please jump in if you have any ideas to share with us.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  4. #14
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,510
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Ubuntu 12.04 and RTL 8211CL not working

    Please check the module parameters:
    Code:
    echo "options forcedeth msi=0 msix=0" | sudo tee -a /etc/modprobe.d/forcedeth.conf
    Reboot and reset the BIOS to default. Check the outputs again

  5. #15
    Join Date
    Oct 2013
    Beans
    10

    Re: Ubuntu 12.04 and RTL 8211CL not working

    Hi praseodym, thanks for reply!!!..

    Well I was a bit busy this days, but finally I did try your advice..., the first thing is that forcedeth.conf wasnt created yet, I run your command and did a BIOS reset...

    Not connection yet... now, what are the outputs that I need to recheck???

    Many thanks in advance.

  6. #16
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,510
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Ubuntu 12.04 and RTL 8211CL not working

    Lets have a look at
    Code:
    lsmod
    ifconfig -a
    cat /etc/resolv.conf
    cat /etc/network/interfaces
    route -n
    dmesg | egrep 'eth|force'
    cat /var/lib/NetworkManager/NetworkManager.state
    cat /etc/NetworkManager/NetworkManager.conf

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •