Results 1 to 2 of 2

Thread: Macbook pro 9,1

  1. #1
    Join Date
    Oct 2013
    Beans
    2

    Macbook pro 9,1

    HI to all.
    I have a macbook pro 9,1 (my job machine) with kubuntu 12.10 installed in.
    I want upgrade this to 13.10 or make a new installation, but if I try live distribution i don't see external screen.
    My question is: if I setup kubuntu 13.10 on my machine in EFI mode or not can I see extern monitor.

    My external monitory is connected with display port to VGA.

    Thanks for help!
    Last edited by Yol4o; October 23rd, 2013 at 10:26 AM.

  2. #2
    Join Date
    Oct 2013
    Beans
    2

    Re: Macbook pro 9,1

    Ok, I answer myself!
    For install kubuntu 13.10 with esternal screen that work, than with displayport to VGA do:

    1) Use rEFInd ( http://www.rodsbooks.com/refind/installing.html )

    2) Normal installation and select "device for boot loader installation" how the partition where you decide of install it!

    2.5) If the installation end with error with "not install grub-efi-amd64... there is not a loader ecc... ecc..." don't worry, if you set rEFInd for scan for linux drive (for this read all "Installing rEFInd Using install.sh under Linux or Mac OS X" at http://www.rodsbooks.com/refind/installing.html)

    3) For see external monitor and use NVIDIA driver do:

    3.1) If you have had error "grub-efi-amd64" resolve dependence remove grub-pc or run "sudo aptitude" (sudo apt-get install aptitude) to see for what depends on the error and fix it

    3.2) Converting Ubuntu into EFI mode ( https://help.ubuntu.com/community/UE..._into_EFI_mode )

    3.2.1) sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
    3.2.2) sudo apt-get install -y boot-repair && boot-repair

    3.2.3) Click on “Advanced options”, go to the “GRUB location” tab.
    3.2.4) Make sure that “Separate /boot/efi partition” is checked, then click the “Apply” button, and follow the directions (you’ll be asked to remove and reinstall GRUB)
    3.2.5) Reboot. You’ll probably haedit /etc/default/grub and add “i915.lvds_channel_mode=2 i915.modeset=0 i915.lvds_use_ssc=0″ to GRUB_CMDLINE_LINUX_DEFAULT inside the double-quotes between the words “quiet splash“. ve several new options in rEFIt, select any of them to boot up

    4) Install Nvidia Driver (that help to see external screen! )
    4.1) sudo apt-get install linux-headers-`uname -r`
    4.2) sudo apt-get install nvidia-current
    4.3) sudo nvidia-xconfig
    4.4) edit /etc/X11/xorg.conf and add to the Device section: Option "UseDPLib" "off"
    4.5) edit /etc/default/grub and add "i915.lvds_channel_mode=2 i915.modeset=0 i915.lvds_use_ssc=0" to GRUB_CMDLINE_LINUX_DEFAULT inside the double-quotes between the words “quiet splash“, the result is:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet i915.lvds_channel_mode=2 i915.modeset=0 i915.lvds_use_ssc=0 splash"

    4.6) sudo update-grub


    This is all!

    Thanks to and sources of information:

    *) http://cberner.com/2013/03/01/instal...ok-pro-retina/
    *) https://help.ubuntu.com/community/UE..._into_EFI_mode

    Sorry for my English

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •