Results 1 to 4 of 4

Thread: JACK not working in Ubuntu Studio (HELP!)

  1. #1
    Join Date
    Jan 2011
    Beans
    5

    JACK not working in Ubuntu Studio (HELP!)

    I can't figure this one out. I have Ubuntu Studio 12.4 on a couple other computers and Jack works just dandy. I can not for the life of me make it work on my desktop. Here's the errors I'm running into:
    15:30:48.180 Patchbay deactivated.

    15:30:48.205 Statistics reset.
    15:30:48.218 ALSA connection change.
    15:30:48.226 D-BUS: Service is available (org.jackaudio.service aka jackdbus).
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server socket
    jack server is not running or cannot be started
    15:30:48.243 ALSA connection graph change.

    15:30:51.435 D-BUS: JACK server could not be started. Sorry
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server socket
    jack server is not running or cannot be started
    Sun Oct 20 15:30:51 2013: Starting jack server...
    Sun Oct 20 15:30:51 2013: JACK server starting in realtime mode with priority 10
    Sun Oct 20 15:30:51 2013: control device hw:0
    Sun Oct 20 15:30:51 2013: control device hw:0
    Sun Oct 20 15:30:51 2013: [1m[31mERROR: Failed to acquire device name : Audio0 error : Cannot allocate memory[0m
    Sun Oct 20 15:30:51 2013: [1m[31mERROR: Audio device hw:0 cannot be acquired...[0m
    Sun Oct 20 15:30:51 2013: [1m[31mERROR: Cannot initialize driver[0m
    Sun Oct 20 15:30:51 2013: [1m[31mERROR: JackServer::Open() failed with -1[0m
    Sun Oct 20 15:30:51 2013: [1m[31mERROR: Failed to open server[0m
    Sun Oct 20 15:30:52 2013: Saving settings to "/home/dann/.config/jack/conf.xml" ...

    15:30:53.508 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server socket

    jack server is not running or cannot be started
    Default settings, or tweaking everything- it always yields the same result. It also pops up with "D-BUS: JACK Server could not be started Sorry" and "Could not connect to JACK Server as client, -Overall operation failed -Unable to connect to server"

    I'm using a USB sound card (which is installed properly and gives me no issues when using anything else). Said soundcard works perfectly on my laptop running the same OS and configuration (however it won't run in KXStudio(?). But I'm unable to get JACK running when using my onboard Soundcard or anything other changes you can think of.

    I did some Googling (for days...) trying to figure this out. A lot of people have run into this problem. Most people's stems from pulseaudio, however turning off pulseaudio entirely (and even removing it completely) doesn't help.

    Oddly enough, I CAN get JACK running in KXStudio with Claudia, but NOT with my USB Soundcard. The USB Soundcard isn't the biggest deal. I'd be happy to have JACK running AT ALL in my Ubuntu install. But I know for a fact that Ubuntu Studio 12.4 can run JACK with this soundcard as it gives me no issues at all on my laptop.

    I'm tearing my hair out here. I've been working on this around a week now. I've installed Ubuntu a few dozen times in different ways trying to make this work. Can anyone help? At this point I'd even be willing to pay someone to make this work.

  2. #2
    Join Date
    May 2013
    Location
    Hamunaptra
    Beans
    622
    Distro
    Ubuntu Studio

    Re: JACK not working in Ubuntu Studio (HELP!)

    Have you tried changing the Interface in Jack Settings ? It is currently hw:0, are there any dropdown options? Please try them if there are any.

    All I can point out are some help pages which have worked for me:

    This link should help you: https://help.ubuntu.com/community/UbuntuStudio/ProAudioIntro#UbuntuStudio.2BAC8-ProAudioIntro.2BAC8-1204.Starting_Jack

    https://help.ubuntu.com/community/Ho...KConfiguration

    http://www.64studio.com/quickstart_jack

    http://jackaudio.org/faq
    Last edited by su:bhatta; October 21st, 2013 at 12:59 PM.
    bhatta

    May the Source be with you !
    Ash nazg durbatulūk, ash nazg gimbatul, ash nazg thrakatulūk, agh
    'Buntu-ishi krimpatul !

  3. #3
    Join Date
    Nov 2013
    Beans
    11

    Re: JACK not working in Ubuntu Studio (HELP!)

    Don't forget to add your username to the "audio"group, In terminal type sudo usermod -a -G audio username (where username is your log-in name)

    and check to make sure that /etc/security/limits.d/audio.conf. isn't /etc/security/limits.d/audio.conf.disabled
    if so simply rename it w/out the disabled part. (in your file manager press ctrl+h to show hidden files)

    For more info have a lookk at: https://help.ubuntu.com/community/Ub...dioPreparation
    Last edited by fred-lorrain; November 3rd, 2013 at 02:48 PM.

  4. #4
    Join Date
    May 2013
    Location
    Hamunaptra
    Beans
    622
    Distro
    Ubuntu Studio

    Re: JACK not working in Ubuntu Studio (HELP!)

    Quote Originally Posted by fred-lorrain View Post
    Don't forget to add your username to the "audio"group, In terminal type sudo usermod -a -G audio username (where username is your log-in name)

    and check to make sure that /etc/security/limits.d/audio.conf. isn't /etc/security/limits.d/audio.conf.disabled
    if so simply rename it w/out the disabled part. (in your file manager press ctrl+h to show hidden files)

    For more info have a lookk at: https://help.ubuntu.com/community/Ub...dioPreparation
    Hi fred-lorrain,

    With an Ubuntu Studio installation you don't have to add user to the audio group, both user addition & audio.conf is enabled by default.

    That guide is for installing Ubuntu Studio packages on top of an standard Ubuntu installation, as mentioned in the first line of the page.

    The OP uses Ubuntu Studio 12.04. so those might not be the issue.
    bhatta

    May the Source be with you !
    Ash nazg durbatulūk, ash nazg gimbatul, ash nazg thrakatulūk, agh
    'Buntu-ishi krimpatul !

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •