Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Problem with ATI Radeon HD Mobility 5145

  1. #1
    Join Date
    Oct 2013
    Beans
    8

    Problem with ATI Radeon HD Mobility 5145

    I have an Asus K52JB and my video card is ATI Radeon Mobility 5145. Just for some information i read here : http://ubuntuforums.org/showthread.php?t=1678044 that the card is based on the 4500 series.

    So if i just don't install nothing, in "System Details">"Details" it tells me that my graphics are "Gallium 0.4 on AMD RV710".

    I've tried to install fglrx drivers and AMD site drivers too but always gives me some problem.

    On ubuntu 13.04 and 13.10 if i install these drivers, when i reboot the resolution is very bad and my unity and side bar doesnt show ( tried to reset unity, didn't work).

    So i moved on to ubuntu 12.04, since it is a LTS and is older, maybe it could work. It didn't. When i reboot, my unity and side bar shows, but my resolution is very low and on options there's no option to an higher resolution.

    With the default "Gallium 0.4 on AMD RV710" i tried glxgears. It gives me 60fps. I don't know if it is good or no.

    Thanks in advance,

    Edgar.
    Last edited by MEkXhkM; November 6th, 2013 at 12:27 AM.

  2. #2
    Join Date
    Oct 2013
    Beans
    8

    Re: Problem with ATI Radeon HD Mobility 5145

    Please, any help is welcome.

    When i do "lspci | grep VGA" it shows me "VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4530/4570/545v]"

  3. #3
    Join Date
    Jun 2007
    Beans
    11,061

    Re: Problem with ATI Radeon HD Mobility 5145

    You can't install fglrx on anything newer than 12.04.1, nor do you need to.

    With the default "Gallium 0.4 on AMD RV710" i tried glxgears. It gives me 60fps. I don't know if it is good or no.
    glxgears is not a benchmark. 60fps = 60Hz monitor (because video is synced to avoid tearing).

  4. #4
    Join Date
    Oct 2013
    Beans
    8

    Re: Problem with ATI Radeon HD Mobility 5145

    Quote Originally Posted by Temüjin View Post
    You can't install fglrx on anything newer than 12.04.1, nor do you need to.


    glxgears is not a benchmark. 60fps = 60Hz monitor (because video is synced to avoid tearing).
    So i don't need to install anything? I mean, my graphics are good, i don't have lag or anything. Tried a few games, so good so far. I am just intrigued for showing "gallium" instead of my graphic card.

  5. #5
    Join Date
    Jun 2007
    Beans
    11,061

    Re: Problem with ATI Radeon HD Mobility 5145

    So i don't need to install anything?
    There's nothing to install. The legacy proprietary driver doesn't support modern versions of Ubuntu.

    I am just intrigued for showing "gallium" instead of my graphic card.
    Don't worry about it. I see the exact same thing on my RadeonHD 4550. Gallium3D is the name of the open-source 3D driver infrastructure. RV710 is the ATI codename of your card's chip.

  6. #6
    Join Date
    Oct 2013
    Beans
    8

    Re: Problem with ATI Radeon HD Mobility 5145

    Ok, thank you for your help !

  7. #7
    Join Date
    Oct 2013
    Beans
    8

    Re: Problem with ATI Radeon HD Mobility 5145

    Maybe i found the solution.

    In this website: http://wiki.cchtml.com/index.php/Hardware they say : "ATI/AMD initially dropped Catalyst support for these cards in the regular Catalyst 12-6. These cards are now supported with the later released Catalyst 13-1 legacy, but you MUST use a kernel <= 3.4 and Xserver <= 1.12. For example, you can use Catalyst 13-1 legacy if you're running Ubuntu 12.04 or Debian Squeeze/6.0. Open source support is good and 3D is still improving."

    So if i downgrade kernel to 3.4 and Xserver to 1.12 and install catalyst 13.1 i'll be able to get my graphic cards properly.

    It is possible to do downgrade? I'm on ubuntu 13.10. The only thing that is stopping me to totally migrate to ubuntu is this graphic issue.

    Or should i just downgrade to ubuntu 12.04 as they say?
    Last edited by MEkXhkM; November 5th, 2013 at 08:09 PM.

  8. #8
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Problem with ATI Radeon HD Mobility 5145

    Hello!

    I would highly recommend against using that method!

    What you will end up with is effectively a broken installation, you may have trouble upgrading in the future, you may end up with package dependency issues and it is just a lot of work to go through when the open source Radeon driver has improved so much in the last year or two.

    If you really want to use the ATI driver, then use a version of Ubuntu no later than 12.04.1 -- which is supported until 2017 -- with the legacy driver.
    Last edited by QIII; November 5th, 2013 at 08:42 PM.

  9. #9
    Join Date
    Oct 2013
    Beans
    8

    Re: Problem with ATI Radeon HD Mobility 5145

    Quote Originally Posted by QIII View Post
    Hello!

    I would highly recommend against using that method!

    What you will end up with is effectively a broken installation, you may have trouble upgrading in the future, you may end up with package dependency issues and it is just a lot of work to go through when the open source Radeon driver has improved so much in the last year or two.

    If you really want to use the ATI driver, then use a version of Ubuntu no later than 12.04.1 -- which is supported until 2017 -- with the legacy driver.
    Thank you for your advice Yeah, the open source driver is quite good, but is not good enough to run, for example, L4d2.

    I'm taking your advice and installing 12.04.1 or earlier. I know that ubuntu 12.04 has kernel 3.2 but what about Xserver? It can't be more than 1.12. I've google it, but found nothing.

  10. #10
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Problem with ATI Radeon HD Mobility 5145

    You're good with 12.04.1. Just don't try 12.04.2. That's where X Server and the kernel will refuse to cooperate with you.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •