Results 1 to 6 of 6

Thread: Can't install Wine 1.7.4 from PPA

  1. #1
    Join Date
    Mar 2006
    Beans
    13

    Can't install Wine 1.7.4 from PPA

    Hi,

    Is anyone else having problems installing Wine 1.7.4 from the PPA? Every time I try to install on 64 bit Quantal I get the following error:

    The following packages have unmet dependencies.
    wine1.7 : Depends: wine1.7-amd64 (= 1.7.4-0ubuntu4) but it is not going to be installed
    Depends: wine1.7-i386 (= 1.7.4-0ubuntu4)
    E: Unable to correct problems, you have held broken packages.

    The wine1.7-i386 package it's complaining about is not shown in Synaptic. Any help would be much appreciated!

  2. #2
    Join Date
    Oct 2011
    Location
    London, UK
    Beans
    41
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Can't install Wine 1.7.4 from PPA

    Im having this problem as well. tried all the usual permutations of apt-get with no success.

    The following packages have unmet dependencies.
    wine1.7 : Depends: wine1.7-amd64 (= 1.7.4-0ubuntu4~saucy1) but it is not going to be installed
    Depends: wine1.7-i386 (= 1.7.4-0ubuntu4~saucy1)
    E: Unable to correct problems, you have held broken packages.

  3. #3
    Join Date
    Jul 2013
    Location
    Wisconsin
    Beans
    1,186

    Re: Can't install Wine 1.7.4 from PPA

    You should notify the PPA maintainer.
    PPAs are not community-supported software. They are only supported by the PPA maintainer.

  4. #4
    Join Date
    Oct 2011
    Location
    London, UK
    Beans
    41
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Can't install Wine 1.7.4 from PPA

    I spoke to the maintainer. The solution was the following for me

    sudo apt-get install wine1.7-i386
    followed by
    sudo apt-get install wine1.7

    i am now up and running. all is well.

  5. #5
    Join Date
    Nov 2013
    Beans
    1

    Re: Can't install Wine 1.7.4 from PPA

    Quote Originally Posted by father_ted View Post
    I spoke to the maintainer. The solution was the following for me

    sudo apt-get install wine1.7-i386
    followed by
    sudo apt-get install wine1.7

    i am now up and running. all is well.
    That has not worked for me :/.

    The following packages have unmet dependencies: wine1.7 : Depends: wine1.7-i386 (= 1.7.4-0ubuntu4~saucy1) but it is not installable
    Recommends: fonts-droid but it is not going to be installed
    Recommends: ttf-mscorefonts-installer but it is not installable
    Recommends: fonts-horai-umefont but it is not going to be installed
    Recommends: fonts-unfonts-core but it is not going to be installed
    Recommends: winbind but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    Although the apt-get install wine1.7, I'm running in a chroot within uck.
    I gather that:
    "Depends: wine1.7-i386 (= 1.7.4-0ubuntu4 ~ saucy1) but it is not installable"
    , is due to the architecture. Then it occurred to me to add the i386 architecture with dpkg --add-architecture i386

    dpkg --add-architecture i386 && apt-get update && apt-get install wine1.7

    , and that works for me (~200mb 32 bits libs deps )

  6. #6
    Join Date
    Apr 2014
    Beans
    1

    Re: Can't install Wine 1.7.4 from PPA

    I tried to run
    sudo apt-get install wine1.7-i386
    but got this message

    ubuntu@ubuntu:~$ sudo apt-get install wine1.7-i386
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package wine1.7-i386 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source


    E: Package 'wine1.7-i386' has no installation candidate
    ubuntu@ubuntu:~$

    help!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •