Results 1 to 9 of 9

Thread: Kernels failing to install as of yesterday

  1. #1
    Join Date
    Mar 2014
    Beans
    2

    Kernels failing to install as of yesterday

    Here is the pastebin of my terminal output: http://pastebin.com/CfUc3ymr

    This install of Ubuntu 14.04 dev was made about a week ago. I don't have any ppa's providing alternative kernels or other major package changes.

    Would anyone know how to fix this issue?

    Thanks.

  2. #2
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Kernels failing to install as of yesterday

    Code:
    sudo apt-get update
    sudo apt-get install -f
    sudo apt-get dist-upgrade
    Be carefull when answering to the question for the last command...

  3. #3
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Kernels failing to install as of yesterday

    Not sure why this should cause an error -
    Code:
    /usr/sbin/grub-mkconfig: 11: /etc/default/grub: i915.i915_enable_rc6=1: not found
    ..but try removing that entry from you /etc/default/grub file using a live CD/USB, then try what zika suggested above.

    You may also have to do -
    Code:
    sudo dpkg configure -a
    sudo dpkg --configure -a
    ..from recovery mode > root shell, after removing the offending entry from the /etc/default/grub file.
    Last edited by varunendra; March 6th, 2014 at 09:08 AM. Reason: corrected the dpkg command, Thanks to ventrical :)
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  4. #4
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    6,469
    Distro
    Ubuntu Development Release

    Re: Kernels failing to install as of yesterday

    Quote Originally Posted by devin-a-hudson View Post
    Here is the pastebin of my terminal output: http://pastebin.com/CfUc3ymr

    This install of Ubuntu 14.04 dev was made about a week ago. I don't have any ppa's providing alternative kernels or other major package changes.

    Would anyone know how to fix this issue?

    Thanks.

    Code:
      sudo -i dpkg --configure -a
    
    




    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  5. #5
    Join Date
    Mar 2014
    Beans
    2

    Re: Kernels failing to install as of yesterday

    Quote Originally Posted by varunendra View Post
    Not sure why this should cause an error -
    Code:
    /usr/sbin/grub-mkconfig: 11: /etc/default/grub: i915.i915_enable_rc6=1: not found
    ..but try removing that entry from you /etc/default/grub file using a live CD/USB, then try what zika suggested above.

    You may also have to do -
    Code:
    sudo dpkg configure -a
    sudo dpkg --configure -a
    ..from recovery mode > root shell, after removing the offending entry from the /etc/default/grub file.
    These instructions seemed to have worked!

    Thank you, and everyone else that offered help

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Kernels failing to install as of yesterday

    Glad it worked.

    And Thanks for the feedback! It helps not only us build out confidence in a particular solution, but also helps others by indicating which of the suggested solutions worked.

    PS:
    If you really need that driver parameter, you should be able to add it again to grub now. Or more safely, you can write a .conf file in /etc/modprobe.d directory to load that parameter. That is usually an easier way, but may fail if the driver is loaded BEFORE the files in that directory are parsed. Let me know if you really need that parameter and wish to try the other method.
    Last edited by varunendra; March 7th, 2014 at 10:20 AM. Reason: Striked out wrong info.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  7. #7
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Kernels failing to install as of yesterday

    Quote Originally Posted by varunendra View Post
    Glad it worked.

    And Thanks for the feedback! It helps not only us build out confidence in a particular solution, but also helps others by indicating which of the suggested solutions worked.

    PS:
    If you really need that driver parameter, you should be able to add it again to grub now. Or more safely, you can write a .conf file in /etc/modprobe.d directory to load that parameter. That is usually an easier way, but may fail if the driver is loaded BEFORE the files in that directory are parsed. Let me know if you really need that parameter and wish to try the other method.
    I do find that it is easier and even safer to use parameters such as the one mentioned above in the kernel boot line because, once the need for it die or there is a change that should be made, it is much easier to change it in Grub (on boot) than to get stuck with it and have to do chroot ... Speaking from experience not just from the top of my (almost empty, old) head...

  8. #8
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Kernels failing to install as of yesterday

    Quote Originally Posted by zika View Post
    it is much easier to change it in Grub (on boot) than to get stuck with it and have to do chroot..
    Yup, I completely agree, that is an advantage in Grub boot line parameters. Besides, some parameters may not work with the .conf file method at all.

    It is just usually easier to tell newbies how to boot with a live media and delete or modify a .conf file, than to explain how to get the grub menu > identify and edit the boot line, and boot. That, plus the two steps (edit /etc/default/grub + update-grub) Vs a single step (echo "..." | tee /etc/modprobe.d/file.conf) while creating it.

    PS:
    I had actually thought of removing the term 'safer' before posting, forgot it. Thanks, zika, for bringing it up. Going to correct it now.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  9. #9
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Kernels failing to install as of yesterday

    Quote Originally Posted by varunendra;12949394That, plus [B
    the two steps[/B] (edit /etc/default/grub + update-grub) Vs a single step (echo "..." | tee /etc/modprobe.d/file.conf) while creating it.
    With sed (+ tee && etc) even that becomes one-liner...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •