Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

  1. #1
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    Applicable Only to Asus Laptops/Netbooks that use "asus_nb_wmi" driver.

    Symptoms :
    • The Wireless is disabled (hard-blocked) despite a correct driver being loaded for it.
    • The Fn+F2 key to enable it won't work.
    • Either it will get enabled only momentarily, or not at all.
    • Usually (but not necessarily) a suspend --> resume cycle makes it active and it remains active for most (but not all) people afterwards.


    Verify :

    1) Check if a driver is available for the card (open a terminal with Ctrl-Alt-T and enter the following command in it) :
    Code:
    lspci -nnk | grep -A2 0280
    Notice the last line that says "Kernel driver in use:".
    Is there a module name in front of it? (e.g. "Kernel driver in use: ath9k")

    2) Check if the driver is loaded and if "asus_nb_wmi" driver is also in use :
    Code:
    lsmod | grep -e ath9k -e asus
    (replace "ath9k" with whatever driver is used by your wireless)
    Do you see the driver for your card, and "asus_nb_wmi" both in the above output?

    3) Check the "Hard blocked" state of wifi -
    Code:
    rfkill list all
    Note the state of the "phy0" interface.
    Does it show as "Hard blocked: yes" ?

    4) Suspend the notebook by pressing Fn+F1 (or any other way) --> then resume it again.
    Does the wireless become active now?

    If the answer to all four checks above is yes (no.4 may be an exception for a few), then your system has this bug and the workaround is as follows -



    Workaround(Thanks to my respectable senior Mr. chili555 for finding this fix and guiding me through it) :

    Please open a terminal (Ctrl-Alt-T) and run the following command in it (you may copy-paste it) -
    Code:
    echo "options asus_nb_wmi wapf=4" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf
    It will create a file "asus_nb_wmi.conf" in "/etc/modprobe.d" directory that will load the driver "asus_nb_wmi" with a parameter "wapf=4" since next boot.

    Reboot and the wifi should be active now. Unfortunately, Fn+F2 still won't work. A workaround, until it gets fixed, is given in the next post below. I'll update this post if (and when) found a fix to that.




    If the above trick works for you, I would STRONGLY recommend you to add yourself to the "Affected" users list of the following two bug reports to help getting more attention to the problem so that it gets fixed quickly :

    Bug Report against the "asus_nb_wmi" driver : https://bugs.launchpad.net/bugs/1173681
    Bug Report against the "Fn+F2" key disability : https://bugs.launchpad.net/bugs/1277959

    How to Report a Bug Effectively : https://help.ubuntu.com/community/ReportingBugs

    EDIT : If this workaround works for you, please also post the output of -
    Code:
    cat /sys/class/dmi/id/product_name
    ..in this thread to help fixing the bug permanently for your laptop model. Please read posts #19 and #21 for details. Thanks to HansdeGoede for coming to the rescue.

    Cleanup (if the above workaround doesn't work for you) :

    Just delete the "asus_nb_wmi.conf" file we created above, and everything will be back to defaults -
    Code:
    sudo rm /etc/modprobe.d/asus_nb_wmi.conf


    Alternative to the Fn+F2 switch to toggle WiFi on/off :

    Please see next post below
    Last edited by varunendra; July 19th, 2014 at 02:32 AM. Reason: changed wapf value from 1 to 4
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  2. #2
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    Setting a HotKey to Toggle the WiFi On/Off (Alternative to the Fn+F2 switch)

    Until this issue is fixed with newer updates, you may use "xbindkeys" tool to set a hotkey (can be a single key or a key-combination) of your choice to toggle the WiFi enabled/disabled.

    This is how -

    A. Create a Script to do it smartly :

    1) First, we create a script (for ease of use, and so that we can toggle it on/off using the same hotkey) -
    Code:
    #!/bin/bash
    # Script to toggle the wireless blocked/unblocked
    
    # index no. of phy interface
    IFACE=`rfkill list all | grep phy | cut -c 1`
    
    # WiFi block state 0=active, 1=blocked
    BLOCKED=`rfkill list all | grep -iA1 phy | grep -ic soft.*yes`
    
    if [ $BLOCKED -eq 1 ]; then
    	rfkill unblock $IFACE
    
    else
    	rfkill block $IFACE
    fi
    Copy-paste the contents of the above box in a text file and save this file in your Home directory with the name - "wifitoggle.sh". Make sure the first line is (without double quotes) "#!/bin/bash" and last one is "fi".

    2) Make the script executable by running the following command in a terminal -
    Code:
    chmod +x wifitoggle.sh
    3) Run the following command to Create a symlink to this script in /bin directory -
    Code:
    sudo ln -s $HOME/wifitoggle.sh /bin

    Now proceed to binding it with a hotkey as follows -

    B. Bind the Script with a HotKey of your choice :

    1) Install xbindkeys-config (a GUI frontend to xbindkeys - the program that captures and binds hotkeys with commands) -
    Code:
    sudo apt-get install xbindkeys-config
    2) Create a default config file for it (else it would crash on key capture step) -
    Code:
    xbindkeys --defaults > ~/.xbindkeysrc
    3) Run the program from terminal or "Alt+F2" (because it does not create a launcher in Unity dash) -
    Code:
    xbindkeys-config
    let the terminal running in the background..
    In the GUI box that opens, 3 example shortcuts are already present. You may leave them.

    4) Click on "New" button at the bottom of the GUI.

    5) In the right hand pane of the GUI, fill in a suitable name in the "Name" field, e.g. "Toggle Wifi"

    6) Click on "Get Key" button. This will open a tiny blank box doing nothing but waiting for your input.

    7) Press the desired key (or key combination) that you want for toggling Wifi on/off. For example, "F3" key (as it remains mostly unused). The tiny box will disappear and the key will be recorded.

    8) In the "Action" field, type this -
    Code:
    /bin/bash /bin/wifitoggle.sh
    9) Click on "Apply" button and test the hotkey to see if it works as expected.

    10) Click on "Save & Apply & Exit" to save the new hotkey to the default file and exit.

    From now on, as soon as you will press this key or the key-combination, the wifi will change its state from On to Off, or Off to On.

    The Fn key doesn't seem to be noticed by any key capture program I could find (probably that's why it is considered "Hardware Switch"), so it's not possible to use it yet.


    Once more, I'd request anyone who needs this workaround to submit a bug report against the problem, or add themselves to the "Affects Me" list, and point to this thread as a possible workaround.

    The stronger it gets reported, the sooner we'll get it fixed, thus not requiring such crude workarounds.
    Last edited by varunendra; February 24th, 2014 at 04:50 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  3. #3
    Join Date
    Nov 2009
    Location
    Italy, lake of Como
    Beans
    55
    Distro
    Ubuntu 14.04 Trusty Tahr

    Thumbs up Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    Thank you very much this solved my issues with an ASUS X551C computer.
    BTW don't by this machine it's awful.

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    You're welcome !

    We'd appreciate if you could let us know 'Why' the machine is awful, in the thread dedicated for this : Laptop INCOMPATIBILITY List
    It is the correct place for letting us know what works and what not with your machine, and it helps users making a decision on what to buy.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  5. #5
    Join Date
    Jan 2009
    Beans
    54

    Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    That line:
    echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf

    solved the problem with my Asus laptop F550C and the Atheros card inside. Once rebooted after that order it works now perfect.
    Many thanks.

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    You're welcome! Please consider adding yourself to the "Affects Me" list of the linked bug reports. Thanks.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  7. #7
    Join Date
    Apr 2014
    Beans
    1

    Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    thanks, my wireless is working now ., thanks, and thanks again . !!!!

  8. #8
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    Welcome to the forums Jerry! Always so pleasant to see someone's first post being a thanks for a successful fix.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  9. #9
    Join Date
    May 2014
    Beans
    11

    Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    Ermagerd much thx :d :d

  10. #10
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Fix : Asus WiFi Disabled (Hard-blocked), Fn+F2 won't work

    Quote Originally Posted by kmdude344 View Post
    Ermagerd much thx :d :d
    You're welcome!

    Please consider the request regarding the bug reports.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •