Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

  1. #1
    Join Date
    Oct 2013
    Beans
    2

    (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    I used to be able to use the Anthy IME to be able to type Japanese but I can no longer find that in the new Ibus.
    Anyone mind pointing me in the right direction?

  2. #2
    Join Date
    Sep 2006
    Location
    Haddonfield, NJ
    Beans
    350
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    Same problem here. I have anthy installed, and I set ibus as the input method as I used to do in previous versions of Ubuntu, but I can no longer switch between input methods. The zenkaku key on my Japanese keyboard does nothing at all, nor does super-shift-space or any other key combo. I am stuck using English input. Nor is there an icon where I can select the input method.

    The im-config options are different than they used to be, and now there seems to be no way to add input methods.


    Edit

    Okay, I figured it out. You have to load up the "Text Entry Settings" and click on the plus sign to add an input method. It works once you do that.
    Last edited by osarusan; October 18th, 2013 at 02:40 PM.

  3. #3
    Join Date
    Jan 2008
    Beans
    17

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    Quote Originally Posted by osarusan View Post
    Edit

    Okay, I figured it out. You have to load up the "Text Entry Settings" and click on the plus sign to add an input method. It works once you do that.
    Same problem, and I have added Japanese in the text entry, still doesn't work, even after reboot.

  4. #4
    Join Date
    Oct 2013
    Beans
    2

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    Can anybody give us a hand?

  5. #5
    Join Date
    Oct 2013
    Beans
    3

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    Edit: Added the full process

    osarusan's solution worked for me. It seems that you switch between Ibus inputs like keyboard layouts, which I think is more logical than the old system. Here are the steps I took:

    First open "Language Support"



    Then click the button "Install/Remove Languages"



    Next, scroll down until you find "Japanese", check the box by it, and then press "Apply Changes"



    It installs some packages...



    Then make sure that your input method is set to "IBus"



    Next go to "Text Entry" by searching for it from the Unity menu and click the plus sign



    Search for "japanese" or scroll down until you find "Japanese (Anthy)"



    Now just select "Anthy" like you would select a keyboard layout, from the thing in the menu bar.



    Hope this helps!
    Last edited by dsavi2; October 20th, 2013 at 09:59 PM.

  6. #6
    Join Date
    Jun 2007
    Location
    Planet-Untu
    Beans
    155
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    Beautiful Icon for Language Switching! TERRIBLE FUNCTIONALITY. Korean input does not work. Icon might swtich to KO, but it produces no Hangul characters! Suggestions?

    BTW, I got Hangul to work through ibus-setup from command line; however, the input does not matter what the language indicator says. This is such a basic function that I cannot believe that it doesn't work!!!

  7. #7
    Join Date
    Jul 2010
    Beans
    110

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    I have occasional needs to input Chinese and Japanese characters. After adding pinyin to the ibus input source, another problem arises: the default keys for switching the input source are "Super + Space". Lo and behold, every time I tried to do that, the Dash screen would pop up, and I am still unable to use pinyin or anthy. I know I can probably change the default setting(s) to make ibus work, but how about the next person or persons that I am planning to give the Ubuntu 13.10 USB to? This is not something that I can explain well without excessive explanations that no one will read. There are already enough challenges to transition a Windows user to Linux/Ubuntu, and we really don't need to go through this additional hurdle.

    As I mentioned in another thread, for CJK users, my advice is to forgo ibus and switch to fcitx. Or, better yes, we should begin experimenting with UbuntuKylin, which, although is been developed ostensibly for (simplified) Chinese users, seems to be a better fit for all CJK users in general.
    Last edited by ping-wu; October 19th, 2013 at 11:41 PM.

  8. #8
    Join Date
    Oct 2013
    Beans
    3

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    Quote Originally Posted by ping-wu View Post
    I have occasional needs to input Chinese and Japanese characters. After adding pinyin to the ibus input source, another problem arises: the default keys for switching the input source are "Super + Space". Lo and behold, every time I tries to do that, the Dash screen would pop up, and I am still unable to use pinyin or anthy.
    Agreed, this is really weird and should be changed. Unity is known to grab some keys, most notably Alt and Super. My solution to this so far has just been to use the "previous input method" shortcut, which is also a default, instead (Shift+Super+Space). Because it's prefixed with a space, Unity doesn't grab it and it works fine, just in reverse.

  9. #9
    Join Date
    Jan 2008
    Beans
    17

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    Quote Originally Posted by dsavi2 View Post

    Search for "japanese" or scroll down until you find "Japanese (Anthy)"


    Thank you!! This worked for me, I had selected the first option, Japanese. Now Japanese (Anthy) is OK

    ありがとう!

  10. #10
    Join Date
    Oct 2013
    Beans
    1

    Re: (Ubuntu 13.10) How to use Japanese Anthy in the new Ibus

    Quote Originally Posted by borischan View Post
    Thank you!! This worked for me, I had selected the first option, Japanese. Now Japanese (Anthy) is OK

    ありがとう!
    how can you did it??
    i mean, i can't find japanese ( anthy ) on my laptop, what did you do ?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •