Results 1 to 6 of 6

Thread: Sub-woofer dead with Ubuntu 13.10 on Dell 17R

  1. #1
    Join Date
    May 2006
    Location
    San Francisco Bay Area
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Sub-woofer dead with Ubuntu 13.10 on Dell 17R

    The sound is shallow without the sub-woofer since only the tiny left & right speakers are working. There was a fix for 13.04 which made the sub-woofer work but that doesn't work with 13.10. That fix was to append the following line to the end of /etc/modprobe.d/alsa-base.conf

    options snd-hda-intel model=ref

    If I add that line under 13.10 the sound goes dead and I get no sound from any speaker. Is there some other fix for this latest version?

  2. #2
    Join Date
    May 2006
    Location
    San Francisco Bay Area
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Sub-woofer dead with Ubuntu 13.10 on Dell 17R

    UPDATE: The steps below do nothing for the problem. See my last post in this thread for the real solution.

    After googling around I see that it appears to be a common problem. Here is a web page about just that. I tried every combination of things mentioned there but nothing makes the sub-woofer work in Ubuntu 13.10. Interestingly, I do now have a sub-woofer control in the sound panel, but it is dimmed (disabled). Below I describe the modifications that got me that far, but like I said, still no sound from the sub-woofer

    In Terminal type the following:
    sudo gedit /etc/pulse/daemon.conf
    Uncomment and modify the following lines:
    enable-lfe-remixing = yes
    default-sample-channels = 3
    default-channel-map = front-left,front-right,lfe
    Next type the following:
    sudo gedit /etc/pulse/default.pa
    Append the following line to the end of that file and restart:
    load-module module-combine channels=3 channel_map=front-left,front-right,lfe
    The Intel codec is IDT 92HD91BXX and it seems to be a popular one used in many other computers beside Dells. Hopefully there will be some movement to make this work someday.
    Last edited by mikesmithv; October 21st, 2013 at 09:58 PM.

  3. #3
    Join Date
    Sep 2013
    Beans
    1

    Re: Sub-woofer dead with Ubuntu 13.10 on Dell 17R

    I've downgraded my Ubuntu to 13.04 as there were a lot of bugs. But here was given an answer. Could you try it?
    Last edited by solid.danil; October 21st, 2013 at 12:50 AM.

  4. #4
    Join Date
    May 2006
    Location
    San Francisco Bay Area
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Sub-woofer dead with Ubuntu 13.10 on Dell 17R

    I tried it and it works! Here are my version of those steps (with a little more detail):

    In "Ubuntu Software Center" search for "alsa-tools-gui" and install it.

    Open Terminal and type hdajackretask and press Enter.

    In the window the comes up check "Show unconnected pins" checkbox in upper right-hand side.

    Scroll down and find "Pin ID: 0x10" and under that do the following:
    Check the "Override" checkbox.
    Select "Internal speaker (LFE)" in pop-down menu.

    Click "Install boot override" button in lower right-hand side.

    Restart computer - sub-woofer works!

    Maybe it's my imagination but the sub-woofer sounds better than ever doing this patch. Even better, when I plug in the headphones the speakers go completely silent now. With Ubuntu 13.04 using the "options snd-hda-intel model=ref" patch I mentioned above the sub-woofer still had sound when headphones were plugged in. Now the sound functions are all working as they should. Thankyou so much for that post.

  5. #5
    Join Date
    Oct 2013
    Beans
    1

    Talking Re: Sub-woofer dead with Ubuntu 13.10 on Dell 17R

    Had try this for my Asus G73JH -A1 and even if the subwofer button did not appear the bass started working

  6. #6
    Join Date
    Dec 2013
    Beans
    1

    Re: Sub-woofer dead with Ubuntu 13.10 on Dell 17R

    works like a charm on a Dell Studio 1557 (STAC92HD73)
    but would be nice to know, what hdajackretask actually changed, and if it could be done with pulse/alsa config (which still fails under 13.10)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •