Results 1 to 3 of 3

Thread: Kubuntu screen brightness and wireless problems upgrading to saucy

  1. #1
    Join Date
    Jul 2008
    Beans
    19

    Kubuntu screen brightness and wireless problems upgrading to saucy

    Upon upgrading from Kubuntu 13.04 to 13.10, I am no longer able to change the brightness via KDE system settings or the battery monitor widget. Upon editing my /etc/default/grub to
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    I am able to modify brightness via keyboard controls but not via system settings or the battery monitor widget.
    Brightness appears to be at 100% on startup. /sys/class/backlight contains thinkpad_screen and intel_backlight. xbacklight does not change when given commands such as xbacklight -set 50.
    Additionally, I periodically get the error notification "Wireless Interface wlan0 failed to activate - Authorization Supplicant timed out."
    I am using a Lenovo Thinkpad T430s with Nvidia Optimus graphics and an Intel wireless card. All settings worked fine before the upgrade.

  2. #2
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Kubuntu screen brightness and wireless problems upgrading to saucy

    Quote Originally Posted by emperortux View Post
    ..I am able to modify brightness via keyboard controls but not via system settings or the battery monitor widget.
    Brightness appears to be at 100% on startup.
    Please run the following script when it is at 100% -
    Code:
    for i in `ls /sys/class/backlight/`; do echo -e "\n $i"; cat /sys/class/backlight/$i/{brightness,max_brightness,actual_brightness}; done
    Then decrease the brightness by one step using key controls, and run it again.

    Lastly, decrease it to minimum and run the script for a third time.

    Copy-paste the outputs of all three times here in your next post and we may try a few things depending upon the change/no-change that may occur.

    And have you also tried the "acpi_osi=" parameter before "acpi_backlight=vendor" ? I'd suggest to try it if you haven't already. Also, "acpi_osi=linux" if the first form doesn't help. Of course run "sudo update-grub" command each time after making a change in the default file, then reboot to see its effect.

    PS: For the wireless issue, you should start a different thread in Networking & Wireless section of the forums
    Last edited by varunendra; October 18th, 2013 at 03:46 PM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  3. #3
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate Development Release

    Re: Kubuntu screen brightness and wireless problems upgrading to saucy

    Moved to General Help.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •