Results 1 to 8 of 8

Thread: Ubuntu 13.04 desktop background issues, mosaic

  1. #1
    Join Date
    Jul 2011
    Beans
    1

    Ubuntu 13.04 desktop background issues, mosaic

    I have a problem with my desktop background after last update.
    My Desktop wall paper looks like mosaic and when I open any window, the background keeps the trail of it.
    I've tried running in fail safe graphics more, no fix. I've tried installing ubuntu-desktop and unity, no fix.
    Please help.

    Screenshot from 2013-06-12 11:59:23.jpgScreenshot from 2013-06-12 11:59:53.jpg

  2. #2
    Join Date
    Jun 2013
    Beans
    2

    Re: Ubuntu 13.04 desktop background issues, mosaic

    I have exactly the same problem. With a program open, though, Unity works fine - no trails or other graphical glitching. Minimise a full open window and try and use Unity over the desktop background and it quickly becomes a ghost trail mess.

    id: cpu:0
    description: CPU
    product: Intel(R) Pentium(R) 4 CPU 3.00GHz
    vendor: Intel Corp.
    physical id: 400
    bus info: cpu@0
    version: 15.4.3
    serial: 0000-0F43-0000-0000-0000-0000
    slot: Microprocessor
    size: 3GHz
    capacity: 4GHz
    width: 64 bits
    clock: 800MHz
    capabilities: boot fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx x86-64 constant_tsc pebs bts pni dtes64 monitor ds_cpl est cid cx16 xtpr
    configuration:
    id = 0


    id: display:0
    description: VGA compatible controller
    product: RV370 [Radeon X600/X600 SE]
    vendor: Advanced Micro Devices [AMD] nee ATI
    physical id: 0
    bus info: pci@0000:01:00.0
    version: 00
    width: 64 bits
    clock: 33MHz
    capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
    configuration:
    driver = radeon
    latency = 0
    resources:
    irq : 42
    memory : e0000000-e7ffffff
    memory : efde0000-efdeffff
    ioport : dc00(size=256)
    memory : efe00000-efe1ffff

  3. #3
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Ubuntu 13.04 desktop background issues, mosaic

    Quote Originally Posted by juranich View Post
    I have a problem with my desktop background after last update.
    My Desktop wall paper looks like mosaic and when I open any window, the background keeps the trail of it.
    I've tried running in fail safe graphics more, no fix. I've tried installing ubuntu-desktop and unity, no fix.
    Please help.

    Screenshot from 2013-06-12 11:59:23.jpgScreenshot from 2013-06-12 11:59:53.jpg
    Check to see what driver your using...
    Code:
    /usr/lib/nux/unity_support_test -p
    Eg I'm using the nouveau driver
    Code:
    glen@Raring:~$ /usr/lib/nux/unity_support_test -p
    OpenGL vendor string:   nouveau
    OpenGL renderer string: Gallium 0.4 on NVCF
    OpenGL version string:  3.0 Mesa 9.1.1
    
    Not software rendered:    yes
    Not blacklisted:          yes
    GLX fbconfig:             yes
    GLX texture from pixmap:  yes
    GL npot or rect textures: yes
    GL vertex program:        yes
    GL fragment program:      yes
    GL vertex buffer object:  yes
    GL framebuffer object:    yes
    GL version is 1.4+:       yes
    
    Unity 3D supported:       yes
    Also try different settings in
    ccsm > ubuntu unity plugin
    for opacity, backround color and dash blur.

    ccsm is compizconfig-settings-manager and is not in the default install.
    To install...
    Code:
    sudo apt-get install compizconfig-settings-manager
    To run enter ccsm in the dash or a terminal.
    Attached Images Attached Images
    Last edited by stinkeye; June 13th, 2013 at 03:01 PM.

  4. #4
    Join Date
    Jun 2013
    Beans
    2

    Re: Ubuntu 13.04 desktop background issues, mosaic

    Thanks for your suggestions, stinkeye. Changing the compiz settings doesn't solve the problem.

    OpenGL vendor string: X.Org R300 Project
    OpenGL renderer string: Gallium 0.4 on ATI RV370
    OpenGL version string: 2.1 Mesa 9.1.1


    Not software rendered: yes
    Not blacklisted: yes
    GLX fbconfig: yes
    GLX texture from pixmap: yes
    GL npot or rect textures: yes
    GL vertex program: yes
    GL fragment program: yes
    GL vertex buffer object: yes
    GL framebuffer object: yes
    GL version is 1.4+: yes


    Unity 3D supported: yes

  5. #5
    Join Date
    Oct 2011
    Beans
    2

    Re: Ubuntu 13.04 desktop background issues, mosaic

    I am having similar issue. Wallpaper and graphics are fine on login screen and in any application, but leave "window trails" when anything is over the desktop. Killing Nautulis stops the trails.
    It seems that the following solves the problem (I'm not sure if the fix is persistent upon reboot):
    Code:
    killall nautilus
    nautilus --no-desktop
    Although now I don't have my desktop icons, so it's not an ideal fix.

  6. #6
    Join Date
    Oct 2011
    Beans
    2

    Re: Ubuntu 13.04 desktop background issues, mosaic

    What I found for me is that what I posted above only works until you log out. When I logged out or restarted, nautulis would startup without the "--no-desktop" option, and the problem would be back. To permanently fix the problem, I had to purge nautulis, and re-install it.

    Code:
    sudo apt-get purge nautilus
    sudo apt-get install nautilus

  7. #7
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Ubuntu 13.04 desktop background issues, mosaic

    Quote Originally Posted by NOTAL View Post
    What I found for me is that what I posted above only works until you log out. When I logged out or restarted, nautulis would startup without the "--no-desktop" option, and the problem would be back. To permanently fix the problem, I had to purge nautulis, and re-install it.

    Code:
    sudo apt-get purge nautilus
    sudo apt-get install nautilus
    If you kill nautilus it no longer draws icons on the desktop until you either restart the session
    or simply open your home folder, thereby restarting nautilus without the "--no-desktop" option.
    Don't think purging and re-installing nautilus will fix.

    If killing nautilus fixes your problem, set nautilus not to manage the desktop....in terminal...
    Code:
    gsettings set org.gnome.desktop.background show-desktop-icons false
    You will no longer have desktop icons or a right click menu on the desktop.

    To allow nautilus to manage the desktop again, run...
    Code:
    gsettings reset org.gnome.desktop.background show-desktop-icons
    Last edited by stinkeye; June 30th, 2013 at 04:26 AM.

  8. #8
    Join Date
    Jun 2011
    Beans
    1

    Unhappy Re: Ubuntu 13.04 desktop background issues, mosaic

    Same thing happend to me on 13.04 x64 after today updates. The things mentioned here had no effect on it though.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •