Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: 13.04 -> 13.10 = Choppy/Crappy sound with Pulseaudio

  1. #11
    Join Date
    Aug 2013
    Beans
    3

    Re: 13.04 -> 13.10 = Choppy/Crappy sound with Pulseaudio

    Something is weird with the communication between pulseaudio and the alsa-drivers. I use ubuntu-studio for audio production with jack, and found that the jack-sink for pulseaudio works well. There's no sync problem when jack sits between pulseaudio and alsa. Whatever I do to make pulseaudio use the same samplerate (48k) and formats (s24le) as jack makes no difference. Standalone pulseaudio with direct connection to alsa is useless with any of my audio-adapters (Intel HDA, Roland 2ch USB, Behringer X32 mixer w/32ch USB, Soundcraft digital mixer w/32ch FW, Presonus 8ch USB).

  2. #12
    Join Date
    Nov 2006
    Beans
    4

    Re: 13.04 -> 13.10 = Choppy/Crappy sound with Pulseaudio

    i also have the same problem on fresh 13.10 install and the latest skype :/

  3. #13
    Join Date
    Feb 2008
    Beans
    10

    Re: 13.04 -> 13.10 = Choppy/Crappy sound with Pulseaudio

    I have also been having issues with choppy sound in Kubuntu 13.10, with none of the old fixes (tsched=0) working. Your suggestion, heldal2, works though, I have found that by using jack as the interop layer between pulseaudio and alsa the playback is clean. For anyone else wanting to do the same, I followed the instructions at https://help.ubuntu.com/community/Ub...udioIntro/1204

  4. #14
    Join Date
    Oct 2010
    Beans
    11

    Re: 13.04 -> 13.10 = Choppy/Crappy sound with Pulseaudio

    Same issue. Mainly with flash. Starts ok, but in a few seconds starts getting choppier and choppier.
    As soon as I open pavucontrol, the sound choppiness goes away immediately. If I close pavucontrol, it's choppy again immediately.

    Workaround2:
    I have two sound cards. I disabled "simultaneous output" in pulseaudio preferences. Got even flash video better as well.
    Last edited by karsta62; February 12th, 2014 at 08:08 PM.

  5. #15
    Join Date
    Jan 2008
    Beans
    24

    Re: 13.04 -> 13.10 = Choppy/Crappy sound with Pulseaudio

    Seems that this is now an acknowledged bug with Puklse 4.0 compatibility for many apps. workaround:

    change puklse latency before calling app, .e.g.:

    env PULSE_LATENCY_MSEC=30 appl_name

    You can embed this in the app launcher, e.g. - for audacity:

    sudo sed -i 's/^Exec=.*/Exec=env PULSE_LATENCY_MSEC=30 audacity %U/' /usr/share/applications/audacity.desktop

  6. #16
    Join Date
    Apr 2014
    Beans
    1

    Re: 13.04 -> 13.10 = Choppy/Crappy sound with Pulseaudio

    Quote Originally Posted by heldal2 View Post
    Something is weird with the communication between pulseaudio and the alsa-drivers. I use ubuntu-studio for audio production with jack, and found that the jack-sink for pulseaudio works well. There's no sync problem when jack sits between pulseaudio and alsa. Whatever I do to make pulseaudio use the same samplerate (48k) and formats (s24le) as jack makes no difference. Standalone pulseaudio with direct connection to alsa is useless with any of my audio-adapters (Intel HDA, Roland 2ch USB, Behringer X32 mixer w/32ch USB, Soundcraft digital mixer w/32ch FW, Presonus 8ch USB).
    Thanks hedal2, You solved my problem with flash-player with pulseaudio on a amd64 system. Just to clarify for nobs as me, I followed the instructions at
    https://help.ubuntu.com/community/Ub...udioIntro/1204
    as terranim suggested: installed jack and configured it with QjackCtl to use alsa as his output. I also had to put a "2" instead of a "3" in "periods/buffer". After that, I could press the Start button and jackd started without erros
    Then on firefox entered a flash page and started to play sound. With pavucontrol , "playback" tab, I changed the output of the app Alsa plug-in (plugin-container) to "Jack sink" and the sound started to be heared. So I think flash is playing sound to alsa-plugin , wich is recevied by pulseaudio who sends it to Jack thru jack sink, who finally outputs it to alsa directly. No more choppy sound.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •