Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problem with new ibus in ubuntu 13.10

  1. #1
    Join Date
    Sep 2013
    Beans
    3

    Problem with new ibus in ubuntu 13.10

    i installed Ubuntu 13.10. It has a new version of Ibus. But I don't know how to show the language panel of Ibus. I need it to type vietnamese with vni, and japanese. Can you tell me how to show it or install the older version of ibus?
    Last edited by mousewis; September 9th, 2013 at 03:12 PM.

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    9,607
    Distro
    Ubuntu Development Release

    Re: Problem with new ibus in ubuntu 13.10

    I am not sure I understand the problem. In 13.10 IBUS is part of the Language Support utility. It has a panel for Keyboard input method. That is where we select IBUS or default. There is a tool tip that appears over "Default." It says

    If you need to type in languages which require more complex input methods than just a simple key to letter mapping, you may want to enable this function. For example, you will need this function for typing Chinese, Japanese, Korean, Vietanese. The recommended value for Ubuntu is "IBUS". If you want to use alternative input method systems, install the corresponding packages first and then choose the desired system here.
    The same advice appears whether the method system is set to default or IBUS. It seems to me that we select IBUS and then install the language from Language Support and that is all it takes. I could be wrong. You might then want to go to Keyboard Layouts and install a keyboard layout for the language. Then an icon will appear in the top panel that will let you switch language keyboard layouts. You will then find that you can use Shift+Super+Space to switch back and forth between layouts.

    Regards.
    Last edited by grahammechanical; September 9th, 2013 at 03:44 PM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 15.10 Wily Werewolf

    Re: Problem with new ibus in ubuntu 13.10

    Moved to Ubuntu +1

  4. #4
    Join Date
    Sep 2013
    Beans
    3

    Re: Problem with new ibus in ubuntu 13.10

    thanks for answering my question. telex and vni are two conventions for encoding vietnamese. but when i install ubuntu 13.10, i only can use telex. because the new ibus doesn't "show the language panel". you can see it here http://i.imgur.com/meV1E.png. the line " show language panel" doesn't appear in ubuntu 13.10. can you help me. thanks very much.

  5. #5
    Join Date
    Dec 2004
    Beans
    56
    Distro
    Ubuntu Development Release

    Re: Problem with new ibus in ubuntu 13.10

    I've got the same problems as mousewis in the previous post and some more:

    I'm using IBUS 1.5.3 with Ubuntu 13.10. When I select IBUS as the input method (in the language support menu), the unity launcher doesn't respond to text input any more. All other applications work without problems.

    The other problem is, that I was no able to get Japanese input working with the new IBUS version using Mozc or Anthy (as described in http://www.localizingjapan.com/blog/...ring-ringtail/ for example). This was all working for me since Ubuntu 10.10...

    Has someone got IBUS and Japanese input with the new IBUS working on Ubuntu 13.10? How?

  6. #6
    Join Date
    Sep 2006
    Location
    Haddonfield, NJ
    Beans
    350
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Problem with new ibus in ubuntu 13.10

    Same problem here. (How was this marked solved???)

    Ibus is installed, but there is no way to change the input method to Japanese. The zenaku key does nothing and does not switch the language. Further, there is no option for changing the IME in the notification area either, so I can't even use the mouse to change input methods. Currently there is no way at all that I know of for me to type in Japanese...

  7. #7
    Join Date
    Oct 2013
    Beans
    4

    Re: Problem with new ibus in ubuntu 13.10

    Quote Originally Posted by grahammechanical View Post
    I am not sure I understand the problem. In 13.10 IBUS is part of the Language Support utility. It has a panel for Keyboard input method. That is where we select IBUS or default. There is a tool tip that appears over "Default." It says



    The same advice appears whether the method system is set to default or IBUS. It seems to me that we select IBUS and then install the language from Language Support and that is all it takes. I could be wrong. You might then want to go to Keyboard Layouts and install a keyboard layout for the language. Then an icon will appear in the top panel that will let you switch language keyboard layouts. You will then find that you can use Shift+Super+Space to switch back and forth between layouts.

    Regards.
    Yes. combining with Shift+Super+Space will help switch between input languages to IBUS, especially Unikey for Vietnamese. However there is no choice for typing Telex or Vni; by default it will use telex way for typing which annoys those who are fimilar with vni. Does any one know how to get ibus reference as it was on 12.04 or even 13.04?
    Thanks.

  8. #8
    Join Date
    Jan 2008
    Beans
    17

    Re: Problem with new ibus in ubuntu 13.10

    Quote Originally Posted by osarusan View Post
    Same problem here. (How was this marked solved???)

    Ibus is installed, but there is no way to change the input method to Japanese. The zenaku key does nothing and does not switch the language. Further, there is no option for changing the IME in the notification area either, so I can't even use the mouse to change input methods. Currently there is no way at all that I know of for me to type in Japanese...
    Same problem here, need Japanese and can't input since upgrade to 13.10
    Oh, and what is "Shift+Super+Space"? I need my zenkaku key...
    Last edited by borischan; October 18th, 2013 at 03:38 AM. Reason: more

  9. #9
    Join Date
    Oct 2013
    Beans
    1

    Re: Problem with new ibus in ubuntu 13.10

    I think i 've found the way to fix it, i install xubuntu-desktop and it have an option to switch between Vni and Telex, hope it work for Japanese too.
    Sorry for my bad english.

  10. #10
    Join Date
    Jul 2012
    Beans
    1

    Re: Problem with new ibus in ubuntu 13.10

    Hi all, i same problem after upgrade ubuntu 13.10 , and i use ibus to type vietnamese . ( i use gnome 3)
    And I fix it : go System Settings->Region & Language -> Input source -> click button Add ->choose input source and set shortcuts -> log out.
    p/s: my english not good Screenshot from 2013-10-18 18:34:29.png

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •