Results 1 to 4 of 4

Thread: SwiftKit under Wine?

  1. #1
    Join Date
    Oct 2013

    SwiftKit under Wine?

    Swift Kit is an application built for Runescape that has tools, calculators, maps, and etc.

    I am currently running Xubuntu 12.04.3 and attempted to install Swift Kit under wine. I followed these instructions:

    It is possible to install SwiftKit on Linux using Wine and Winetricks.
    1.  If you don't already have Wine, you're going to need to download it.  You can either get this from the Add/Remove panel in Ubuntu or from  Wine's repositories here.
    2. If you don't have Winetricks, install it. Wine is not the same as winetricks. To install Winetricks type:
        wget You're going to need a few things from Winetricks to run SwiftKit. To install them type:
        sh winetricks vcrun6 wsh56 allfonts4. Download Java from here. Run it with Wine.
    5. Run the SwiftKit installer. It will give you an error, ignore it.
    Congratulations! You've now installed SwiftKit on a Linux machine! 
    Credits to primefalcon. (Taken from the SwiftKit website)
    However, when I click the icon nothing will happen, so i tried running through the terminal and got these errors

    david@david-laptop:~$ /home/david/Desktop/SwiftKit.desktop
    /home/david/Desktop/SwiftKit.desktop: line 1: [Desktop: command not found
    /home/david/Desktop/SwiftKit.desktop: line 3: syntax error near unexpected token `('
    /home/david/Desktop/SwiftKit.desktop: line 3: `Exec=env WINEPREFIX="/home/david/.wine" wine C:\\\\Program\\ Files\\ \\(x86\\)\\\\SwiftKit\\\\SwiftKit.exe '
    anyone have any thoughts?

    Any and all help is appreciated

  2. #2
    Join Date
    Oct 2013

    Re: SwiftKit under Wine?

    Hi im Simmo head of swiftkit support

    The post that have read is about 5 years old. Swiftkit has changed a lot since then and is no longer a pre compiled single binary file. Swiftkit now heavly manipulates the windows api. Our own testing has shown that swiftkit is unable to work with wine. You may find it easier to get our osx version working with ubuntu.

    That being said it may still be possible to get it to work and if you are able to we would like to know.

    To start off your comand line error is cause becuase you have a ( in the file path you need to escape it like you have done with the slashes.
    Last edited by eliteazza; October 16th, 2013 at 10:57 PM. Reason: updated information

  3. #3
    Join Date
    Oct 2013

    Re: SwiftKit under Wine?

    Hmm well do you think I would be better off using the 2007 version of Swift Switch? All I really want are the calculators and tools

  4. #4
    Join Date
    Jul 2007
    Magic City of the Plains
    Xubuntu 15.10 Wily Werewolf

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts