Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Error while installing libgraph-1.0.2

  1. #1
    Join Date
    May 2013
    Beans
    44

    Error while installing libgraph-1.0.2

    Hi friends,

    I am trying to install libgraph-1.0.2
    After running ./configure command and then running make command, I got following error:

    Makefile:934: warning: overriding commands for target `libgraph.pc'
    Makefile:409: warning: ignoring old commands for target `libgraph.pc'
    if /bin/bash ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -g -O2 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DFONTDIR=\""/usr/local/share/libgraph/Font/"\" -g -O2 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -MT guile-libgraph.lo -MD -MP -MF ".deps/guile-libgraph.Tpo" -c -o guile-libgraph.lo guile-libgraph.c; \
    then mv -f ".deps/guile-libgraph.Tpo" ".deps/guile-libgraph.Plo"; else rm -f ".deps/guile-libgraph.Tpo"; exit 1; fi
    gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -g -O2 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DFONTDIR=\"/usr/local/share/libgraph/Font/\" -g -O2 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -MT guile-libgraph.lo -MD -MP -MF .deps/guile-libgraph.Tpo -c guile-libgraph.c -fPIC -DPIC -o .libs/guile-libgraph.o
    guile-libgraph.c:25:22: fatal error: libguile.h: No such file or directory
    compilation terminated.
    make[2]: *** [guile-libgraph.lo] Error 1
    make[2]: Leaving directory `/home/rahul/Downloads/libgraph-1.0.2'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/rahul/Downloads/libgraph-1.0.2'
    make: *** [all] Error 2


    Thereafter , I installed guile from Synaptic Package Manager, but still the same error is shown.
    What should I do???



    Regards

  2. #2
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error while installing libgraph-1.0.2

    You need to install guile-dev. (In general, header files (.h) are provided by -dev packages.)
    「明後日の夕方には帰ってるからね。」


  3. #3
    Join Date
    May 2013
    Beans
    44

    Re: Error while installing libgraph-1.0.2

    @Bachstelze:

    I have already installed guile-2.0-dev
    Now, tell me what should I do....

  4. #4
    Join Date
    May 2013
    Beans
    44

    Re: Error while installing libgraph-1.0.2

    Hi Bachstelze,

    I did the same but no effect took place.
    So what should I do?

    Regards

  5. #5
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error while installing libgraph-1.0.2

    Which version of Ubuntu are you running?
    「明後日の夕方には帰ってるからね。」


  6. #6
    Join Date
    Aug 2010
    Location
    Lancs, United Kingdom
    Beans
    1,079
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Error while installing libgraph-1.0.2

    After installing guile-dev, did you rerun configure?

  7. #7
    Join Date
    May 2013
    Beans
    44

    Re: Error while installing libgraph-1.0.2

    Hi,
    I am using ubuntu 12.04 LTE

  8. #8
    Join Date
    May 2013
    Beans
    44

    Re: Error while installing libgraph-1.0.2

    @spjackson:

    Yes I reran the configure

  9. #9
    Join Date
    Aug 2010
    Location
    Lancs, United Kingdom
    Beans
    1,079
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Error while installing libgraph-1.0.2

    If you have installed the prerequisites properly, I am afraid I've no idea what your problem is.

    I did a fresh install of 12.04
    Code:
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 12.04 LTS
    Release:    12.04
    Codename:   precise
    Installed the prerequisites thus
    Code:
    $ sudo apt-get install build-essential
    $ sudo apt-get install guile-1.8-dev
    $ sudo apt-get install libsdl1.2-dev
    $ sudo apt-get install libsdl-image1.2-dev
    Checked I'd got libguile.h
    Code:
    $ find /usr/include -name "*guile*"
    /usr/include/libguile.h
    /usr/include/libguile
    /usr/include/guile
    Yes, I have, so get the source and build it...
    Code:
    $ wget http://download.savannah.gnu.org/releases/libgraph/libgraph-1.0.2.tar.gz
    $ tar xf libgraph-1.0.2.tar.gz
    $ cd libgraph-1.0.2/
    $ ./configure
    $ make
    and it builds without error. What are you doing differently?

  10. #10
    Join Date
    May 2013
    Beans
    44

    Re: Error while installing libgraph-1.0.2

    @spjackson:

    Thanks for the help. Now it has been installed
    Actually I had installed guile-2.0.
    So, I followed your steps again, and now it's done.
    Thank you.

    But, now while compiling a .cpp file for graphics I encountered the following error:

    rahul@rahul-VPCEG28FN:~/CProgram/Graphics$ g++ aa.cpp -lgraph

    /usr/bin/ld: error: cannot find -lgraph
    /tmp/ccntOaHb.o:aa.cpp:function main: error: undefined reference to 'initgraph'
    /tmp/ccntOaHb.o:aa.cpp:function main: error: undefined reference to 'line'
    /tmp/ccntOaHb.o:aa.cpp:function main: error: undefined reference to 'closegraph'
    collect2: ld returned 1 exit status


    Please tell me where doing wrong.....
    Thanks

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •