Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Dual boot Machine dropping connection only on Ubuntu. DHCP?

  1. #11
    Join Date
    Oct 2013
    Beans
    13

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Ok great. I appreciate this. I'll dig into it tomorrow, and change the settings on the router. Can I ask, is AES CCMP algorythm implied with WPA2, or is that something I would have to find and change as well? I'm asking because the cisco forums were also saying that TKIP was no longer a separate setting, or a selection to change, but included with WPA/WPA2 mix mode. So I'm wondering if that's also the case with WPA2 personal and Aes/CCMP currently. I mean, if i change my wireless setting in router to WPA2 personal, will that automatically delete TKIP, allowing replacement by AES/CCMP? Thanks, this was a good read, and the Windows patch makes sense to me.

  2. #12
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,668
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Quote Originally Posted by Mike1977 View Post
    is AES CCMP algorythm implied with WPA2, or is that something I would have to find and change as well? I'm asking because the cisco forums were also saying that TKIP was no longer a separate setting, or a selection to change, but included with WPA/WPA2 mix mode. So I'm wondering if that's also the case with WPA2 personal and Aes/CCMP currently. I mean, if i change my wireless setting in router to WPA2 personal, will that automatically delete TKIP, allowing replacement by AES/CCMP?
    It *should* be implied. But with some wierd settings I have seen in some routers, I have doubts. See this screenshot -



    It shows the selected Encryption mode to be WPA-PSK, which I think shouldn't leave the option of anything other than TKIP, both AES and TKIP options are available. To me, it means that either that model does not provide the option of WPA2 exclusively (might be selected implicitely if you selected "AES"), or it may use some weird non-standard setting.

    As such, check the options available to you in 'Your' router, and make sure to choose the correct one explicitly if possible.
    Attached Images Attached Images
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #13
    Join Date
    Oct 2013
    Beans
    13

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Hi Varun,
    So I'm having an issue here. I changed the settings on 2.4ghz to wpa2, and disabled 5ghz. I clicked "save settings" and the popup window went away. I tried to then enter my router settings again, to restart, but it would not connect to Internet. It Now gives me "Install Cisco connect to setup router" I already have Cisco connect in programs, but I went through the steps anyways. .. That Did not work. I also unplugged router and restarted, and that did not work. While trying to enter settings advanced , it says "class not registered"
    EDIT: I pushed forward on network, and entered my ip in browser, and was able to access the settings again. I changed 5ghz from disabled to wpa2 personal. Then I went back to main settings page and clicked reboot. Seems to be connecting fine now. Properties list wpa2 personal/ aes
    Last edited by Mike1977; October 18th, 2013 at 08:41 PM.

  4. #14
    Join Date
    Oct 2013
    Beans
    13

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Ok,
    So I moved forward with the first link you posted above, with the parameters to try. Just to be clear: I have both 5ghz and 2.4GHZ set to WPA2-personal with AES encryption.
    The first command in your link totally disconnected my computer. So I tried the second command, and it is now re-connected. However, I am still showing 3 out of 4 bars on wifi icon, and it's fluctuating. Here is the readout from the first two commands in terminal:
    # sudo modprobe -rv rtl8192ce
    [sudo] password for mike:
    rmmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/net/mac80211/mac80211.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/net/wireless/cfg80211.ko
    mike@Mike-Ubuntu12:~$ sudo modprobe -rv rtl8192ce
    mike@Mike-Ubuntu12:~$ sudo modprobe -v rtl8192ce fwlps=0
    insmod /lib/modules/3.8.0-31-generic/kernel/net/wireless/cfg80211.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/net/mac80211/mac80211.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko fwlps=0 #
    EDIT: OK so I've done all 4 parameters. I still have 3 out of 4 bars showing, and I am 4 feet away from my router (wireless). I don't know if this really matters here, but I ran speedtest and am getting 10ms PING, 55.92 down and 11.53 up. I am on clean non vpn while trying all these teminal commands. I have a few things to do online here. So , I'll monitor the connection and see if it drops/disconnects like it has been before. Time will tell.

    #mike@Mike-Ubuntu12:~$ sudo modprobe -rv rtl8192ce
    [sudo] password for mike:
    Sorry, try again.
    [sudo] password for mike:
    rmmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/net/mac80211/mac80211.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/net/wireless/cfg80211.ko
    mike@Mike-Ubuntu12:~$ sudo modprobe -rv rtl8192ce
    mike@Mike-Ubuntu12:~$ sudo modprobe -v rtl8192ce fwlps=0
    insmod /lib/modules/3.8.0-31-generic/kernel/net/wireless/cfg80211.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/net/mac80211/mac80211.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko fwlps=0
    mike@Mike-Ubuntu12:~$ sudo modprobe -rv rtl8192ce
    rmmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/net/mac80211/mac80211.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/net/wireless/cfg80211.ko
    mike@Mike-Ubuntu12:~$ sudo modprobe -v rtl8192ce ips=0
    insmod /lib/modules/3.8.0-31-generic/kernel/net/wireless/cfg80211.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/net/mac80211/mac80211.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko ips=0
    mike@Mike-Ubuntu12:~$ sudo modprobe -rv rtl8192ce
    rmmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/net/mac80211/mac80211.ko
    rmmod /lib/modules/3.8.0-31-generic/kernel/net/wireless/cfg80211.ko
    mike@Mike-Ubuntu12:~$ sudo modprobe -v rtl8192ce swenc=1 ips=0 fwlps=0
    insmod /lib/modules/3.8.0-31-generic/kernel/net/wireless/cfg80211.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/net/mac80211/mac80211.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    insmod /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko swenc=1 ips=0 fwlps=0
    mike@Mike-Ubuntu12:~$ #
    Last edited by Mike1977; October 18th, 2013 at 09:19 PM.

  5. #15
    Join Date
    Oct 2013
    Beans
    13

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    I ran your wireless script again. I haven't rebooted yet, so I figured I'd run your wireless script before doing so.

    Code:
    *********** info trace ***************
    
    ***** uname -a *****
    
    Linux Mike-Ubuntu12 3.8.0-31-generic #46~precise1-Ubuntu SMP Wed Sep 11 18:21:16 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    
    ***** lsb_release *****
    
    Distributor ID:    Ubuntu
    Description:    Ubuntu 12.04.3 LTS
    Release:    12.04
    Codename:    precise
    
    ***** lspci *****
    
    02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
        Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:8181]
        Kernel driver in use: rtl8192ce
    --
    03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
        Subsystem: Toshiba America Info Systems Device [1179:fc50]
        Kernel driver in use: atl1c
    
    ***** lsusb *****
    
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 04f2:b289 Chicony Electronics Co., Ltd 
    
    ***** PCMCIA Card Info *****
    
    
    ***** iwconfig *****
    
    wlan0     IEEE 802.11bgn  ESSID:"HighMoon"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: <MAC address removed>   
              Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
              Power Management:off
              Link Quality=70/70  Signal level=26 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:2   Missed beacon:0
    
    
    ***** rfkill *****
    
    3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    
    ***** lsmod *****
    
    rtl8192ce             141806  0 
    rtlwifi               123323  1 rtl8192ce
    mac80211              630977  2 rtl8192ce,rtlwifi
    cfg80211              525326  2 rtlwifi,mac80211
    
    ***** nm-tool *****
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: wlan0  [HighMoon] ----------------------------------------------------
      Type:              802.11 WiFi
      Driver:            rtl8192ce
      State:             connected
      Default:           yes
      HW Address:        <MAC address removed>
    
      Capabilities:
        Speed:           72 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points (* = current AP)
        mccoy:           Infra, <MAC address removed>, Freq 2412 MHz, Rate 54 Mb/s, Strength 26 WPA WPA2
        HighMoon-guest:  Infra, <MAC address removed>, Freq 2462 MHz, Rate 54 Mb/s, Strength 94
        *HighMoon:       Infra, <MAC address removed>, Freq 2462 MHz, Rate 54 Mb/s, Strength 88 WPA2
    
      IPv4 Settings:
        Address:         192.168.1.116
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.1.1
    
        DNS:             75.75.76.76
        DNS:             75.75.75.75
        DNS:             192.168.1.1
    
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            atl1c
      State:             unavailable
      Default:           no
      HW Address:        <MAC address removed>
    
      Capabilities:
        Carrier Detect:  yes
        Speed:           100 Mb/s
    
      Wired Properties
        Carrier:         off
    
    
    
    ***** NetworkManager.state *****
    
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true
    
    ***** NetworkManager.conf *****
    
    [main]
    plugins=ifupdown,keyfile
    dns=dnsmasq
    
    [ifupdown]
    managed=false
    
    ***** interfaces *****
    
    auto lo
    iface lo inet loopback
    
    
    ***** iwlist *****
    
    wlan0     Scan completed :
              Cell 01 - Address: <MAC address removed>
                        Channel:11
                        Frequency:2.462 GHz (Channel 11)
                        Quality=70/70  Signal level=-38 dBm  
                        Encryption key:on
                        ESSID:"HighMoon"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=0000000000000000
                        Extra: Last beacon: 60ms ago
                        IE: Unknown: 0008486967684D6F6F6E
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 03010B
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D160B080400000000000000000000000000000000000000
                        IE: Unknown: DD810050F204104A00011010440001021041000100103B0001031047001002519461683B1AF5B2843176671BB6DB102100074C696E6B7379731023000D4C696E6B7379732045343230301024000776312E302E30321042000234321054000800060050F20400011011000D4C696E6B737973204534323030100800020084103C000103
                        IE: Unknown: DD090010180204F02C0000
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
              Cell 02 - Address: <MAC address removed>
                        Channel:11
                        Frequency:2.462 GHz (Channel 11)
                        Quality=26/70  Signal level=-84 dBm  
                        Encryption key:on
                        ESSID:"Kenny"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s
                        Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=0000003e0bbbf826
                        Extra: Last beacon: 216ms ago
                        IE: Unknown: 00054B656E6E79
                        IE: Unknown: 010882848B960C121824
                        IE: Unknown: 03010B
                        IE: Unknown: 050400010100
                        IE: Unknown: 200100
                        IE: Unknown: 2A0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: WPA Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32043048606C
                        IE: Unknown: DD180050F2020101040003A4000027A4000042435E0062322F00
                        IE: Unknown: 2D1A8C131BFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D160B080800000000000000000000000000000000000000
                        IE: Unknown: DD0900037F01010000FF7F
                        IE: Unknown: DD0A00037F04010000000000
                        IE: Unknown: 0706555320010B1B
              Cell 03 - Address: <MAC address removed>
                        Channel:11
                        Frequency:2.462 GHz (Channel 11)
                        Quality=70/70  Signal level=-38 dBm  
                        Encryption key:off
                        ESSID:"HighMoon-guest"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=0000000000000000
                        Extra: Last beacon: 60ms ago
                        IE: Unknown: 000E486967684D6F6F6E2D6775657374
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 03010B
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D160B080000000000000000000000000000000000000000
                        IE: Unknown: DD090010180200F02C0000
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
              Cell 04 - Address: <MAC address removed>
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=70/70  Signal level=-36 dBm  
                        Encryption key:on
                        ESSID:"mccoy"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=0000000cc490c33e
                        Extra: Last beacon: 60ms ago
                        IE: Unknown: 00056D63636F79
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030101
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32040C121860
                        IE: Unknown: DD090010180206F0000000
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
    
    
    ***** resolv.conf *****
    
    nameserver 127.0.0.1
    search hsd1.pa.comcast.net
    
    ***** blacklist *****
    
    [/etc/modprobe.d/blacklist-ath_pci.conf]
    blacklist ath_pci
    
    [/etc/modprobe.d/blacklist.conf]
    blacklist evbug
    blacklist usbmouse
    blacklist usbkbd
    blacklist eepro100
    blacklist de4x5
    blacklist eth1394
    blacklist snd_intel8x0m
    blacklist snd_aw2
    blacklist i2c_i801
    blacklist prism54
    blacklist bcm43xx
    blacklist garmin_gps
    blacklist asus_acpi
    blacklist snd_pcsp
    blacklist pcspkr
    blacklist amd76x_edac
    
    ***** modinfo *****
    
    filename:       /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
    firmware:       rtlwifi/rtl8192cfw.bin
    description:    Realtek 8192C/8188C 802.11n PCI wireless
    license:        GPL
    author:         Larry Finger    <Larry.Finger@lwfinger.net>
    author:         Realtek WlanFAE    <wlanfae@realtek.com>
    author:         lizhaoming    <chaoming_li@realsil.com.cn>
    srcversion:     8371CA3A9E899B11125FFDE
    alias:          pci:v000010ECd00008176sv*sd*bc*sc*i*
    alias:          pci:v000010ECd00008177sv*sd*bc*sc*i*
    alias:          pci:v000010ECd00008178sv*sd*bc*sc*i*
    alias:          pci:v000010ECd00008191sv*sd*bc*sc*i*
    depends:        rtlwifi,mac80211
    vermagic:       3.8.0-31-generic SMP mod_unload modversions 
    parm:           swlps:bool
    parm:           swenc:using hardware crypto (default 0 [hardware])
     (bool)
    parm:           ips:using no link power save (default 1 is open)
     (bool)
    parm:           fwlps:using linked fw control power save (default 1 is open)
     (bool)
    
    filename:       /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    description:    Realtek 802.11n PCI wireless core
    license:        GPL
    author:         Larry Finger    <Larry.FInger@lwfinger.net>
    author:         Realtek WlanFAE    <wlanfae@realtek.com>
    author:         lizhaoming    <chaoming_li@realsil.com.cn>
    srcversion:     C5BE23342E67ABA5ADA703E
    depends:        mac80211,cfg80211
    vermagic:       3.8.0-31-generic SMP mod_unload modversions 
    
    
    ***** udev rules *****
    
    # PCI device 0x1969:/sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0 (atl1c)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    
    # PCI device 0x10ec:/sys/devices/pci0000:00/0000:00:1c.5/0000:02:00.0 (rtl8192ce)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    
    ***** dmesg *****
    
    [   10.515839] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [   10.516029] rtlwifi: wireless switch is on
    [   19.204605] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   19.206176] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   24.639618] wlan0: authenticate with <MAC address removed>
    [   24.659702] wlan0: send auth to <MAC address removed> (try 1/3)
    [   24.661341] wlan0: authenticated
    [   24.663164] wlan0: associate with <MAC address removed> (try 1/3)
    [   24.666506] wlan0: RX AssocResp from <MAC address removed> (capab=0x11 status=0 aid=2)
    [   24.666726] wlan0: associated
    [   24.666735] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [  165.223326] wlan0: deauthenticated from <MAC address removed> (Reason: 7)
    [  166.524363] wlan0: authenticate with <MAC address removed>
    [  166.543916] wlan0: send auth to <MAC address removed> (try 1/3)
    [  166.545589] wlan0: authenticated
    [  166.547099] wlan0: associate with <MAC address removed> (try 1/3)
    [  166.553047] wlan0: RX AssocResp from <MAC address removed> (capab=0x11 status=0 aid=2)
    [  166.553322] wlan0: associated
    [  758.271726] rtlwifi-0:rtl_watchdog_wq_callback():<0-0> AP off, try to reconnect now
    [  758.271808] wlan0: Connection to AP <MAC address removed> lost
    [  758.277756] rtlwifi-0:rtl_action_proc():<10000-1> sta is NULL
    [  759.220040] wlan0: authenticate with <MAC address removed>
    [  759.239395] wlan0: send auth to <MAC address removed> (try 1/3)
    [  759.242098] wlan0: authenticated
    [  759.242604] wlan0: associate with <MAC address removed> (try 1/3)
    [  759.246178] wlan0: RX AssocResp from <MAC address removed> (capab=0x11 status=0 aid=2)
    [  759.246434] wlan0: associated
    [  796.614627] wlan0: deauthenticating from <MAC address removed> by local choice (reason=3)
    [  869.875685] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [  869.875994] rtlwifi: wireless switch is on
    [  870.236469] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [  870.240839] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [  872.844584] wlan0: authenticate with <MAC address removed>
    [  872.864338] wlan0: send auth to <MAC address removed> (try 1/3)
    [  872.866869] wlan0: authenticated
    [  872.867457] wlan0: associate with <MAC address removed> (try 1/3)
    [  872.870819] wlan0: RX AssocResp from <MAC address removed> (capab=0x11 status=0 aid=2)
    [  872.870996] wlan0: associated
    [  872.871019] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1402.149103] wlan0: deauthenticating from <MAC address removed> by local choice (reason=3)
    [ 1418.649815] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [ 1418.650207] rtlwifi: wireless switch is on
    [ 1419.011980] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1419.016519] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1421.623361] wlan0: authenticate with <MAC address removed>
    [ 1421.643842] wlan0: send auth to <MAC address removed> (try 1/3)
    [ 1421.645907] wlan0: authenticated
    [ 1421.646956] wlan0: associate with <MAC address removed> (try 1/3)
    [ 1421.650521] wlan0: RX AssocResp from <MAC address removed> (capab=0x11 status=0 aid=2)
    [ 1421.650821] wlan0: associated
    [ 1421.650846] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1490.957592] wlan0: deauthenticating from <MAC address removed> by local choice (reason=3)
    [ 1494.670146] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [ 1494.670883] rtlwifi: wireless switch is on
    [ 1495.026842] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1495.031110] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1497.666236] wlan0: authenticate with <MAC address removed>
    [ 1497.686126] wlan0: send auth to <MAC address removed> (try 1/3)
    [ 1497.688380] wlan0: authenticated
    [ 1497.689441] wlan0: associate with <MAC address removed> (try 1/3)
    [ 1497.692869] wlan0: RX AssocResp from <MAC address removed>

  6. #16
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,668
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Everything looks pretty solid to me, including the speeds you mentioned. You should probably try changing the channel from 11 to 1, as both the other APs are using the same channel/frequency, could be causing some interference.

    Let's take a look at the current parameters in use. Please post back the output of -
    Code:
    grep -R [[:alnum:]] /sys/module/rtl8192ce/parameters
    If (and only if, since the speeds are fine now) the stability gives too much trouble, also try disabling the N-channel in the router (use b/g-only mode). Although, as you may have guessed, it is a compromise with speeds your router can deliver, but just test it (again, only if stability is still poor) and then decide whether you want to keep it that way or not.

    EDIT:
    Oh, and by "looking at current parameters" I mean to see which ones you have applied and whether they were applied correctly or not. Of course if you haven't made them permanent yet they will revert to defaults at next boot, unless you apply them again.

    I suggest you make them permanent anyway and then test/post back. It is as easy to revert as deleting the .conf file -
    Code:
    sudo rm /etc/modprobe.d/rtl8192ce.conf
    Last edited by varunendra; October 19th, 2013 at 01:33 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  7. #17
    Join Date
    Oct 2013
    Beans
    13

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    I had already re booted after seeing your post. So I figured, before establishing the parameters again, I would run the code you provided. Just to see what it read out as vanilla. Here's the output:

    Code:
    /sys/module/rtl8192ce/parameters/ips:Y
    /sys/module/rtl8192ce/parameters/fwlps:Y
    /sys/module/rtl8192ce/parameters/swenc:N
    /sys/module/rtl8192ce/parameters/swlps:N
    I will now re establish the parameters, and edit this reply with the readout included. But just in case, I will not make the parameters permanent until you see all the readouts and approve.

    EDIT 1 : As I said before, the first code command disconnects my wifi fully
    Code:
    sudo modprobe -rv rtl8192ce
    sudo modprobe -v rtl8192ce swenc=1
    .
    So I ran the 2nd code/ parameter you provided:
    Code:
    sudo modprobe -rv rtl8192ce
    sudo modprobe -v rtl8192ce fwlps=0
    Code:
    /sys/module/rtl8192ce/parameters/ips:Y
    /sys/module/rtl8192ce/parameters/fwlps:N
    /sys/module/rtl8192ce/parameters/swenc:N
    /sys/module/rtl8192ce/parameters/swlps:N
    Oddly, this time the 3rd parameter had disconnected me too.
    Code:
    sudo modprobe -rv rtl8192ce
    sudo modprobe -v rtl8192ce ips=0
    So I ran 4th parameter (blind shot all 3)
    Code:
    sudo modprobe -rv rtl8192ce
    sudo modprobe -v rtl8192ce swenc=1 ips=0 fwlps=0
    and here is my results:

    Code:
    /sys/module/rtl8192ce/parameters/ips:N
    /sys/module/rtl8192ce/parameters/fwlps:N
    /sys/module/rtl8192ce/parameters/swenc:Y
    /sys/module/rtl8192ce/parameters/swlps:N
    I'm a little confused though. I was guessing that by running the 4th parameter, my results would have been a combination of all 3 readouts. Meaning the top 3 lines would all have "Y" at the end. So which, if any, should I make permanent? Thanks.

    I have not figured out how to change the channel from 11 to 1 yet.
    Last edited by Mike1977; October 19th, 2013 at 06:29 PM.

  8. #18
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,668
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Quote Originally Posted by Mike1977 View Post
    I'm a little confused though. I was guessing that by running the 4th parameter, my results would have been a combination of all 3 readouts. Meaning the top 3 lines would all have "Y" at the end. So which, if any, should I make permanent? Thanks.
    Whichever seems to help, which is apparently the fwlps=0 parameter. And none of the 'parameters' should disconnect you, only the first part of each set (modprobe -r), due to the "-r" option, which is to 'remove' the driver (thus disabling the interface) so we can reload it with the desired parameter.

    And "Y" or "1" means True or Yes, while "N" or "0" means false or No. So the output is in accordance with what you tried.

    Based on the response so far, you should try -
    Code:
    echo "options rtl8192ce fwlps=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf
    ..to make only fwlps=0 parameter permanent.

    After doing this, the test command should show you this on next boot -
    Code:
    /sys/module/rtl8192ce/parameters/ips:Y
    /sys/module/rtl8192ce/parameters/fwlps:N
    /sys/module/rtl8192ce/parameters/swenc:N
    /sys/module/rtl8192ce/parameters/swlps:N
    If still disconnecting, you may try the "swenc=1" parameter in temporary mode after this, the fwlps=0 will be loaded automatically. Let me know how it goes.
    Last edited by varunendra; October 19th, 2013 at 07:15 PM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  9. #19
    Join Date
    Oct 2013
    Beans
    13

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Ok. Seems to be in line with what you thought. I ran the conf* script and rebooted.

    Code:
    mike@Mike-Ubuntu12:~$ grep -R [[:alnum:]] /sys/module/rtl8192ce/parameters
    /sys/module/rtl8192ce/parameters/ips:Y
    /sys/module/rtl8192ce/parameters/fwlps:N
    /sys/module/rtl8192ce/parameters/swenc:N
    /sys/module/rtl8192ce/parameters/swlps:N
    So I guess I just have to see if it disconnects now. I'll let you know. Thanks!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •