Results 1 to 5 of 5

Thread: [ubuntu] Can't properly boot Ubuntu after modifying grub file

  1. #1
    Join Date
    Oct 2013
    Beans
    11

    [ubuntu] Can't properly boot Ubuntu after modifying grub file

    I can reach the grub menu (I think that's what it's called) (I run a Windows7/Ubuntu 12.04 Dual boot), but after I select Ubuntu, I get stuck at a purple screen. I was following these instructions:

    for all you novices like me i will try to give you a step by step
    open your console (for kde, go to start button >systems> terminal)
    $ type "gksudo dolphin"
    or type "gksudo nautilus"
    this command brings up your default file explorer. you will be prompted for your admin password.

    once password is entered the explorer windows will come up. go to /etc/default/ open file called grub. it will be automatically opened in an editor
    find the line
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
    change it to

    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nomodeset i8042.nomux

    save the file and close
    on terminal, type sudo update-grub
    then reboot
    Except I forgot to add in the i8042.nomux part, and now I can't boot into Ubuntu. Help on how I can be able to dim my screen or how to modify the grub file back to what it originally was please?

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    8,098
    Distro
    Ubuntu Development Release

    Re: [ubuntu] Can't properly boot Ubuntu after modifying grub file

    1) At the Grub boot menu select Recovery mode.
    2) At the Recovery menu select network. That will establish a network connection using the existing configuration files. It will also put the file system into read/write mode, which is needed if we are to edit a system file.
    3) When back at the Recovery menu select root. That will get you to a command prompt. Run

    Code:
     nano /etc/default/grub
    That should open an editor called nano and place the grub file in its editing window. There will be some instructions in using Ctrl+W to writeout (save) and Ctrl+X to exit or something like that. I am writing from memory. Check for yourself.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    Oct 2013
    Beans
    11

    Re: [ubuntu] Can't properly boot Ubuntu after modifying grub file

    Hi grahammechemical, thanks for the reply.

    Unfortunately, I am unable to get into recovery mode. I can't get past the black screen that spits out a bunch of text telling you what is being loaded or what Ubuntu is trying to process. I think I am getting a udevd error related to my graphics card. What can I do now?

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: [ubuntu] Can't properly boot Ubuntu after modifying grub file

    If you get grub menu, on Ubuntu entry press e for edit and scroll to Linux line. You can then add your entries next to or inplace of splash quiet. This is a one time change to test boot parameters or let you boot. Then you can make it permanent if boot parameters work by editing /etc/default/grub.

    How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions
    Info on other boot parameters
    http://www.kernel.org/doc/Documentat...parameters.txt
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #5
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [ubuntu] Can't properly boot Ubuntu after modifying grub file

    Quote Originally Posted by FDRmz4Y View Post
    I was following these instructions:
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
    change it to

    GRUB_CMDLINE_LINUX_DEFAULT=quiet splash nomodeset i8042.nomux
    If the instructions are copy-pasted and not a typo on your part here, then the closing double-quote is missing after i8042.nomux. That maybe what is causing it to stuck. Besides what oldfred suggested (and he's the best person for help on these), you can boot with a live cd/usb and correct that. To be extra sure, just copy-paste the existing double-quotes, instead of typing them (some keyboard layouts type a non-acceptable type of double-quote which gives errors later).

    For screen dimming issue, you should start a new thread. Different threads for different topics is a general rule of thumb for getting and offering best kind of help.
    As a quick shot, you may try (without quotes) "acpi_osi=" boot option (see here for details). If that doesn't help, start a new thread and post back the details of the problem, as well as the output of command suggested in this post, might get you quicker help.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •