Results 1 to 7 of 7

Thread: Mythfilldatabase not updating schedule information

  1. #1
    Join Date
    Jan 2010
    Beans
    54

    Mythfilldatabase not updating schedule information

    After I upgraded - using the Mythbuntu Control Center - from 0.25 to 0.26, I started getting this message & I notice that the schedule information is not being updated.

    I see this message when I look at mythweb or the system status in the front end.

    "mythfilldatabase ran, but did not insert any new data into the Guide for 1 of 1 sources. This can indicate a potential grabber failure."

    When I run mythfilldatabase - even with the --dd-grab-all switch, I still have the same problem. It seems to download the information from schedulesdirect, then connects to the backend to insert the next scheduled run. I don't see any error messages.


    Any ideas?
    Where do I start to debug?

  2. #2
    Join Date
    Oct 2013
    Beans
    1

    Re: Mythfilldatabase not updating schedule information

    Same problem over here except upgrading process. I did a fresh install with the latest ISO then I upgraded to 0.27.
    First mythfilldatabase did work, all others did not insert any data in the DB. I get the same message as cedyathome. "mythfilldatabase run ... failure"

  3. #3
    Join Date
    Jan 2010
    Beans
    54

    Re: Mythfilldatabase not updating schedule information

    This thread is the nearest to my issue that I've found. (Don't know how I missed it earlier)
    http://ubuntuforums.org/showthread.p...thfilldatabase

    I did a reboot and now, while I still see the error, I have 14 days of schedule data. Previously, it was only 11 days. Let's see if it runs without error tomorrow or at least keeps the data updated.

  4. #4
    Join Date
    May 2008
    Beans
    102

    Re: Mythfilldatabase not updating schedule information

    I've done several resets and power cycles none of which have helped.

  5. #5
    Join Date
    May 2006
    Beans
    35

    Re: Mythfilldatabase not updating schedule information

    I was having a similar problem with mythfilldatabase not running automatically. Running it manually in a terminal window always worked. In order to troubleshoot the problem, I added a line via mythtv-setup to log errors... but I never had to check the log, because (or coincidentally?) once I added the line to log errors, mythfilldatabase started running automatically with no errors.

  6. #6
    Join Date
    May 2008
    Beans
    102

    Re: Mythfilldatabase not updating schedule information

    Quote Originally Posted by ceenvee703 View Post
    I was having a similar problem with mythfilldatabase not running automatically. Running it manually in a terminal window always worked. In order to troubleshoot the problem, I added a line via mythtv-setup to log errors... but I never had to check the log, because (or coincidentally?) once I added the line to log errors, mythfilldatabase started running automatically with no errors.

    What line did you add and where did you added it?

  7. #7
    Join Date
    Dec 2013
    Beans
    5

    Re: Mythfilldatabase not updating schedule information

    I have had that error pop up when I ran mythfilldatabase and the grabber got data, but there was no NEW data...that is, there were no changes in the guide data. mythfilldatabase threw the error, but nothing actually failed...but programmatically it looked like something went wrong. In fact it was just an unnecessary guide pull.

    Could that be what you are seeing?

    --Dave

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •