Results 1 to 8 of 8

Thread: mod_security 2.6.0 on Ubuntu 12.04 LTS?

  1. #1
    Join Date
    May 2013
    Beans
    10

    mod_security 2.6.0 on Ubuntu 12.04 LTS?

    Is there a way to use mod_security 2.6.0 with 12.04 LTS (via apt)? It seems it installs 2.5.11, there's functions in 2.6.0 which are required for the ruleset I'm using.

    Thanks

  2. #2
    Join Date
    Nov 2008
    Location
    Kingdom of cookies
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: mod_security 2.6.0 on Ubuntu 12.04 LTS?

    Mod_Security is at 2.6.3 (http://packages.ubuntu.com/search?ke...se&section=all)

    You can download the latest core rules at https://www.owasp.org/index.php/Cate...t#tab=Download
    Ubuntu Forums Moderation Staff || SandyDNET
    Twitter: @CatchesAStar | Last.fm
    Ubuntu Membership via Forum Contributions

  3. #3
    Join Date
    May 2013
    Beans
    10

    Re: mod_security 2.6.0 on Ubuntu 12.04 LTS?

    Quote Originally Posted by sandyd View Post
    Thanks, how do I get 2.6.3? When I installed it via apt-get last night, it gave me

    ii libapache-mod-security 2.5.11-1ubuntu0.1 Tighten web applications security for Apache
    ii mod-security-common 2.5.11-1ubuntu0.1 Tighten web applications security - common files

    Running 10.04.4 LTS

  4. #4
    Join Date
    Nov 2008
    Location
    Kingdom of cookies
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: mod_security 2.6.0 on Ubuntu 12.04 LTS?

    Quote Originally Posted by optize View Post
    Thanks, how do I get 2.6.3? When I installed it via apt-get last night, it gave me

    ii libapache-mod-security 2.5.11-1ubuntu0.1 Tighten web applications security for Apache
    ii mod-security-common 2.5.11-1ubuntu0.1 Tighten web applications security - common files

    Running 10.04.4 LTS
    You wrote 12.04 LTS in your first post, and now 10.04 - which one are you using?

    You will have to upgrade or manually backport libapache2-mod-security if you are using 10.04
    Ubuntu Forums Moderation Staff || SandyDNET
    Twitter: @CatchesAStar | Last.fm
    Ubuntu Membership via Forum Contributions

  5. #5
    Join Date
    May 2013
    Beans
    10

    Re: mod_security 2.6.0 on Ubuntu 12.04 LTS?

    Quote Originally Posted by sandyd View Post
    You wrote 12.04 LTS in your first post, and now 10.04 - which one are you using?

    You will have to upgrade or manually backport libapache2-mod-security if you are using 10.04

    12.04, sorry.

  6. #6
    Join Date
    Nov 2008
    Location
    Kingdom of cookies
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: mod_security 2.6.0 on Ubuntu 12.04 LTS?

    can you post the output of
    Code:
    lsb_release -a
    Thanks.
    Ubuntu Forums Moderation Staff || SandyDNET
    Twitter: @CatchesAStar | Last.fm
    Ubuntu Membership via Forum Contributions

  7. #7
    Join Date
    May 2013
    Beans
    10

    Re: mod_security 2.6.0 on Ubuntu 12.04 LTS?

    # lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 12.04 LTS
    Release: 12.04
    Codename: precise

  8. #8
    Join Date
    May 2013
    Beans
    10

    Re: mod_security 2.6.0 on Ubuntu 12.04 LTS?

    Ah, I think I see the problem.

    I was installing libapache-mod-security, libapache2-mod-security has 2.6.x.

    Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •