Results 1 to 7 of 7

Thread: Some applications not using selected theme.

  1. #1
    Join Date
    Feb 2013
    Location
    UK, West Yorkshire
    Beans
    62
    Distro
    Xubuntu 14.04 Trusty Tahr

    Some applications not using selected theme.

    Hi,
    I installed Lubuntu 13.04 and then decided I wanted to use openbox over the top of it.

    I found that all of the applications I used in LXDE did not appear as they did in openbox. I found that I could change the gtk icon theme by adding the line:
    Code:
    gtk-icon-theme-name = "zoncolorGreyDark"
    to the file: .gtkrc-2.0
    I was also able to set the theme using
    Code:
    gtk-chtheme

    That solved the problem, except for the Ubuntu Software Centre, update-manager and the Synaptic package manager.

    Screenshots:
    Ubuntu Software Centre: http://postimg.org/image/nl8h1j9y9/
    update-manager: http://postimg.org/image/ya9ranm3d/
    Synaptic Package Manager: http://postimg.org/image/ncl73vonr/

    How can I resolve this? I'm assuming there is another config file somewhere where I need to set the theme and icon again.

    Thanks and any suggestions are welcome.

  2. #2
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,668
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Some applications not using selected theme.

    http://ubuntuforums.org/showthread.php?t=2173126 has something on the topic. I don't know about "Ubuntu Software Center". It's not installed by default on Lubuntu 13.04.
    de gustibus et coloribus non est disputandum -- Wiktionary

  3. #3
    Join Date
    Feb 2013
    Location
    UK, West Yorkshire
    Beans
    62
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Some applications not using selected theme.

    Quote Originally Posted by vasa1 View Post
    http://ubuntuforums.org/showthread.php?t=2173126 has something on the topic. I don't know about "Ubuntu Software Center". It's not installed by default on Lubuntu 13.04.
    I've tried adding the extra lines to the settings.ini file (I had to create this file myself and then add the lines) but upon exiting and restarting openbox, there is no difference whatsoever.

    Thanks for referencing me that link.

  4. #4
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,668
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Some applications not using selected theme.

    Quote Originally Posted by sudo san View Post
    I've tried adding the extra lines to the settings.ini file (I had to create this file myself and then add the lines) but upon exiting and restarting openbox, there is no difference whatsoever.

    Thanks for referencing me that link.
    Could you please provide the full path to the settings.ini file you created?

    The applications you're having problems with, Synaptic & Software Center, are the ones that need "administrative privileges". See what you have in /etc/gtk-3.0/settings.ini.

    Mine looks like this:
    Code:
    [Settings]
    gtk-theme-name = MyGreybird
    gtk-icon-theme-name = NoInherits
    gtk-fallback-icon-theme = gnome
    Where MyGreybird is what has to be entered because my gtk theme is ~/.themes/MyGreybird and NoInherits is my icon theme in ~/.icons/NoInherits.

    For reasons I don't fully understand, the full paths shouldn't be used. So, you'd replace MyGreybird and NoInherits with whatever your gtk and icon themes are called. Maybe a log out and log in will be needed to get the changes to take effect.
    de gustibus et coloribus non est disputandum -- Wiktionary

  5. #5
    Join Date
    Feb 2013
    Location
    UK, West Yorkshire
    Beans
    62
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Some applications not using selected theme.

    Quote Originally Posted by vasa1 View Post
    Could you please provide the full path to the settings.ini file you created?

    The applications you're having problems with, Synaptic & Software Center, are the ones that need "administrative privileges". See what you have in /etc/gtk-3.0/settings.ini.

    Mine looks like this:
    Code:
    [Settings]
    gtk-theme-name = MyGreybird
    gtk-icon-theme-name = NoInherits
    gtk-fallback-icon-theme = gnome
    Where MyGreybird is what has to be entered because my gtk theme is ~/.themes/MyGreybird and NoInherits is my icon theme in ~/.icons/NoInherits.

    For reasons I don't fully understand, the full paths shouldn't be used. So, you'd replace MyGreybird and NoInherits with whatever your gtk and icon themes are called. Maybe a log out and log in will be needed to get the changes to take effect.
    I can report that editing/etc/gtk-3.0/settings.ini successfully solved the problem on all applications that did not use the themes. This also worked on Audacious, but I forgot to mention it in the first post. This little fix is going into my openbox toolbox.

    Thanks for all the help!
    Last edited by sudo san; October 10th, 2013 at 03:58 PM.

  6. #6
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,668
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Some applications not using selected theme.

    Quote Originally Posted by sudo san View Post
    I can report that editing /etc/gtk-3.0/settings.ini successfully solved the problem on all applications that did not use the themes. This also worked on Audacious, but I forgot to mention it in the first post. This little fix is going into my openbox toolbox.

    Thanks for all the help!
    Don't you mean gtk-3.0?
    You are most welcome. People using the Openbox session in Lubuntu seem quite few (or quite silent). If you have some tips or advice, do share!
    de gustibus et coloribus non est disputandum -- Wiktionary

  7. #7
    Join Date
    Feb 2013
    Location
    UK, West Yorkshire
    Beans
    62
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Some applications not using selected theme.

    Quote Originally Posted by vasa1 View Post
    Don't you mean gtk-3.0?
    You are most welcome. People using the Openbox session in Lubuntu seem quite few (or quite silent). If you have some tips or advice, do share!
    Ah, yes I did mean that and I will change that so others that may not get confused and can also be helped too!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •