Results 1 to 4 of 4

Thread: How to disable a key

  1. #1
    Join Date
    Oct 2011
    Beans
    9

    Question How to disable a key

    Okay so I am having an issue with my keyboard on my laptop, it's going faulty, there is a certain that is constantly being pressed and at first using xmodmap has helped, but it seems as if the issue is still going on. I have come to the understanding it was whatever key keycode 112 is, which for me appears to be pageup - even though when I right click the highlighted menu goes down. So I used
    Code:
    xmodmap -e 'keycode 112='
    and the issue continued, so I did the following -again- to find out what was wrong;
    Code:
    xev
    and recieved this output
    Code:
     KeyPress event, serial 80, synthetic NO, window 0x5000001,     root 0x262, subw 0x0, time 118525837, (-208,178), root:(1031,685),     state 0x10, keycode 112 (keysym 0x0, NoSymbol), same_screen YES,     XLookupString gives 0 bytes:      XmbLookupString gives 0 bytes:      XFilterEvent returns: False
    I have no idea why it constantly is doing this, maybe it is actually that the key is stuck (even though I removed the key itself and tried to clean it) but if I removed what it should do than I don't know how it's still interacting with me, maybe someone can enlighten me on this situation. thanks in advance~
    Last edited by ex1t; October 15th, 2013 at 11:32 PM. Reason: solved~

  2. #2
    Join Date
    Jul 2008
    Location
    Canada
    Beans
    545
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to disable a key

    Try
    Code:
    xmodmap -e "keycode 112 = 0x0000"
    Last edited by Vakman; October 13th, 2013 at 02:30 AM. Reason: Typo.

  3. #3
    Join Date
    Oct 2011
    Beans
    9

    Re: How to disable a key

    Quote Originally Posted by Vakman View Post
    Try
    Code:
    xmodmap -e "keycode 121 = 0x0000"
    I used this (but keycode 112 instead lol) and so far for the past 3 hours, I have had no issues. Really got my idea that this may of been the more proper way that I should of followed. Thanks, hopefully it will work continuously, I will update this thread with an edit later on to say if it has fully fixed the issue I have had.

    Thanks again;

    ps : Ubuntu fixed my computer a ton, Windows was destroying it. So, big ups to the devs, thanks a ton. :)


    Edit: This has been the successful fix for the entire issue, has been a good amount of time since doing that with no rebooting or anything else, and my problem has been solved. :) Thanks for letting me know how to use xmodmap properly lol
    Last edited by ex1t; October 4th, 2013 at 03:06 AM. Reason: Updating

  4. #4
    Join Date
    Jul 2008
    Location
    Canada
    Beans
    545
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to disable a key

    Haha, no worries, sorry about the typo but glad you noticed it.
    Mark thread as solved

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •