Results 1 to 6 of 6

Thread: [12.04, 64bit] Wireless not working on a Toshiba Satellite L650-1JT

  1. #1
    Join Date
    Aug 2008
    Beans
    151
    Distro
    Xubuntu

    [12.04, 64bit] Wireless not working on a Toshiba Satellite L650-1JT

    Hello everyone!

    Recently, I've convinced my SO that switching to Ubuntu would be a good idea, given that she was fed up with Windows. She had already tried it under Wubi, and everything went smooth. However, this time around, the OS doesn't seem to believe she has a wireless card. It worked a few times, and if she reboots it 5 or 6 times, it will eventually work. I suspected the hardware button was to blame, but there is no option on the BIOS to enable wireless, and the key combination (Fn+F8) doesn't seem to do anything.

    I have been googling for a few hours, to no avail. All the commands I tried that listed hardware didn't list any wireless hardware, and the "activate wireless" text doesn't appear on network manager. Personally, it sounds like a driver issue, but I really can't tell, since it seems to work intermittently.

    I have the machine nearby, in case you guys need me to run any commands.

    So, any suggestions?
    Maybe I should surrender and do a 32bit install?

    Thanks a lot in advance!

    (PS: the laptop is this one.)

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    10,554
    Distro
    Lubuntu 15.04 Vivid Vervet

    Re: [12.04, 64bit] Wireless not working on a Toshiba Satellite L650-1JT

    Please run
    Code:
    sudo lshw -sanitize > lshw.txt
    and post lshw.txt in CODE tags.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  3. #3
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [12.04, 64bit] Wireless not working on a Toshiba Satellite L650-1JT

    Quote Originally Posted by Gonz_91 View Post
    Maybe I should surrender and do a 32bit install?
    It is quite unlikely that it will make it any better. I don't have anything to back it up, but I've been "feeling" lately that some drivers even work better in 64 bit version (or in other words, 32 bit doesn't work as good in *some* drivers).

    Apart from what mrgs asked, please also post the outputs of -
    Code:
    uname -mr
    lsb_release -d
    lspci -nnk | grep -iA2 net
    lsmod
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  4. #4
    Join Date
    Aug 2008
    Beans
    151
    Distro
    Xubuntu

    Re: [12.04, 64bit] Wireless not working on a Toshiba Satellite L650-1JT

    Hello mrgs, varunendra,

    Thank you both very very much for your replies and attention. I'm terribly sorry for taking such a long time to reply, but free time has been very scarce, and I didn't want to bump this thread up without having the info you guys requested.

    I am writing this from the aforementioned machine (my girlfriend's laptop) and, for some mysterious reason, everything seems to be working. Last week I couldn't get it to recognize the fact that it had wireless, even after 5 or 6 reboots and now, after sitting practically untouched for a week, everything seems to be working.

    I can still post the outputs you guys requested, but I doubt they'll be of any help, since the problem seems to have gone away.

    I've updated everything through apt-get update && apt-get upgrade, hoping that it was some hiccup in a driver that was later solved. Also, I rebooted several times before the updates, trying to reproduce the fault, but everything worked fine even after 4 reboots. I must confess: I'm at a loss, here.

    Finally, what do you guys think I should do with this thread? The problem is solved, apparently, but the solution isn't presented here, so I don't think marking it as solved would be a good idea. I'd delete it, but fear the problem may reappear.

    Thanks a lot for your help!

  5. #5
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [12.04, 64bit] Wireless not working on a Toshiba Satellite L650-1JT

    I'd recommend to post back the outputs anyway. Maybe it turns out to be something with a known bug that might have got fixed in the recent updates. If not, we maybe able to predict most common causes for the problem, if there ARE some known ones.

    And if you don't post back any problems with it again, I hope we can safely assume the 'Solution' was an update..
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  6. #6
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    10,554
    Distro
    Lubuntu 15.04 Vivid Vervet

    Re: [12.04, 64bit] Wireless not working on a Toshiba Satellite L650-1JT

    Please mark it 'solved', so people who might be offering help do not have to read through the thread.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •