Hi,
I can't install logisim 2.7.1, which I need to use for a computer architecture class I am taking. I looked in the software center and tried the apt-get thing but might not have used it correctly. I am new to ubuntu but I did install updates and a c++ compiler through apt-get. I am using Ubuntu 12.04 LTS on a laptop that was installed using a windows installer. Can someone tell me step by step how to install this program called Logisim?

Thanks
David