Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Movie player does not work : Package dependencies cannot be resolved

  1. #1
    Join Date
    Sep 2013
    Beans
    6

    Movie player does not work : Package dependencies cannot be resolved

    Hi guys - I'm fairly new to this ubuntu malarkey but here's to hoping someone can help.

    My movie player does not work, and when I try to get the session installer to update the relevant packages it comes up with an error stating that "package dependencies cannot be resolved" and then a whole load of detail that goes like this

    The following packages have unmet dependencies:

    gstreamer0.10-plugins-ugly: Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.4 is to be installed
    Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
    Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed
    Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.35.2) but 0.10.36-1ubuntu0.1 is to be installed
    Depends: libgstreamer0.10-0 (>= 0.10.35.2) but 0.10.36-1ubuntu1 is to be installed
    Depends: libmad0 (>= 0.15.1b-3) but 0.15.1b-7ubuntu1 is to be installed
    Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
    Depends: libstdc++6 (>= 4.1.1) but 4.6.3-1ubuntu5 is to be installed
    gstreamer0.10-plugins-ugly:i386: Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.4 is to be installed
    Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
    Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed
    Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.35.2) but 0.10.36-1ubuntu0.1 is to be installed
    Depends: libgstreamer0.10-0 (>= 0.10.35.2) but 0.10.36-1ubuntu1 is to be installed
    Depends: libmad0 (>= 0.15.1b-3) but 0.15.1b-7ubuntu1 is to be installed
    Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
    Depends: libstdc++6 (>= 4.1.1) but 4.6.3-1ubuntu5 is to be installed


    Any suggestions?

    Much appreciated

    Davie

  2. #2
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    5,003

    Re: Movie player does not work : Package dependencies cannot be resolved

    gstreamer0.10-plugins-ugly: Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.4 is to be installed
    The version 2.15 is a 12.04 package and the requested package (2.7) is a 13.04 package. Which Ubuntu version are you running?

    http://packages.ubuntu.com/precise/libc6

  3. #3
    Join Date
    Sep 2013
    Beans
    6

    Re: Movie player does not work : Package dependencies cannot be resolved

    12.04. Would it be easier if I updated to 13.04?

  4. #4
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    5,003

    Re: Movie player does not work : Package dependencies cannot be resolved

    Quote Originally Posted by davie1994 View Post
    12.04. Would it be easier if I updated to 13.04?
    A lot of good things are being said about 13.04. If it was me, I think I move on, but remember 12.04 is supported till 2017 and 13.04 support ends in a few months. You will have to upgrade every 6 months or so.

    Also, I have full backup. So if things goes bad, I can restore. Can you?

  5. #5
    Join Date
    Sep 2013
    Beans
    6

    Re: Movie player does not work : Package dependencies cannot be resolved

    Got a back up for current system on a DVD drive. I assume that's adequate

  6. #6
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    5,003

    Re: Movie player does not work : Package dependencies cannot be resolved

    Quote Originally Posted by davie1994 View Post
    Got a back up for current system on a DVD drive. I assume that's adequate
    If your happy with it, so am I

    You have to upgrade to 12.10 first. Then 13.04.

    GUI
    http://www.ubuntu.com/download/desktop/upgrade

    In terminal
    https://help.ubuntu.com/lts/servergu...upgrading.html

    and
    https://help.ubuntu.com/community/QuantalUpgrades

  7. #7

    Re: Movie player does not work : Package dependencies cannot be resolved

    Quote Originally Posted by ibjsb4 View Post
    The version 2.15 is a 12.04 package and the requested package (2.7) is a 13.04 package. Which Ubuntu version are you running?

    http://packages.ubuntu.com/precise/libc6
    That is/was not the issue, more likely the Op hasn't updated his sources, doesn't currently have 'updates' enabled & or has some proposed packages or ppa installed.

    The version of libc6 in 13.04 is 2.17, not 2.7 which is from ages ago ( & the apt line was just >= 2.7 which 2.15-0ubuntu10.4 certainly qualifies, 2.15-0ubuntu10.4 is from precise-updates

  8. #8
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    11,304
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Movie player does not work : Package dependencies cannot be resolved

    If I were you, I'd install SMPlayer instead: "sudo apt-get install smplayer".
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  9. #9
    Join Date
    Jan 2009
    Location
    Belgium (Ghent)
    Beans
    481
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Movie player does not work : Package dependencies cannot be resolved

    Dutch speaking; understand English, writing is a bit difficult. Member of: http://forum.ubuntu-nl.org
    be Open be Free be Ubuntu Reg. User #485479
    Ubuntu 13.10 Saucy Salamander - Ubuntu 14.04 Trusty Tahr

  10. #10
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    5,003

    Re: Movie player does not work : Package dependencies cannot be resolved

    Quote Originally Posted by mc4man View Post
    The version of libc6 in 13.04 is 2.17, not 2.7 which is from ages ago ( & the apt line was just >= 2.7 which 2.15-0ubuntu10.4 certainly qualifies, 2.15-0ubuntu10.4 is from precise-updates
    Right you are, I misread it. But methinks the op is now running 13.04

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •