Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: transparent menus / panels

  1. #1
    Join Date
    Sep 2013
    Beans
    20

    transparent menus / panels

    Hey all,

    I'm trying for 3 hours to set my upper panel to a transparent design.
    With Ubuntu itself I can only set the panel to transparent, the menu buttons
    are still grey (Applications, Sound, Bluetooth, WLan etc.)

    I already searched with google for a solution and I found a application
    called 'CompizConfig' and tried to use it but as much as I try there is no
    change at the design.

    Do you have any idea what's wrong? It should be possible to set the menu to a transparent
    design, or not? Which apps are needed for it?

    Friendly regards
    Timo

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    6,923
    Distro
    Ubuntu Development Release

    Re: transparent menus / panels

    As far as I know the colour of the app indicators in top panel are a function of the theme. That also applies to the background colour of the app indicator menus. For example, If we use the Radiance theme then the colour of the app indicator icons and the characters on their menus have a dark look. Whereas, if we use the Ambience theme (default) the app indicators and the characters on the menus have a light look.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    Sep 2013
    Beans
    20

    Re: transparent menus / panels

    Hey,

    After... I think 5 hours of searching I got Compiz working, after logging off,
    Compiz stopped working again.

    At first I used this command:
    compiz --replace

    And then this one:
    gtk-window-decorator --replace

    Do you know why Compiz is not starting - Or why my compiz settings
    does not have any effect without using this commands?

    //edit:
    After using compiz --replace I get this errors:
    Setting Update "opacity_step"
    Setting Update "opacity_matches"
    Setting Update "opacity_values"
    Starting gtk-window-decorator
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    compiz (decor) - Warn: No default decoration found, placement will not be correct
    I only changed some settings in the opacity options.

    - Timo
    Last edited by timo2; September 27th, 2013 at 07:57 AM.

  4. #4
    Join Date
    Oct 2008
    Beans
    3,509

    Re: transparent menus / panels

    What ubuntu release are you running?
    What desktop are you logging into?

    This terminal command will show your current logged in session...
    Code:
    echo $DESKTOP_SESSION

  5. #5
    Join Date
    Sep 2013
    Beans
    20

    Re: transparent menus / panels

    Hey,

    I got this info:
    gnome-fallback
    - Timo

  6. #6
    Join Date
    Oct 2008
    Beans
    3,509

    Re: transparent menus / panels

    Quote Originally Posted by timo2 View Post
    Hey,

    I got this info:
    gnome-fallback

    - Timo
    ...and the release....
    Code:
    cat /etc/lsb-release
    Are you logging into the ubuntu session at the login screen but being dropped back to the gnome-fallback session.
    The ubuntu session runs compiz as the window manager. The Unity interface is a plugin for compiz.

    If your gfx card is incompatible with a 3d driver, you cannot run compiz/unity.

    Test gfx compatibilty for running unity....
    Code:
    /usr/lib/nux/unity_support_test -p
    eg my output...
    Code:
    glen@Raring:~$ /usr/lib/nux/unity_support_test -p
    OpenGL vendor string:   NVIDIA Corporation
    OpenGL renderer string: GeForce GTX 550 Ti/PCIe/SSE2
    OpenGL version string:  4.3.0 NVIDIA 313.30
    
    Not software rendered:    yes
    Not blacklisted:          yes
    GLX fbconfig:             yes
    GLX texture from pixmap:  yes
    GL npot or rect textures: yes
    GL vertex program:        yes
    GL fragment program:      yes
    GL vertex buffer object:  yes
    GL framebuffer object:    yes
    GL version is 1.4+:       yes
    
    Unity 3D supported:       yes
    Also install a small application to tell you which window manager is running...
    Code:
    sudo apt-get install wmctrl
    This terminal command will tell you your current window manager...
    Code:
    wmctrl -m
    eg my output when in the ubuntu/unity session...
    Code:
    glen@Raring:~$ wmctrl -m
    Name: Compiz
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: OFF
    If your window manager is not Compiz, compizconfig-settings-manager(ccsm) will not have any effect.

    In the ubuntu session you can make the unity panel and menus transparent using ccsm...
    162.jpg

    but in the gnome-fallback session the gnome-panel is used and certain areas remain opaque as stated by grahammechanical.
    163.jpg
    Last edited by stinkeye; September 29th, 2013 at 07:24 AM.

  7. #7
    Join Date
    Sep 2013
    Beans
    20

    Re: transparent menus / panels

    The Release Info:
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04.3 LTS"
    Graphics infos:
    timo@timo-satellite:~$ /usr/lib/nux/unity_support_test -p
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: AMD Radeon HD 7640G
    OpenGL version string: 4.2.12217 Compatibility Profile Context 12.104

    Not software rendered: yes
    Not blacklisted: yes
    GLX fbconfig: yes
    GLX texture from pixmap: yes
    GL npot or rect textures: yes
    GL vertex program: yes
    GL fragment program: yes
    GL vertex buffer object: yes
    GL framebuffer object: yes
    GL version is 1.4+: yes

    Unity 3D supported: yes
    My window manager is Metacity...
    timo@timo-satellite:~$ wmctrl -m
    Name: Metacity
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: N/A

    How can I set it to Compiz? I'm not using Unity, I'm using gnome <3

    - Timo

  8. #8
    Join Date
    Oct 2008
    Beans
    3,509

    Re: transparent menus / panels

    Quote Originally Posted by timo2 View Post
    The Release Info:


    Graphics infos:


    My window manager is Metacity...



    How can I set it to Compiz? I'm not using Unity, I'm using gnome <3

    - Timo
    Try setting compiz back to defaults and then replacing metacity with compiz.
    In terminal...
    Code:
    gconftool --recursive-unset /apps/compiz-1
    then...
    Code:
    compiz --replace && disown
    If the unity interface appears use ccsm to disable it.

    PS compiz runs a lot better on 13.04 and if you install gnome-panel
    you will have 2 extra login sessions...
    • gnome-classic(no effects)....uses metacity
    • gnome-classic.......uses compiz


    Both sessions use the old style gnome-panel.

    Are you able to login to the unity session running compiz?
    Last edited by stinkeye; September 30th, 2013 at 08:00 AM.

  9. #9
    Join Date
    Sep 2013
    Beans
    20

    Re: transparent menus / panels

    I used your commands, still Metacity

    //edit:
    When I use 'compiz --replace', Compiz is starting BUT: I don't have any menu panels
    for closing the windows anymore ^^
    Last edited by timo2; September 30th, 2013 at 08:04 AM.

  10. #10
    Join Date
    Oct 2008
    Beans
    3,509

    Re: transparent menus / panels

    Quote Originally Posted by timo2 View Post
    I used your commands, still Metacity
    Are you able to login to the unity session running compiz?

    The unity session can be changed to a gnome-classic session by disabling the unity plugin with ccsm and adding gnome-panel to startup applications
    Last edited by stinkeye; September 30th, 2013 at 08:08 AM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •