Results 1 to 5 of 5

Thread: Server troubleshooting help: [504] Gateway Timeout, was working server yesterday

  1. #1
    Join Date
    Mar 2008
    Beans
    13

    Server troubleshooting help: [504] Gateway Timeout, was working server yesterday

    Two days ago I had a functioning server at http://mashjournal.zapto.org, but on Monday unexplainably the server went down to the outside world. Trying to log in from outside my internal network yields a [504] Gateway Timeout. Pointing a browser to localhost when logged onto the server and pointing a browser at the server's local IP address when logged onto my home network leads to the site loading normally. I'm not sure where to start with troubleshooting this problem and so was hoping for some outside help. Is it the router that I should be checking, or somewhere else?

    Any help is much appreciated. Thanks for your time and consideration. I'm looking forward to hearing back.

  2. #2
    Join Date
    Mar 2008
    Beans
    13

    Re: Server troubleshooting help: [504] Gateway Timeout, was working server yesterday

    Just a quick update:
    This server domain is going through port forwarding, so http://theronmuller.zapto.org:8080/ points to: http://mashjournal.zapto.org/ The former address is working but the latter isn't. Perhaps this can help with troubleshooting?

    Thanks in advance for any help you may be able to offer.

  3. #3
    Join Date
    Aug 2005
    Location
    Amsterdam
    Beans
    52
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Server troubleshooting help: [504] Gateway Timeout, was working server yesterday

    This is an interesting setup. We will need to see the config files to understand more. How is one forwarding to the other, and the other proxying for the first?

    More info is needed

  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,928
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Server troubleshooting help: [504] Gateway Timeout, was working server yesterday

    Quote Originally Posted by theronmuller View Post
    Just a quick update:
    This server domain is going through port forwarding, so http://theronmuller.zapto.org:8080/ points to: http://mashjournal.zapto.org/
    Usually a port is forwarded to an IP/port combination, not a URL. On the router, does port 8080 forward back to port 80 on the machine that hosts mashjournal? If the forward actually uses a hostname rather than an IP, then does the name "mashjournal.zapto.org" point to the IP address of the server on which it is running? Perhaps a local DNS issue?

    Use IP addresses whenever possible for things like port forwards.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  5. #5
    Join Date
    Mar 2008
    Beans
    13

    Re: Server troubleshooting help: [504] Gateway Timeout, was working server yesterday

    Thanks for the comments. I'm using no-ip.com's domain management service because I'm running these servers on my home ISP, which issues a dynamically allocated IP address. Changing the configuration for mashjournal.zapto.org on no-ip.com to the server's IP address did the trick.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •