Results 1 to 7 of 7

Thread: BURG EFI signed entries don't work

  1. #1
    Join Date
    May 2009
    Location
    The Netherlands
    Beans
    35
    Distro
    Ubuntu 13.10 Saucy Salamander

    BURG EFI signed entries don't work

    Hi there,

    So I've installed BURG, a fancy grub-like bootloader with more eye candy, on my Ubuntu 13.04 x64 box now and it wants to boot an EFI boot entry by default. Every time it does so I get thrown kernel panics and my system doesn't boot. I have to manually select the "normal" one in order to boot successfully. Personally, I don't have any use for the EFI entries and I don know how I got even them. Is there any way to remove these entries for good, even after an "sudo update-burg"?

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: BURG EFI signed entries don't work

    I do not think burg has been maintained for quite a while. If you want a boot manager, you can try rEFInd, if booting with UEFI. If BIOS then something is installed incorrectly. Then try Boot-Repair and post link to BootInfo report.

    Alternative efi boot Manager for UEFI limited systems:
    https://wiki.archlinux.org/index.php...s#Using_rEFInd
    http://www.rodsbooks.com/refind/
    http://www.rodsbooks.com/efi-bootloaders/


    Post the link to the BootInfo report that this creates. Is part of Boot-Repair:
    https://help.ubuntu.com/community/Boot-Info
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    May 2009
    Location
    The Netherlands
    Beans
    35
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: BURG EFI signed entries don't work

    Thanks, but I actually don't need to boot with UEFI, I'm using regular BIOS. BootInfo report: http://paste.ubuntu.com/6144934/
    Last edited by Resilldoux; September 23rd, 2013 at 11:34 AM. Reason: typo

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: BURG EFI signed entries don't work

    I do not see anything wrong.

    You do have LVM on sda, but I do not know about that or if that confuses os-prober.
    Your Windows data partition on sdb has the hidden system reserved partition that Windows wants with UEFI installs. It may have just created it as it has to be before the first Windows install on gpt drives.

    If you have BIOS/CSM mode on in UEFI you should not get any UEFI boot. And you have no efi partitions for any boot loader or UEFI to see to implement UEFI boot.
    Last edited by oldfred; September 23rd, 2013 at 04:17 PM.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #5
    Join Date
    May 2009
    Location
    The Netherlands
    Beans
    35
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: BURG EFI signed entries don't work

    Yes, I use BIOS mode in UEFI, so I I would also presume I don't need the EFI entries. The problem is, my machine does seem to think so, irregardless. How can I help resolve this?

  6. #6
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: BURG EFI signed entries don't work

    Since it is a combined UEFI/BIOS system, your UEFI menu will always show some of both. But if you have only installed BIOS mode, that is all that should be shown to boot your system. You have no efi partition with efi boot files.


    But for example Ubuntu live installer offers both UEFI & BIOS mode, so your system should offer to boot either way.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  7. #7
    Join Date
    Jun 2014
    Beans
    1

    Re: BURG EFI signed entries don't work

    Remove efi.signed From Burg Menu


    • Navigate To Boot Directory
    • cd /boot
      • Enter Superuser Mode
      • sudo su (Enter Your Password)
        • Change The Name Of Following File:
        • mv vmlinuz-3.13.0-29-generic.efi.signed #vmlinuz-3.13.0-29-generic.efi.signed
          • Update burg (So Next Time You Boot Up The Option To Boot Up In The .efi.signed Will Not Show Up).
          • update-burg

    Your Burg Menu Should Be With Out This Option And When Folded Default Should Be The First Os Listed

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •