Results 1 to 3 of 3

Thread: Backspace not working properly when font format change

  1. #1
    Join Date
    Jun 2013
    Location
    Somewhere on Earth.
    Beans
    345
    Distro
    Ubuntu 13.10 Saucy Salamander

    Angry Backspace not working properly when font format change

    Hello all!

    Every time I need to change the format, I find it quite annoying that pressing backspace does not work properly.

    Examples:

    Quote Originally Posted by Original
    This text has no format This text is boldf
    Oops, spelling error!! Backspace results in:
    Quote Originally Posted by Result
    This text has no forma This text if boldf
    I have to re-write the "t" and use the arrow keys to go and fix the spelling error.
    Also happens when switching from no-format to italic, italic to no-format, bold to no-format, etc.
    Also happens when pressing the left key (| stands for the text-cursor):

    Quote Originally Posted by Original
    This text has no format This texct is bold|
    Oops, I have to go back and change something! Left key results in:
    Quote Originally Posted by Result
    This text has not forma|t This texct is bold
    PS. Same thing results in other computers.

    Why does this happen? Is this a bug?
    Last edited by Jonathan Precise; September 24th, 2013 at 04:31 PM. Reason: Remove signature

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Backspace not working properly when font format change

    If you are talking about editing problems with the forum message editor, then I would suggest switching to Source Mode or one of the non-WYSIWYG modes. I don't follow your description of the cursor problem, but not being able to see the BBCode for bold text (or other BBCode) can cause confusion when editing a post. I long ago abandoned the WYSIWYG editor as being more trouble than it's worth, and more likely to lead to the cursor problems you describe.

    Try one or both of two things:

    In the advanced editor click on the button top left of the editor toolbar that looks something like A/A to toggle between WYSIWYG and source mode. My guess is that you are using WYSIWYG. Source mode will let you see the BBCode. It doesn't preview how the text will look as you type but at least you get to see if you've put the cursor in the right place when you are editing, and you can use the preview post button to make sure your formatting looks OK. Or...

    Settings -> General Settings -> Message Editor Interface. I find "Standard Editor - Extra formatting controls" to be the most usable but personal preferences vary.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  3. #3
    Join Date
    Jun 2013
    Location
    Somewhere on Earth.
    Beans
    345
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Backspace not working properly when font format change

    Ok, Thank you!!!

    Marked as solved.
    I recommend a full ubuntu installation rather than a wubi install. Ask me why.
    To migrate from wubi, click here. (by bcbc)
    Status: Online
    https://help.ubuntu.com/community/UEFI, and Buggy UEFI solution.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •