Results 1 to 7 of 7

Thread: Qualcomm Atheros AR9462: Flaky Internet Ubuntu 12.04

  1. #1
    Join Date
    Sep 2013
    Beans
    3

    Qualcomm Atheros AR9462: Flaky Internet Ubuntu 12.04

    Hello! I have Ubuntu 12.04 dual booted with Windows 7. Each time I turn my laptop on it takes a few minutes to connect to the wifi, and the connection drops every couple minutes. I don't have these problems on my Windows 7 partition. I would be very grateful for any advice--I would love to continue using Ubuntu as my main OS but I've only been able to use Windows 7 because of this internet problem. Thank you so much in advance!!

  2. #2
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Flaky Internet Ubuntu 12.04

    Hi,, please post the output of..
    Code:
    lspci -nnk | grep -iA3 net
    thanks.
    Craving anchovy, herring and squid pizza.....with clam sauce

  3. #3
    Join Date
    Sep 2013
    Beans
    3

    Re: Flaky Internet Ubuntu 12.04

    01:00.0 Network controller [0280]: Qualcomm Atheros AR9462 Wireless Network Adap
    ter [168c:0034] (rev 01)
    Subsystem: Bigfoot Networks, Inc. Device [1a56: 2003]
    Kernel driver in use: ath9k
    Kernel modules: ath9k

  4. #4
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Flaky Internet Ubuntu 12.04

    Hi give this a try..
    Code:
    sudo modprobe -rfv ath9k
    sudo modprobe ath9k nohwcrypt=1
    *Don't boot and let it run for an hour or so...
    IF and only if, it stays connected then do..
    to make it permanent
    Code:
    sudo gedit /etc/modprobe.d/ath9k.conf
    enter one line of code.
    Code:
    options ath9k nohwcrypt=1
    save and close gedit...boot
    Last edited by Hadaka; September 20th, 2013 at 07:52 PM.
    Craving anchovy, herring and squid pizza.....with clam sauce

  5. #5
    Join Date
    Sep 2013
    Beans
    3

    Re: Flaky Internet Ubuntu 12.04

    I followed your instructions, but the problem persists. Please let me know if there is anything else I can try. Thanks for your time!

  6. #6
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Flaky Internet Ubuntu 12.04

    Hi, about the only other thing i can suggest is to
    set your router to wpa2 only (not mixed) and use channel 1 or 11
    not alot of options for the ath9k driver...sorry.
    Craving anchovy, herring and squid pizza.....with clam sauce

  7. #7
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Flaky Internet Ubuntu 12.04

    You may try compiling the latest backported version, it seems to work better : http://ubuntuforums.org/showthread.p...2#post12785322
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •