Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Overheating problem ( cannot solved )

  1. #1
    Join Date
    Sep 2013
    Beans
    7

    Overheating problem ( cannot solved )

    My laptop overheated very frequently after I installed Ubuntu based Operating System. My laptop started to cool down when I switch the proprietary drivers. Once I restarted everything went hairwire. I only able to see my desktop wallpaper ! I right clicked and select change wallpaper. The dialog box pop up and I noticed that the close, minimize and maximize buttons are missing ! This goes for all OS. The problem just improved slightly after I install another kernal. My laptop is warm for normal use, but it is extreamly hot when I watch videos.

    Is there any other solutions. I already tried everything. Changing the driver solved overheating issue but it makes everything went hairwire !

  2. #2
    Join Date
    Nov 2010
    Location
    /Earth/Asia/India
    Beans
    218
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Overheating problem ( cannot solved )

    The problem may be with your graphics drivers.
    Can you please specify your video card make ?

    To better define power consumption and battery usage you can use 'tlp'
    Its a console-based application that does a pretty neat job in managing power.
    See if it helps you
    Kids, you tried your best and you failed miserably. The lesson is, never try.
    -Homer Simpson

  3. #3
    Join Date
    Sep 2013
    Beans
    7

    Re: Overheating problem ( cannot solved )

    Please refer to the screenshot below. I select the second one and the heating problem solved, but once I restarted I only able to view my wallpaper. My laptop stil warm.


    So, I actually installed Jupuiter and cfkg ( sth like that ) to lower down my CPU by setting it in Power Saving Mode. I notice my laptop doesn't get as hot as I just installed Ubuntu but it still get hot as time passes by unlike I select the proprietary driver.

    I cannot figured out why I switched off my laptop, placed in a air conditioned room, 26 degree celcius. I switched it on back and the temperature reading is 50 ++ .

    I actually installed kernal but it didn't help much. The option that can greatly reduce the temperature ruin the whole system as I can see the wallpaper when I logged in once I started it up.

    Last edited by mörgæs; September 18th, 2013 at 06:16 PM. Reason: Please use standard font.

  4. #4
    Join Date
    Nov 2010
    Location
    /Earth/Asia/India
    Beans
    218
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Overheating problem ( cannot solved )

    Do you use Compiz ?
    Maybe Compiz is causing problem
    Kids, you tried your best and you failed miserably. The lesson is, never try.
    -Homer Simpson

  5. #5
    Join Date
    Sep 2008
    Location
    Chicago
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Overheating problem ( cannot solved )

    One thing you might try is installing Gnome 3 (download from USC) and then logout. On the Login screen, click on the Ubuntu logo and select Gnome Without Special Effects (this may not be the exact wording). My PC 's performance went up and temperature went down after doing this. On the other hand, maybe a pretty screen is more important to you than performance. That's why *nix offers choices.
    In working with *nix...There be dragons. Newcomers: I recommend reading Linux is Not Windows (http://linux.oneandoneis2.org/LNW.htm) and The Linux Command Line (http://www.linuxcommand.org/tlcl.php) before beginning your quest for a better OS.

  6. #6
    Join Date
    Jun 2007
    Beans
    11,122

    Re: Overheating problem ( cannot solved )

    Showing a screenshot may be leaving out important information (like if you also have an Intel GPU in a hybrid setup).
    Code:
    lspci | grep VGA

  7. #7
    Join Date
    Sep 2013
    Beans
    7

    Re: Overheating problem ( cannot solved )

    lspci | grep VGA

    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Seymour [Radeon HD 6400M/7400M Series]

    I cannot downl

  8. #8
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    443
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Overheating problem ( cannot solved )

    So it looks like you have hybrid graphics chips in your computer like me. The problem for me was solved by turning off the ATI graphics card and only using the intel integrated. The ATI graphics card is much faster and always on (making it very hot). If you're going to be doing intensive graphics work you might need to use the ATI gpu.
    For me the intel integrated graphics is more than enough so I only use that.

    There is the proprietary catalyst driver avaliable from AMD. Using that you can switch between the two cards to give you best performance or battery life. Personally I've had no success with it. I've tried everything, spent days on it. I have heard some success stories and last I tried them was more than a year ago so things might have changed. Personally I wouldn't bother with Catalyst and found it easier to just turn off the ATI card and be done with it.

    I suggest you completely remove the graphics drivers you installed before you go on and that you reboot after removing them. If you're not sure how to ask for help, I'm not to sure how to go about completely removing the ATI drivers but it shouldn't be that difficult.

    To check which graphics card is on and which is in use run:
    Code:
    sudo cat /sys/kernel/debug/vgaswitcheroo/switch
    You should see something like this:
    Code:
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Off:0000:01:00.0
    IGD is the Intel chip, the + means it's the one in use, and Pwr means it's on.
    DIS is the ATI card and if it says Off, you're laptop is going to be a LOT cooler. Plus your battery life should go up heaps.

    Now if the ATI card is On you can turn it off.
    First become root:
    Code:
    sudo -i
    Then in the same terminal run:
    Code:
    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    then:
    Code:
    exit
    You can check if it worked by running:
    Code:
    sudo cat /sys/kernel/debug/vgaswitcheroo/switch
    If it worked it will say:
    Code:
    0:DIS: :Off:0000:01:00.0
    1:IGD:+:Pwr:0000:00:02.0
    To make it permanent and last across reboots, add these to /etc/rc.local above the 'exit 0' line (e.g. sudo gedit /etc/rc.local from the terminal):
    Code:
    modprobe radeon
    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    And then add this to /etc/modprobe.d/blacklist-local.conf, also as sudo:
    Code:
    blacklist fglrx

    Big post phew hope that helps!
    Last edited by jonnyboysmithy; September 19th, 2013 at 03:01 AM.

  9. #9
    Join Date
    Sep 2013
    Beans
    7

    Re: Overheating problem ( cannot solved )

    Going to try it later

  10. #10
    Join Date
    Sep 2013
    Beans
    7

    Re: Overheating problem ( cannot solved )

    Quote Originally Posted by jonnyboysmithy View Post
    So it looks like you have hybrid graphics chips in your computer like me. The problem for me was solved by turning off the ATI graphics card and only using the intel integrated. The ATI graphics card is much faster and always on (making it very hot). If you're going to be doing intensive graphics work you might need to use the ATI gpu.
    For me the intel integrated graphics is more than enough so I only use that.

    There is the proprietary catalyst driver avaliable from AMD. Using that you can switch between the two cards to give you best performance or battery life. Personally I've had no success with it. I've tried everything, spent days on it. I have heard some success stories and last I tried them was more than a year ago so things might have changed. Personally I wouldn't bother with Catalyst and found it easier to just turn off the ATI card and be done with it.

    I suggest you completely remove the graphics drivers you installed before you go on and that you reboot after removing them. If you're not sure how to ask for help, I'm not to sure how to go about completely removing the ATI drivers but it shouldn't be that difficult.

    To check which graphics card is on and which is in use run:
    Code:
    sudo cat /sys/kernel/debug/vgaswitcheroo/switch
    You should see something like this:
    Code:
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Off:0000:01:00.0
    IGD is the Intel chip, the + means it's the one in use, and Pwr means it's on.
    DIS is the ATI card and if it says Off, you're laptop is going to be a LOT cooler. Plus your battery life should go up heaps.

    Now if the ATI card is On you can turn it off.
    First become root:
    Code:
    sudo -i
    Then in the same terminal run:
    Code:
    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    then:
    Code:
    exit
    You can check if it worked by running:
    Code:
    sudo cat /sys/kernel/debug/vgaswitcheroo/switch
    If it worked it will say:
    Code:
    0:DIS: :Off:0000:01:00.0
    1:IGD:+:Pwr:0000:00:02.0
    To make it permanent and last across reboots, add these to /etc/rc.local above the 'exit 0' line (e.g. sudo gedit /etc/rc.local from the terminal):
    Code:
    modprobe radeon
    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    And then add this to /etc/modprobe.d/blacklist-local.conf, also as sudo:
    Code:
    blacklist fglrx

    Big post phew hope that helps!

    How to do the last two steps ? It says no file or directory and command not found (blacklist) , Really worry I have to make the words bigger because of some ....



Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •