Results 1 to 3 of 3

Thread: Disabling touchpad

Hybrid View

  1. #1
    Join Date
    Sep 2013
    Beans
    5

    Disabling touchpad

    Is there any way to completely disable the touchpad on an Asus SonicMaster under Ubuntu 12.04?

    I have tried the "disable while typing option" but is only stays disabled until I accidentally brush against the touchpad and next time I look up, I find I have overtyped in some random area of the doc. I have been told that the correct solution is to learn to touch type, but I have never been able to do that. I also tried a piece of cardboard glued over the danger area but I am worried that might damage the screen when the lid is closed.

    Thanks in advance

  2. #2
    Join Date
    Aug 2011
    Beans
    327
    Distro
    Ubuntu 12.04 Precise Pangolin

  3. #3
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Disabling touchpad

    In versions where Touchpad Indicator works, fine

    Otherwise a simple way to disable the touchpad is to include a simple function in .bashrc and call it from a terminal window (I do it directly after login from an autostarted terminal window).

    So if you add the following lines at the end of your .bashrc file

    Code:
    alias TT='touchpad-toggle'
    
    ###
    
    function touchpad-toggle {
    
    # toggle synaptic touchpad on/off
    
    # get current state
    SYNSTATE=$(synclient -l | grep TouchpadOff | awk '{ print $3 }')
    
    # change to other state
    if [ $SYNSTATE = 0 ]; then
        synclient touchpadoff=1
        echo "touchpad OFF"
    elif [ $SYNSTATE = 1 ]; then
        synclient touchpadoff=0
        echo "touchpad ON"
    else
        echo "Couldn't get touchpad status from synclient"
        exit 1
    fi
    }
    
    ####
    
    alias TT
    You can easily toggle the touchpad on/off with the TT.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •